Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

why address refer to router and not private address of machine

Avatar of yccheok
yccheok asked on
NetworkingDNSNetworking Protocols
9 Comments1 Solution274 ViewsLast Modified:
i am running win xp behind a broadband->modem->router.

i setup up my IIS port TCP port to 1515.

my computer name is yccheok

when i type, "http://localhost:1515" in my web broswer, fine, it works!

when i type, "http://yccheok:1515" in my web broswer, fine, it works!

however, when i type, "" in my web broswer, OPPs, it does not works!

it will prompt out a dialog box requires me to enter username (with\admin as default) and password.

strange. it look like my broswer is dialing to the router. however, is not my router address. (my router address is

i run ipconfig and ping yccheok, they give me the result of following:

Windows IP Configuration

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . :
        IP Address. . . . . . . . . . . . :
        Subnet Mask . . . . . . . . . . . :
        Default Gateway . . . . . . . . . :

Pinging yccheok [] with 32 bytes of data:

Reply from bytes=32 time<1ms TTL=128
Reply from bytes=32 time<1ms TTL=128
Reply from bytes=32 time<1ms TTL=128
Reply from bytes=32 time<1ms TTL=128

Ping statistics for
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

it seems that is my private address. is my router address.

please note that i didnt use any port forwarding in my router. ya, i do use NAT in my router.

may i know how can i solve this problem by enable me to take to refer to the IIS server. not router.

thank you.

yan cheng
Avatar of modulo

Our community of experts have been thoroughly vetted for their expertise and industry experience.

This problem has been solved!
Unlock 1 Answer and 9 Comments.
See Answers