Solved

not able to connect to network

Posted on 2004-03-23
20
1,241 Views
Last Modified: 2010-03-18
I have have just set up a home network usning my xp as server.
I have 3 computers in my network including mine and used the same disk to setup all 3.
computers involved are xp , win 98 and me.
when i set up the network i followed the instruction and made sure all computers were on and set mine XP
up to be the server and for them to log on to mine. after I was done i am able to connect between the win98
and the me computer but i can not connect from my xp computer to see either the win98 or the me computer.

I get a msg when i want to see the work group

mshome is not ava. you might not have permission to use this network resourse. Contact the admin of this server to find out if you have access permissions.

the list of servers for this workgroup is not currently ava.

help thanks,  Greg

PS I am the administrator.
0
Comment
Question by:Greg54
  • 8
  • 6
  • 5
  • +1
20 Comments
 
LVL 11

Expert Comment

by:kabaam
ID: 10660951
ME and 98 are using Netbios names to communicate... XP looks for DNS naming
Enable NetBios over TCP/IP on the XP machine.
0
 
LVL 11

Expert Comment

by:kabaam
ID: 10660971
also check into the browser master services
http://support.microsoft.com/default.aspx?scid=kb;en-us;318030
HTH
CHAD
0
 
LVL 11

Expert Comment

by:kabaam
ID: 10661048
One more thing.   XP comes with an Internet connection firewall built-in.  It has been known to cause problems with small networks such as yours.  Disable it.
Also, many other firewall applications require configuration to allow local networking.  Disable any that you may have running to test if it is causing a problem.
0
 

Author Comment

by:Greg54
ID: 10661692
Nothing changed I still can't see workgroup
the changes I did.
xp firewall was no on
I turned of symantics firewall to test.
I read and followed the steps to microsoft
and changed txp/ip enabled it
and checked the browser and it said it was started.

I still get the same msg when i try to see any workgroup

Greg
0
 
LVL 11

Expert Comment

by:kabaam
ID: 10661775
How about users and passwords.
in a peer / peer network each machine should have the same user name and password setup on each machine.
Also, XP doesn't like blank passwords with networking.
What is the name of the workgroup for the 98 and me machines?
0
 

Author Comment

by:Greg54
ID: 10661870
the workgroup is the same for all machines. As I stated i can connect between the me and 98.
as for the passwords in peer to peer nework the same user name and password?
where do i check this?

I don't have passwords setup on the 98 or me

0
 

Expert Comment

by:MCBlair
ID: 10662399
How are the workstations(98, me machines) connected to the server(XP Machine)??  
0
 

Author Comment

by:Greg54
ID: 10662879
lynksys router/switch
0
 
LVL 11

Expert Comment

by:kabaam
ID: 10663010
what is the IP address of the XP machine?
click start.. run..
cmd
ipconfig /all
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 10663086
is your xp OS xp Pro? if so
Run local security policy editor from control panel admin tools and set the local policy, Network Access:

this will repeat some of the comments above
http://www.wown.com/j_helmig/wxpwin9x.htm
and from a great expert lrmoore
First and formost, make sure there is no firewall software running! XP has built in PFW.Turn off the Internet Connection Firewall ICF in the advanced settings for the Lan Connection. Check for Norton Internet Security AV/Firewall, BlackIce, ZoneAlarm, et al.

-------------

Next, check your XP networking setup:

http://support.chartermi.net/support/pipeline/windows/winxp_network.html

Although this link says to set netbios over tcp/ip to "default", follow the instructions below...

-------------

Turn on "Simple file sharing" on the XP machine. Open explorer, click tools, click folder options, click the view tab and scroll down until you see "Use simple file sharing" then check the box..

----------------

For the duration of testing, enable the Guest account on XP. If all works, you can deal with that issue later (username/passwords for everyone on every PC)

----------------

Client for Microsoft Networks needs to be the primary network logon for all other machines

----------------

All machines are in the same workgroup


Enable NetBios over TCP/IP in WIndows XP

Step 1: Turn On NetBIOS over TCP/IP

Click Start, click Control Panel, and then click Network and Internet Connections.

Click Network Connections.

Right-click Local Area Connection, and then click Properties.

Click Internet Protocol (TCP/IP), and then click Properties.

Click the General tab, and then click Advanced.

Click the WINS tab.

Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.

Click Close to close the Local Area Connection Properties dialog box.

Close the Network Connections window.

Step 2: Start the Computer Browser Service

Click Start, right-click My Computer, and then click Manage.

In the console tree, expand Services and Applications.

Click Services.

In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.

Close the Computer Management window.

References:

http://support.microsoft.com/default.aspx?scid=kb;en-us;318030

http://support.microsoft.com/default.aspx?scid=kb;en-us;314366

http://support.microsoft.com/default.aspx?scid=kb;en-us;315267

http://www.practicallynetworked.com/sharing/troubleshoot/slowbrowse02.htm

http://www.michna.com/kb/WxNetwork.htm




0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 41

Expert Comment

by:stevenlewis
ID: 10663096
also make sure file and printer sharing is bound to the LAN NIC
0
 

Author Comment

by:Greg54
ID: 10663258
host name                             howdy
primary dns suffix
node type                               unknown
ip routing enabled                   no
wins proxy enabled                 no


ethernet adapter local area connection:

connection-specific  DNS Suffix       dsl-verizion
description                                    3com
controller compatible
physical addess                          05-05-5b----
dhcp enabled                              yes
autoconfiguration enabled              yes
ip address                                     .1.100
subnet mask                                    255
default gateway                              .1.1
dhcp server                                     .1.1
dns servers                                     4.2.4
                                                     4.2.5
                                                     4.2.6


I am running XP NOT PRO
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 10663272
dumb question, but you are sharing something on each machine? (folder/drive)
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 10663275
>>XP NOT PRO
XP comes in two versions, home and pro
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 10663280
can you ping the other machines from the xp box?
how about the xp box from the other machines?
0
 

Author Comment

by:Greg54
ID: 10663360
no i am not sharing something on each machine. Not a dumb question

xp home version

yes i can ping the other 2 computers from XP and I can ping the gateway
I can not ping the xp from the other 2 computers.
they can ping each other and the gateway


0
 
LVL 11

Accepted Solution

by:
kabaam earned 500 total points
ID: 10663404
a one way ping?
most of the time that would leave a firewall of some sort as a suspect.
I know you checked this earlier... but.  
If you are using the symantic Norton internet security suite... disable the entire set.

0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 10663414
>>no i am not sharing something on each machine
share something
0
 
LVL 11

Expert Comment

by:kabaam
ID: 10663609
Norton Internet firewall has a configuration option to trust networked computers.  
set the network range into the trusted zones and  you should be able to have access and firewall protection
0
 
LVL 11

Expert Comment

by:kabaam
ID: 10663635
did you enable the firewalls after you tested it earlier?  If that is the case, something else wasn't set correctly that changed in the process.  what other items or settings were changed since then?
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

A brief overview to explain gateways, default gateways and static routes OR NO - you CANNOT have two default gateways on the same server, PC or other Windows-based network device. In simple terms a gateway is formed when a computer such as a serv…
A common practice in small networks is making file sharing easy which works extremely well when intra-network security is not an issue. In essence, everyone, that is "Everyone", is given access to all of the shared files - often the entire C: drive …
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now