Solved

DHCP Issue

Posted on 2004-03-23
14
276 Views
Last Modified: 2010-04-11
I am facing a problem with regards to DHCP. I have the following setup. Cable/DSL modem, Linksys 8 Port router, LAN and windows 2000 server. When I activate the DHCP server i get an error mesg that there is a conflict in the network regarding the addresses. I have stopped the DHCP service on the router have forced it to take a static address instead of dynamic addressing for the WAN connection type. I have a DNS server on the same unit. could someone tell me how i could creat a connection to the internet from my intranet and how i could solve this overlapping of ip address outter. I also get DNS refussed error could this be associated with ip configuration issues?

Thanks
0
Comment
Question by:wilkersons
  • 5
  • 4
  • 3
  • +2
14 Comments
 
LVL 27

Expert Comment

by:pseudocyber
ID: 10661712
Yes, your DNS problem could be related.  Let me get this straight - you plug in your Linksys and the OUTSIDE interface is the one with a duplicate IP address!?!

Try turning everything off.  Turn the cable modem on first, wait 2 minutes.  Then turn the Linksys on and wait 2 minutes.  Then plug in ONE PC into the Linksys and test.  See if that works.

The 2K box isn't doing DHCP Server as well is it?
0
 
LVL 21

Accepted Solution

by:
wyliecoyoteuk earned 500 total points
ID: 10661753
You seem a little confused, but I think that this will help.
The setup of the WAN DHCP client on the router is not the same as the DHCP server.
The router uses a DHCP client or a fixed IP addres on the WAN side.
It can also run a DHCP server for your network on the LAN side(this is often the default)
If you then run a DHCP server on your win2K server, there will be problems.

The simplest setup is DHCP server on the router, gives out DNS and Gateway to clients.
If you want to run a DHCP server on the 2K server, disable DHCP server on the router, give it a fixed internal address, and in the DHCP client options settings on the 2k box, add the router as Gateway and DNS server (secondary DNS server if you have an internal DNS server already).

Example (based on actual network)

Router WAN address from provider`s DHCP. internal address: 192.168.1.1 netmask 255.255.255.0 running DHCP, range 192.168.1.100 upwards. (use the unallocated range up to 100 for fixed devices like servers or printers.)
The clients will get addresses in the 192.168.1.xxx range, netmask 255.255.255.0 Gateway 192.168.1.1, DNS servers 192.168.1.99(Internal DNS server), 192.168.1.1


Of course without knowing more about your network size, configuration and useage, I cannot be more specific.




0
 
LVL 21

Expert Comment

by:wyliecoyoteuk
ID: 10661836
plus. as psuedocyber spotted ( and I didn`t) if it is the outside IP that is the problem, unless you have been allocated a fixed IP by your provider (usually costs extra), you will have to use an automatically provided one from the cable modem.
0
 

Author Comment

by:wilkersons
ID: 10662136
Sorry people I should have been more specific. Yes your right wyliecoyoteuk the router WAN DHCP has notin to do with the 2k server DHCP. The issue is that even when i disable the Router DHCP facing the LAN and enable the 2k server DHCP i keep getting teh error "specified ranges either overlap or are invalid" not to mention DNS operation refused

"""""Router WAN address from provider`s DHCP. internal address: 192.168.1.1 netmask 255.255.255.0 running DHCP, range 192.168.1.100 upwards. (use the unallocated range up to 100 for fixed devices like servers or printers.)
The clients will get addresses in the 192.168.1.xxx range, netmask 255.255.255.0 Gateway 192.168.1.1, DNS servers 192.168.1.99(Internal DNS server), 192.168.1.1"""""

I have the following:: ROUTER

Router WAN address : DHCP
Internal Address: 192.168.1.1
Netmask:255.255.255.0
Range: 192.168.1.100 to 192.168.1.175

CLIENTS (Server)

Clients address: 192.168.1.100 to 192.168.1.175
Server address: 192.168.1.98
netmask: 255.255.255.0
default gateway:192.168.1.1
Server has a DNS install on it address: 192.168.1.98
                          alternate address:192.168.1.1


 

0
 
LVL 21

Expert Comment

by:wyliecoyoteuk
ID: 10662743
All looks ok, but sounds like your DHCP scopes or DNS zones are set up incorrectly.
It is possible that you have a mix of ip addresses issued by both the router and the 2k dhcp server, thus when the 2k server tries to issue an address, there is a conflict with an address already on the network.
How many clients do you have? could you try setting the 2k range to 192.168.1.176 -250? (you could always move it back after all the clients have moved over, how long this takes would depend on your lease settings)

0
 

Expert Comment

by:comfixit
ID: 10662944
Try this first.

Turn off your Win2K machine.
Then do a hard reset of your router to factory specifications.
Make sure your desktop is set up for DHCP
Make sure your desktop does not point to your 2000 server for DNS
Then plug in your router and restart your computer and see if that works.

Once you have that working you can change the settings on your windows 2000 server. I reccomend using the 10.0.0.1 IP range for your server and leaving the 192.168.0.1 range for your DHCP.

Hope this helps
0
 
LVL 27

Expert Comment

by:pseudocyber
ID: 10666979
I know you've disabled DHCP services on the router, but just for grins, why not change the scope to something silly, like say .5-.10.?  Then you would know the scopes don't overlap - even though one of them is supposedly inactive.

Any chance you have a protocol analyzer (like ethereal) and could look at the DHCP traffic?  Just to see who is requesting and who is replying?
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 21

Expert Comment

by:wyliecoyoteuk
ID: 10667592
pseudocyber:

yes, ethereal is excellent for this sort of thing :)

download it free from
http://www.ethereal.com
0
 

Expert Comment

by:blackss
ID: 10673715
Simple, change your internal addressing to 192.168.0.1 and up.  You need to differentiate your subnets.

Usually routers dont like to have both networks, inside and out, as the same subnets.  Try it and let us know.
0
 

Author Comment

by:wilkersons
ID: 10681626
blackss do u mean the internal address from the router or the address form the dhcp service/server ?
0
 
LVL 27

Expert Comment

by:pseudocyber
ID: 10700234
Wilkersons, I think Blackss was thinking your WAN network and your internal LAN network were the same - but I didn't get that from your posts.

Were you able to try changing the DHCP scope on your router as I had suggested?

Is this still an issue for you?
0
 

Author Comment

by:wilkersons
ID: 10703815
Guys I will work on ur suggestions and ping u the results
0
 
LVL 27

Expert Comment

by:pseudocyber
ID: 10703833
Sounds good. :)
0
 
LVL 27

Expert Comment

by:pseudocyber
ID: 10712802
How'd it work out Wilkersons?
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Cisco MAC address finding 5 49
DHCP on ASA 3 25
Windows 10 VPN? 6 46
EIGRP Full Mesh 2 37
Preface There are many applications where some computing systems need have their system clocks running synchronized within a small margin and eventually need to be in sync with the global time. There are different solutions for this, i.e. the W3…
Data center, now-a-days, is referred as the home of all the advanced technologies. In-fact, most of the businesses are now establishing their entire organizational structure around the IT capabilities.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now