Solved

Remote desktop logs me in, then right back out

Posted on 2004-03-23
10
987 Views
Last Modified: 2012-05-04
This is a really wierd senerio. As of 1 day ago my administrative remote desktop from a xp machine to my windows 2003 server worked just fine. Now all of a sudden when I log in, it logs me in (I see loading your personal settings etc screen) then logs me right back out immediately (saving your personal settings, logging you off) screen. I can connect with remote desktops.msc as long as i connect to the console, or remote desktop app with the /console switch, but this is as far as I seem to be able to get. PLEASE help me, i have tried every kind of different configuration, security setting, etc etc. I even have reinstalled the OS itself, and it still does this. Im sure its a really simple fix, but cant find info anywhere on this suvject. I do not have terminal services installed, but according to Microsoft I dont need to for the 2 concurrent administrative sessions it allows by default. I am running Windows Server 2003 Enterprise. Any help IS greatly appreciated.
0
Comment
Question by:mekanix
10 Comments
 
LVL 16

Expert Comment

by:JamesDS
ID: 10665089
Can I suggest you look in the event logs on the server AND on the client and tell us what's there.

If you actually reinstalled the server (seems a bit drastic) then the problem is probably client related and nothing to do with the server :(

Cheers

JamesDS
0
 

Author Comment

by:mekanix
ID: 10665170
Thanks!

Was nothing in the event logs exept the logon/logoff typical messages, no errors. Ill get you some more details on these. I think i may have limited the problem somewhat to a particular software product im using. I thought about the only things I had changed from the time it worked, to the time it didnt work and what I came up with was I had installed acronis true image server build 597.Ii uninstalled it, restarted,  then remote desktop worked just fine, although I got an error at logon that mmc.exe had encountered a problem and needed to close. However I could not reproduce this actually fixing it again I re-imaged my drive and started from scratch. at first logon I uninstalled true image server, restarted, and I was back to the same problem. so I dont know if uninstalling this software actually is the fix, or if it was just a random stroke of luck that it worked. im going to do some further diagnosis and testing to try to narrow down the problem a bit more. Thanks for the help its much appreciated!
0
 

Author Comment

by:mekanix
ID: 10665201
Forgot to say, i have tried from 4 different systems running xp pro, here at home, and from the wan (at work) all with the same result. I have also tried even on the local machine and it doen the same thing, so i dont think its a client issue.
0
 
LVL 1

Expert Comment

by:ezjurgen
ID: 10665237
Make a second Admin Account. Try to log in with it, does it have the same effect?

grtz

ez
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:mekanix
ID: 10665282
Heres the only event thats outside the ordinary i.e. diskeeper start/stop etc:

Event Type:      Information
Event Source:      MSDTC
Event Category:      TM
Event ID:      4097
Date:            3/24/2004
Time:            1:19:35 AM
User:            N/A
Computer:      XXXXXX
Description:
MS DTC started with the following settings:

  Security Configuration (OFF = 0 and ON = 1):
      Network Administration of Transactions = 0,
      Network Clients = 0,
      Distributed Transactions using Native MSDTC Protocol = 0,
      Transaction Internet Protocol (TIP) = 0,
      XA Transactions = 1

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


Tried what you said and made another admin account, did the same thing, this is really wierd. Logs me in, then within half a second right back out. Even more strange is this just started happening, it worked as of yesterday. The only thing changed that i can possibly think of is installing that acronis software. I may just have to try another fresh install and before i do anything see if it works, then check it after each step of install to see what is doing this.

thanks again!
0
 

Author Comment

by:mekanix
ID: 10745324
After days upon days of searching I found the solution!!! w00h00!!! It turns out that the newest Nvidia driver (56.64) is causing the problem, the good part is you dont have to uninstall the driver, simply disable the Nvidia display driver service under services, restart and bingo, administrative terminal services sessions now work again without having to log into the console. Hope this helps someone in dire need for a solution as I needed one and couldnt find one.
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 11075722
PAQed, with points refunded (190)

Computer101
E-E Admin
0
 

Expert Comment

by:kjboughton
ID: 11442446
Holy-moly....I had the same damn problem...updated the NVIDIA GeForce FX 5200 drivers on my Windows Server 2003 and had the same problem!  Couldn't logon (logged me right back off) when trying via Remote Desktop.  Thanks for the solution this has been a lifesaver!!!!
0
 

Expert Comment

by:tayyabyunus
ID: 12745237
I can't believe it, i had the same problem for almost 3 months for a customer of mine. it was driving me crazy.  it was the stuipd nvidia driver.  THE PERSON WHO FIGURED THIS OUT FIRST, YOU ARE A GOD AND SHOULD BE WORSHIPPED!! HAHA, just kidding.  
0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

Scenerio: You have a server running Server 2003 and have applied a retail pack of Terminal Server Licenses.  You want to change servers or your server has crashed and you need to reapply the Terminal Server Licenses. When you enter the 16-digit lic…
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now