Solved

Inhereting permissions on folders including CVS

Posted on 2004-03-24
5
261 Views
Last Modified: 2013-12-06
I run a Linux Fedora Core 1 server on our small office network, which works quite happily with few problems.

One issue that is bugging us is that when new folders are created, particularly when CVS'ing up new projects, the folder does not inherit the permissions of the parent folder.

This means that if I upload a new project, no one else can download and/or update it.

What do I need to do (CHMOD, CHOWN, CHGRP etc) to set the entire CVS root to allow this behaviour, without having it open to everyone (we have a user group called CVS)? I am fed up with having to go in to a terminal and update new projects!

Also, I want the same to happen on the file share folders, with permissions being set for different groups. Some will have read only, and others will have full access - but permissions should always be the same on every file / folder created in that folder... i.e. They should always be inherited from the parent.
0
Comment
Question by:SamEdney
5 Comments
 
LVL 34

Accepted Solution

by:
Duncan Roe earned 250 total points
ID: 10665882
The permissions of newly created filesystem objects are governed by your umask setting.
When you type "umask", what is the response?
A typical value is 022, which means owner rwx, group and other r-x. If you remember how octal works, it makes some sense.
(umask is the inverse of the resulting file permission, e.g. 022 -> files 755 as above).
If you want world writeable CVS, do a "umask 0" before creating them. Group writable, umask 002.
0
 
LVL 3

Expert Comment

by:idt
ID: 10667225
When setting up a cvs tree root directory,
make the ownership cvs:cvsusers
add all relevent users to cvsgroup
chmod g+s cvsroot //set user or group ID on execution (s)

and ll should show
drwxrwsr-x    7 cvs      cvsusers     4096 Mar  9 13:21 cvsroot/

then when new directories are made:
$ cd cvsroot
$ mkdir foo
$ ll
drwxrwsr-x    2 dan      cvsusers     4096 Mar 24 08:05 foo/

All can read, cvs works as it should, you get to sleep.

Daniel P.





0
 
LVL 1

Expert Comment

by:gronog
ID: 10680793
you can change rights on the whole subtree by using the -R switch of the chmod command.
(also works with chown)
this could be automated by a cron JOB.
0
 
LVL 3

Expert Comment

by:idt
ID: 10682008
Yes you could use a cron, but the whole idea is to set it up right from the get go.
0
 
LVL 1

Author Comment

by:SamEdney
ID: 10704577
I have just tried out these ideas, and if it works will probably split the points. Sorry for the delay getting back to you... been busy!!
0

Featured Post

Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
Fine Tune your automatic Updates for Ubuntu / Debian
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question