B sees A but A partially sees B

I am beginner in networking and I have setup a small home wireless network as follows :
[A] -> Sony Vaio laptop PCG-GRT260G - Pentium IV - 2.8 - I gb mem. Built-in Wi-Fi 802.11g - Windows XP home
[B] -> Toshiba Portégé 7140CT - Pentium III -0.8 - 0.512 gb mem -PCMCIA WI-FI card Sitcom 802.11b - Windows 2000 pro

[A] shares Internet with [B] and it works fine
[B] sees [A]
[A] sees [B] but only [Printers and Faxes] and [Scheduled Tasks]

I have given in [B] full access to 'everyone' and shared disk C: with all directories and I do not succeed to have access to [B] C:
from [A]
Can somebody help me to solve this strange issue ?
hainauxAsked:
Who is Participating?
 
sirbountyConnect With a Mentor Commented:
[A] should have account Jose (we'll say it's password is Jose (substitute for whatever you're using)).
[B] should also have account Jose with password Jose.

You should be able to communicate between the two when logging in as Jose...

Not sure if these apply to Windows 2000, but should to XP...

Disable all firewalls for testing.  This includes Zone Alarm, Norton Internet Security, etc.
    Including XP's ICF...
    From Control Panel, open Network Connections.
    Right-click Local Area Network from Control Panel's Network Connections and choose Properties
    Click the Advanced tab and deselect (remove the checkbox from) "Protect my computer..."
    Click OK and close out of Network Connections & Control Panel

Enable NetBIOS over TCP/IP:
    XP utilizes DNS for communication by default.  To enable the systems to communicate via NetBIOS,
    proceed as above to enter Network Connections.
    Right-click your Local Area Connection and click Properties
    Scroll down in "This connection uses the following items:" to find Internet Protocol (TCP/IP)
    Select it (highlight it) and click properties
    Click the Advanced button on the General tab.
    Click the WINS tab.
    Under NetBIOS setting heading
     Click Enable NetBIOS over TCP/IP
    Click OK, OK, OK and close out of Network Connections & Control Panel

Let Everyone's permissions apply to anonymous users as well:
     Click Start
     Click Run
     In the Open box type SECPOL.MSC /S <ENTER>
     Navigate to Local Policies/Security Options.
     Double click "Network Access:Let Everyone permissions apply to anonymous users"
     Click Enabled and click OK
     http://support.microsoft.com/?scid=kb;en-us;318030


0
 
sirbountyCommented:
I'll presume that you have both A & B in the same workgroup?  Or does B see A because of ICS?
Try this from Start->Run->CMD on A

NET USE \\[B]\IPC$ /USER:\\[B]\Administrator <ENTER>
Should be asked for a password...

Post back with the results...
0
 
hainauxAuthor Commented:
Thank you.
I have not been asked for a password though there is one to access [B]
Here are the results :
Remote name: \\chantal\\IPC$
Resource type : IPC
Status : OK
# opens : 1
# connections : 1
The command completed successfully
Hope that helps
José
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
sirbountyCommented:
Hi José - after that connection is made - can you try
Start->Run->\\chantal\c$ <ENTER>
???
0
 
hainauxAuthor Commented:
Here is what I got :
[The network path was not found]
0
 
sirbountyCommented:
Can you 'ping' chantal?

Start->Run->CMD <enter>
PING Chantal
You should receive 4 replies...
If so, note the reply address and try my last post with that instead of chantal

For instance:
Start->Run->\\192.168.1.102\c$ <enter>
0
 
hainauxAuthor Commented:
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Jose>ping chantal

Pinging chantal [192.168.0.167] with 32 bytes of data:

Reply from 192.168.0.167: bytes=32 time=29ms TTL=128
Reply from 192.168.0.167: bytes=32 time=1ms TTL=128
Reply from 192.168.0.167: bytes=32 time=1ms TTL=128
Reply from 192.168.0.167: bytes=32 time=6ms TTL=128

Ping statistics for 192.168.0.167:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 29ms, Average = 9ms

C:\Documents and Settings\Jose>\\192.168.0.167\c$
Logon failure: unknown user name or bad password.

C:\Documents and Settings\Jose>
0
 
sirbountyCommented:
Does the same account exist on BOTH devices with the SAME password?
This should work, if you set it up this way...
0
 
hainauxAuthor Commented:
Both devices use the same password but what do you mean by the same account ?
Administrator ? In that case both use same account and same password.
Why do I have a logon failure using the correct ping ?
0
 
hainauxAuthor Commented:
Well.. It becomes a little bit complicated for a networking beginner.
I am convinced that the problem comes from a bad configuration of [B] because I have in the meantime added a third computer [C]  Toshiba Windows 2000 with same devices WI-FI and however using a different password.
[A] is of course asking for the password but afterwards sees [C] completely and can work with all folders and files.
What could I check in the configuration of [B] which could prevent viewing and  accessing its C:  drive ?
May I ask you to give me simple instructions step by step as you did in the first messages because as I told you I am a beginner in networking and the last but not the least 'english' is not my mother language.
Thank you  for your help.
0
 
hainauxAuthor Commented:
I finally got it.
I have just add a new share name in [B] sharing C: [c-Chantal] and that's it. It works now normally and I can see and use all folders in [B] from [A].
Anyway I grant you the points because you have been very helpfull.
Thank you again
José
0
 
sirbountyCommented:
Sorry I've been away.  Glad you've got it working though.
Happy to help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.