Solved

How to set frames for 640x480 screen resolution

Posted on 2004-03-24
9
238 Views
Last Modified: 2010-04-09
My frames work fine if screen resolution in Windows is 1024x768. If I change screen resolution for 640x480, my pages in the frames show as they would be cut. They don't show completly and I set the frames with percentages. What am I missing, please?

<frameset border="0" frameSpacing="0" borderColor="#336699" rows="12%,88%" frameBorder="0">
      <frame name="arriba" scrolling="no" src="banner.html">
      <frameset border="0" frameSpacing="borderColor=#336699" frameBorder="NO" cols="16%,84%">
            <frame name="izquierda" src="menu.htm" noResize scrolling="no">
            <frame name="derecha" src="HTMLPage1.htm">
      </frameset>
      <noframes>
      </noframes>
      <noframes>
0
Comment
Question by:modemonkey
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +1
9 Comments
 
LVL 6

Expert Comment

by:Andy
ID: 10673163
You need to set the height of the top frame (rows) and the width of the left frame (cols) with pixels so they will remain a fixed size regardless of your screen resolution.
0
 
LVL 53

Expert Comment

by:COBOLdinosaur
ID: 10673332
The rows and cols attributes set the size of the frame, no the size of content page.  If teh content is too large you need to work on the page layout to make them flexible with percentages.  However if you need teh oversized page content, then you need to allow the frames to scroll by getting rid of the scrolling="no"  so that it defaults to auto and give youbars when you need them.

Cd&
0
 
LVL 1

Expert Comment

by:essage
ID: 10676787
Try putting these into a fixed table as such:

<table border="0" cellpadding="0" cellspacing="0" style="border-collapse: collapse" bordercolor="#111111" width="600" id="AutoNumber1" height="121">
    <tr>
      <td width="100%" height="400">

<frameset border="0" frameSpacing="0" borderColor="#336699" rows="12%,88%" frameBorder="0">
     <frame name="arriba" scrolling="no" src="banner.html">
     <frameset border="0" frameSpacing="borderColor=#336699" frameBorder="NO" cols="16%,84%">
          <frame name="izquierda" src="menu.htm" noResize scrolling="no">
          <frame name="derecha" src="HTMLPage1.htm">
     </frameset>
     <noframes>
     </noframes>
     <noframes>
</td>
</tr>
</table>
0
Why Off-Site Backups Are The Only Way To Go

You are probably backing up your data—but how and where? Ransomware is on the rise and there are variants that specifically target backups. Read on to discover why off-site is the way to go.

 
LVL 19

Expert Comment

by:webwoman
ID: 10678463
That's TOTALLY wrong - you do NOT put framesets inside tables.

Again (to repeat Cd&) if your content is large, it won't fit in the frameset. If you don't have scrollbars, NOBODY will be able to see your content.

Either allow the scrollbars or redesign the content.
0
 
LVL 6

Accepted Solution

by:
Andy earned 80 total points
ID: 10678530
As I said... If you set the sizes of the frames using percentages then the actual (pixel) size will vary as you change resolution. For example... Setting the left frame to 10% in a resolution of 1024x768 will mean that the left frame is 102 pixels wide but in 640x480 it will only be 64 pixels wide.

You need to set the frame sizes in pixels not percentages. For example... If you set the left frame like this...

<frameset border="0" frameSpacing="borderColor=#336699" frameBorder="NO" cols="150">

Then it will always be 150 pixels wide regardless of the resolution.
0
 
LVL 1

Expert Comment

by:essage
ID: 10678630
webwoman, I have done this with success many times. just giving a possible solution.   Reapz is right, the positions need to be pixal size, not percentage.
0
 
LVL 19

Expert Comment

by:webwoman
ID: 10683292
No way. It's TOTALLY wrong. Frames have absolutely NOTHING to do with tables. IE might let it slide, but nothing else will. Not only that, you don't close the framesets, and don't use the noframes tags correctly.
0

Featured Post

Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article discusses four methods for overlaying images in a container on a web page
Find out what you should include to make the best professional email signature for your organization.
In this tutorial viewers will learn how to embed videos in a webpage using HTML5. Ensure your DOCTYPE declaration is set to HTML5: "<!DOCTYPE html>": Use the <video> tag to insert a video. Define the src as the URL of your video; this is similar to …
The viewer will learn the benefit of using external CSS files and the relationship between class and ID selectors. Create your external css file by saving it as style.css then set up your style tags: (CODE) Reference the nav tag and set your prop…

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question