We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

Remove logon.scr on Host during/after Remote Desktop session

farfromuman
farfromuman asked
on
Medium Priority
1,587 Views
Last Modified: 2008-02-01
Is there a way to disable the screen saver/logon screen on the Host computer while there is a remote desktop session active?  If that is not possible how do I make the Host PC go back (login) to the desktop after remote client disconnects.  This is a HTPC which I manage with Remote Desktop in XP Profesional.
The screen saver is disabled and I use TweakXP to autologon at boot.
Thanks for any help,
Mariusz
Comment
Watch Question

CERTIFIED EXPERT
Top Expert 2005

Commented:
Hi farfromuman,

Key is :

HKEY_USERS\.default\Control Panel\Desktop
ScreenSaveActive = 0

You must also change this value in all users - ie. S-1-5.xxx that are already created.

Regards,

Netman66, MCSE, MCT
Microsoft MVP Team

Author

Commented:
I changed all the instances to 0 but the screen saver and logon screen still kick in as soon as the session starts.
CERTIFIED EXPERT
Top Expert 2005

Commented:
Hmmm...

Try removing the SCREENSAVE.EXE key value in each of those locations.

Author

Commented:
Still there, just to clarify the host shows the "this computer is locked bla bla bla" window and you have to enter the password to get back in.
CERTIFIED EXPERT
Top Expert 2005
Commented:
Unlock this solution with a free trial preview.
(No credit card required)
Get Preview
CERTIFIED EXPERT
Top Expert 2005

Commented:
farfromuman,

Your comment about logon.scr threw me.

Here is some reading:

http://support.microsoft.com/default.aspx?scid=kb;en-us;279656&Product=winxp

http://support.microsoft.com/default.aspx?scid=kb;en-us;315328&Product=winxp

Note in second link - Section 3, step 8.

Author

Commented:
That is correct, I might have not worded the Q corectly. I used TightVNC and PCAnywhere before, VNC was always slow and PCAnywhere hogs memory this is on a 100mb home network. I might give VNC another try if I can't resolve this. Is there a version of VNC that is faster or optimized for ethernet?
CERTIFIED EXPERT
Top Expert 2005

Commented:
farfromuman,

The only option I see for you is to restart the PC from the Remote Session - unless VNC is an option.

http://www.tightvnc.com/
CERTIFIED EXPERT
Top Expert 2005

Commented:
farfromuman,

Sorry - posted together there.

TightVNC seems pretty good - it is more optimized than straight VNC.

Author

Commented:
Netman66,

I installed VNC and so far its not too bad, screen updates don't happen sometimes when they should.  I also miss the easy file transfer option when working from a remote network. I will award the points to you if I don't find a solution in the next few days.
Thanks for all the help.

Mariusz
CERTIFIED EXPERT
Top Expert 2005

Commented:
You're welcome!
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a free trial preview!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.