Solved

open crystal report in 100% magnification

Posted on 2004-03-24
16
443 Views
Last Modified: 2007-12-19
hi,
i got a vb program that call some crystal reports. but i wonder why every report display 69% magnification?i need to manually adjust it to 100%?any way to make it display at 100% at default?i can't find it.

thx n rds,
daniel
0
Comment
Question by:daniellyh
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 3
  • 3
  • +1
16 Comments
 

Expert Comment

by:tounghuat
ID: 10674026
Hi,
if u are using crystal report viewer to preview the report, mayb can try this code:     CRViewer.zoom = 100
0
 
LVL 2

Expert Comment

by:syed555
ID: 10674509
Hi,
  Also try this method.
  In Report Designer, go to file, options, Layout. Set the Preview pages option to Full Size (100%). yours must be set to 'Fit Width'. thats why its trying to fit the width and reducing to 69%.

Syed
0
 
LVL 1

Author Comment

by:daniellyh
ID: 10675443
hi,
i will try. thx for ur ans.

will feed back tomorrow..

daniel
0
Secure Your Active Directory - April 20, 2017

Active Directory plays a critical role in your company’s IT infrastructure and keeping it secure in today’s hacker-infested world is a must.
Microsoft published 300+ pages of guidance, but who has the time, money, and resources to implement? Register now to find an easier way.

 
LVL 1

Author Comment

by:daniellyh
ID: 10676103
hi guys,
i've try to do the report setting at file->option->layout but the result is still the same.

i m using crystal reports 8.5, in vb i include component crystal report control (crystl32.ocx) so i can't found option to set .zoom = 100.

pls provide more help. thx.

daniel
0
 

Expert Comment

by:tounghuat
ID: 10683937
hi,
u need to have a crystal report viewer control in your form to enable you to hardcode the option of .zoom = 100
".zoom" is one of the crystal report viewer control properties, not crystal report control properties.
Not yet tested using version 8.5, but i could set the option .zoom = 100 in version 8.0 and 9.0. of the crystal report.

huat
0
 
LVL 1

Author Comment

by:daniellyh
ID: 10685606
hi,
ic. then any way to see in 100% using crystal report control?

daniel
0
 

Expert Comment

by:tounghuat
ID: 10701576
hi, dun know whether this would help or not.

www.avdf.com/jan98/art_vb003.html

wat it does is try to make the preview is in a new form and set the forms' property windowstate to maximized.

huat....
0
 
LVL 1

Author Comment

by:daniellyh
ID: 10724208
hi,
will try it n see whther is suitable for me...

daniel
0
 
LVL 1

Author Comment

by:daniellyh
ID: 10728680
hi huat,
it seems not wat i m looking for. anyway thx for ur effort.

actually my requirement seems very easy. but is it really so difficult to do it?

daniel
0
 
LVL 100

Accepted Solution

by:
mlmcc earned 30 total points
ID: 10729214
Try this

CrystalReport1.PageZoom (100)

mlmcc
0
 
LVL 1

Author Comment

by:daniellyh
ID: 10746276
hi mlmcc,
ur way work well n simple. thx!
u still got 1 question with me at

http://www.experts-exchange.com/Databases/Crystal_Reports/Q_20835775.html

remember?thx....

n for everyone thx for ur effort too..
daniel
0
 
LVL 100

Expert Comment

by:mlmcc
ID: 10747782
Glad I could help

mlmcc
0
 
LVL 1

Author Comment

by:daniellyh
ID: 10751223
hi mlmcc,
i got a problem again. i just realise ur method doesn't work for every report, even i put that command some report still not displaying in 100%, but some of them does. why?anything else i need to beside that command?

daniel
0
 
LVL 100

Expert Comment

by:mlmcc
ID: 10751978
I can't think of anything off the top of my head.

Are you calling all the reports in the same way?

Is the ZOOM enabled on all reports?

There is an option in the report for how big to open it.
Open Crystal (no report)
Click FILE --> OPTIONS
In CR7 one of the frames on the top tab is PREVIEW PAGES
Click OPEN FULL SIZE

Close Crystal

You may have to adjust some of the reports
Open each report
Click FILE --> REPORT OPTIONS
In CR7 one of the options is PREVIEW PAGES START WITH
Select FULL SIZE

mlmcc
0
 
LVL 1

Author Comment

by:daniellyh
ID: 10754059
hi,
i will try above said method n respond to u in this few days.

daniel
0
 
LVL 1

Author Comment

by:daniellyh
ID: 10785094
hi mlmcc,
ur method worked. now i can display all reports in 100% magnification. thx a lot for it.

btw, i just post 1 new q for crystal report. pls hav a look when u r free.
http://www.experts-exchange.com/Databases/Crystal_Reports/Q_20948007.html

rgds,
daniel
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Crystal Reports: 5 Tests for Top Performance It is complete, your masterpiece report.  Not only does it meet your customer’s expectations, it blows them out the water, all they want is beautifully summarised and displayed in a myriad of ways. …
Hot fix for .Net Crystal Reports 10.2.3600.0 to fix problems with sub reports running on 64 bit operating systems ISSUE: Reports which contain subreports fail with error "Missing Parameter Value" DEPLOYMENT SERVER OS: Windows 2008 with 64 bi…
Finds all prime numbers in a range requested and places them in a public primes() array. I've demostrated a template size of 30 (2 * 3 * 5) but larger templates can be built such 210  (2 * 3 * 5 * 7) or 2310  (2 * 3 * 5 * 7 * 11). The larger templa…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question