We help IT Professionals succeed at work.

db2 on NT unable to allocate memory to bufferpools

crocmike
crocmike asked
on
1,304 Views
Last Modified: 2012-06-27
While Restarting the Database in order to capture the logs, The following commands are used to stop and start the database
 
db2stop force
db2admin stop
db2admin start
db2start
 
After this Db2diag.log says, Unable to allocate memory to bufferpools. Database is starting two tiny bufferpools. At this stage i cannot even open text files. This problem will be solved once i shutdown and restart the machine.

Hardware          :-        UNISYS ES5000
Processor         :-        Intel Pentium II 450 Mhz
Memory            :-        4 GB RAM
Disk Capacity    :-        400 GB using Mylex   RAID 0 - Fibre Channel Disk
Local Hard Disk :-         2 SCSI Harddisk of Capacity 17 GB each ( C Drive & E Drive)
 
 
Software Configuration :-
 
Operating System      :-     Windows NT 4 with NT Service pack 6 Installed
DB Version                :-     IBM UDB DB2 Version 7.2.3 Enterprise Edition For Windows NT  ( Version 7.01 with Fixpack 3 and 5 installed)
 
Operating System is installed on Local SCSI harddisk ( C Drive) and DB2 is installed on E drive. Database is residing on Fibre Channel Disk. It is divided into five Logical drives  Tablespaces are spanned over 5 logical drives.
 
Total Size of the DB is 110 GB, and is roll-forward enabled.
 
Comment
Watch Question

Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
Thanks to GHP7000 and BigSchmuh for your suggestions.

Apologies for our slow response to your suggestions.

We have currently been sidetracked by unrelated hardware problems, so have been delayed in implementing the suggestions.

We are confident, however, that the suggestions are pointing us in the right direction and we expect to be able to provide feedback over the next few days.

Thanks and regards

Author

Commented:
Thank you very much for your answers. We are still waiting for the hardware to test in test database for
/3GB switch setting in NT.

In the meantime we have checked in the
process on the NT task manager. It uses 1 GB only for
db2syscs process. Other processes takes only about max
10k. Meanwhile i have lowered some of the
bufferpools sizes. In NT task manager,

Totals
------

Handles         7127
Threads         480
Processes       34


Commit Charge
-------------

Total           1363984
Limit           28746180
Peak            1380264


Physical Memory
---------------

Total           3734920
Available       2398064
File Cache      201664


Kernel Memory
-------------

Total           200936
Paged           190500
Nonpaged        10436


If the total memory crosses 1400000, i am getting
memory error. Also if i copy 1 GB file from one disk
to another disk, NT is giving error message 'NOT
ENOUGH QUOTA TO PROCESS THIS COMMAND'. After this when
i am connecting to DB, i am getting SQL902n with
reason code 1450.

In the DB, Most of the bufferpools are configured to
use extended memory. Also in the DB, Estore_segs_sz is
configured as 16000 pages and Num_estore_segs is
configured to 0. I am getting error message in the
DB2DIAG.LOG saying that 'ESTORE IS OFF BUT BUFFERPOOLS
ARE CONFIGURED TO USE IT' After this i configured
Num_estore_segs as 20, it is giving SQL1022C.

My question is why i cannot use extended memory ?

Any advice greatly appreciated.

When our test system is restored (tomorrow we hope) will implemenet your suggestions and award points accordingly.

Many thanks for advice.

Regards

Michael

Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
Thanks BigSchmuh and ghp7000 for assistance in resolving these issues.
Apologies for any in delays in responding.

Mike
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.