We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

Windows 2003 + Office 2003 Terminal Services problem!

plattze
plattze asked
on
Medium Priority
3,182 Views
Last Modified: 2012-05-04
I've had this problem for 2 months now, and tried everything, read everything and then rememebr my EE account, so I really hope I can fix the problem after this :)  I'm more than willing to increase the points to my current points total to anyone who can solve the problem.

Basically, at work, we have a single Windows 2003 Terminal Server running in Application Server Mode.  When I started, it never worked, and It was given to me to 'fix' and it had everything installed on it.

The problem is, when a normal Domain User logs in and tries to open a microsoft office application (word, outlook, visio, project..anything), they get an MSI error saying:

"Only administrators have permission to add, remove, or configure server software during a Terminal services remote session.  If you want to install ro configure software on the server, contact your network administrator."

Event log spits out event ID 1004, then 1001: (this is when the normal user tried to load Visio 2003)

Event ID: 1004:
Detection of product '{91510409-6000-11D3-8CFE-0150048383C9}', feature 'VisioCore', component '{45263A41-952C-4331-A44D-420BAB4E5C46}' failed.  The resource 'H:\Program Files\Common Files\Microsoft Shared\Visio Shared\VISFILT.DLL' does not exist.

Event ID: 1001:
Detection of product '{91510409-6000-11D3-8CFE-0150048383C9}', feature 'VisioCore' failed during request for component '{7E5F9F34-8EA7-4EA2-ABFB-CA4E742EFFA1}'

That is basically the problem I am having.  I have tried removing ALL office programs, and reinstalling it via the following method:
* Loged onto the server via mstsc.exe, and logged on as local administrator.
* removed all office programs (visio, project, office)
* reboot
* start menu -> add/remove programs -> add -> floppy/CD -> selected setup.exe in the network share we have of Office 2003.
* Put in Product Key, then while it was installing, it complained about H:/ missing!!!   Being a local admin, you don't have H:/ which is every users home directory mapping. (\\fileserver\home\<username>
* So I logged out, and logged in with my domain account, which is a Domain Adminstrator using mstsc.exe on my XP workstation.  
* Started setup same way, told it to do a "Complete" install, it installed fine (because H:/ existed.)
* Once it installed, It worked for me and everything worked (and currently still works)

Then tried to log in with our normal domain user test account, logged into it with mstsc.exe, logged in fine, but when I tried to run anything, I still got the same error as before.

Then it goes on...

For testing, I tried giving our normal domain user test account, local admin access of the box, and yes, MSIInstaller runs fine, starts installing components, BUT then FAILS with the "Microsoft Source Engine" error.   So I go into Services of the server, and Office Source Engine shows it's location as "H:\Program Files\Common Files\Microsoft Shared\Source Engine\OSE.EXE"

Thats basically it.  Something is SERIOUSLY wrong and it's beyond me, or I'm missing something blatantly obvious so I'm hoping you experts can help me :)

Seems to be that it's half installed into H:/ or something.   Is it fine to be installing office for ts, logged in via mstsc.exe, and not directly logged into the computer via the server KVM's?  Also, what does it mean when people say 'log in via console', I've heard it mentioned somewhere on here but didn't know exactly.  (I started unix, to me console is ssh/telnet, something which 2003 doesn't really have)

Every user in our domain is configured such that there "Profile" tab, "Home Folder" has H:/ mapped to \\fileserver\home\<username>, and Logon Script is "\\fileserver\home\login.bat" which merely does a couple file shares maps to Document Folders.  "Terminal Services Profile" tab is all empty, with "allow login to terminal server" enable,  and local path selected but the textfield beside it empty.

I'm crying out for help on this one!

Thanks.
Comment
Watch Question

Hi plattze,
Dont know if this is it, but always start all programs under the administrator account to verify installation tasks befor a user can use it...

My initial thought..
Mattis

Author

Commented:
Thanks for the reply.

Yep, after install, I ran it (under my domain account (Domain Admin)) and it worked.

Not sure if I made it clear,  but all the programs work for me, but don't for normal domain users.

I did find a weird workout, if it helps diagnose.  If I go into my home drive (h:/), and copy my "Program Files" folder into any normal domain users Home directory, when they log into the Terminal Server, it works fine for them and all applications load without an issue.

Author

Commented:
Sorry, just to confirm.  The above post is a workaround I found, BUT IS NOT THE SOLUTION I am looking for.  I'm not willing to accept that that is the only way I get can it to work!
A write issue to H then.. Sounds like a GPO setting thats not correct.. sorry i cant help more..
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
mbr1971, thanks for the VERY informative reply.

It seems the problem is fixed, but I'm suspicious on if it is working properly in regards to actually _running_ as a Terminal Server.

This is what I've done.

Logged into the server using /console /f and as a local administrator.

I removed all office stuff, checked the registry for H:, and H:/ keys.  Nothing.  So I rebooted her (incase the uninstall removed the keys).  Then copied the installation directories onto the into c:\temp (because Domain Admin only have access to the Fileserver which has it)

Ran "CHANGE USER /INSTALL"
then run -> c:\temp\office2003\setup.exe

Ran setup, and it still complained about Error 1327.  H:/

Quick google returned this:
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q327763 
(There was a SINGLE key pointing to H:\Program Files\Common Files\ being the location of "Common Files")

Which fixed the problem!
Reinstalled setup, went fine, no errors.  

Ran word, powerpoint etc to test while in that local admin account, worked.  Logged off, and logged on with my domain account (Domain Admin) using just mstsc.exe (remote session), then loaded up word, powerpoint etc.  And it worked.  

Then logged in as my normal domain user test accoount, and ran it, and it worked!  

So it seems to be working.  But I do have a final question before I accept your answer mbr1971.  

It seems that now, Office IS NOT using H:\Program  Files.. - Is this right?  
How can I tell if it's installed properly with Terminal Services?  
How can I tell if Individual user settings will be saved for that user?

Basically, I want to ensure that this is a TRUE terminal server install, and not just a normal "local" install.

Once again, thanks mbr1971.

Commented:
Hi,

Glad to hear you're working :)

Re the true terminal server install question - some of the factors depend on your deployment of the product; regarding folder redirection and so on.  Your AD implimentation is also pretty important in this area - I can be more specific in this area if you need the information)

However, one thing which is always different in a terminal server installation of Office 2000, XP, and 2003 is the splash screen when loading applications such as word or excel - instead of the flashy multi-colour affair they normally are, in a terminal server install they are relatively plain - using one colour on a plain background. The reason for this is to minimise bandwidth usage when connecting over a slow link (still looking ok when using 256 colours).  You can test this by simply loading word/outlook/excel (not sure about project or visio - in the 2000 and 2002 versions they didn't, but there have been some changes in 2003.)

As for saving settings, is your test user able to/ have you tried any other users?

Hope this helps,

Regards.

Commented:
Sorry Plattze, I just realised I didn't rally answer your questions:

1)  You are correct, after fixing the 1327 error H/Program files no longer and will not be used (I have had a similar problem a couple of years ago - the same article fixed it for me ;)

2)  The post above answers your question about determining whether it is a terminal server install

3)  Normal office behavior is to save user settings in three main places: "<user profile path>\application data", "<user profile path>\local settings"  and the HKEY_CURRENT_USER registry hive.  So long as the users have rights to these areas (which by default they do) and you have not made any group policy settings which conflict with these changes, a user's settings will be saved.   (group policy setings will _overwrite_ user change settings)

Cheers.

Author

Commented:
mbr1971, once again, thanks for your knowledgable response!

I managed to take 2 screencaps  of the Project and Visio splash screens, because they are the apps which take the longest to load.  A Dual 2.4Ghz/2Gb RAM Xeon doesn't exactly need more than 1ms to take load word :)

Here they are:
http://members.iinet.net.au/~bangers/msvisio.jpg
http://members.iinet.net.au/~bangers/msproject.jpg

Is that TS enabled or not?
Is it possible to view the splash screen without actually loading it?  So I can see what splash screen it would use if the machine was slower?

I'm more than willing to accept your answer, but i'm afraid If I do, it won't allow you to make another comment to answer these final questions to ensure it is actually running as a TS :/  

Commented:
Thanks for the screen shots...

Project 2003 is running the 256 colour splash screen and looks fine.

Visio 2003 - Not sure about whether Visio should exhibit the same behavoir as office, so not definitive.  However, If you open two different test user sessions then open Visio on both, and also open an administrator session, you can check behavior by looking at the following:

In the administrator session, open Terminal Services Manager and highlight the server you wish to manage, on the left pain select processes, and sort by User or Session.  If everything is working as it should, you should have a separate Visio.exe process for each user/session.

The only knowledgbase article which indicates any problem with Visio 2003 on a terminal server is the following:

http://support.microsoft.com/default.aspx?scid=kb;en-us;832129&Product=visio2003

Which looks like a pretty specific problem...

I'd say you've got everything sorted.

As for accepting the answer - I'm new to EE so don't know what the protocol is - so long as you close the question when you're happy with the solution) it's ok with me... :)

Author

Commented:
Sorry, completely forgot about this question.

my apologies mbr1971.

Commented:
No problems.

Thanks for the points ;)

Cheers.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.