Solved

attempting to install MySQL on XP Pro

Posted on 2004-03-24
5
404 Views
Last Modified: 2010-05-18
I'm trying to install and start MySQL on XP Pro...
already installed MySQL 4.0.18 and MyODBC 3.51.06

When i use the services manager to attempt a start i get this message:

Could not start the MySQL service on Local Computer
Error 193: 0x1

Im a newb... any help?
0
Comment
Question by:jmattsutton
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 7

Accepted Solution

by:
madwax earned 168 total points
ID: 10695400
Have you tried removing it completely and re-installed?

I am running the same version on my XP Pro without any difficulties. If you give me some more information I'll probably be able to help you more.

//jan
http://www.ivtaco.se
0
 
LVL 27

Assisted Solution

by:skullnobrains
skullnobrains earned 166 total points
ID: 10715103
hmm, i've been usin mysql on w2k server as a service for some time.
it does allow the service to start any moment but u should still try and set it to auto-start just to check.
if u don't want trouble duplicate the material profile (is it the correct english name ?) and set the betaprofile to autostart if u don't want to risk a nasty crash, if not the debug mode should let you start windows even on such failures)

193 %1 is not a valid Win32 application. ERROR_BAD_EXE_FORMAT
info from the excellent and bookmarked http://www.netop.com/tech/support/errorcodes/win32_error_codes.htm

where did u get the mysql version ? did u try another source ?

actually this may solve the problem even if nobody knows why as this error can happen for many reasons which have nothing to do with the contents of the exe files... (thanks bill :) ... and believe me i talk from (nasty) experiences.
0
 
LVL 1

Assisted Solution

by:dcrudo
dcrudo earned 166 total points
ID: 11913477
I had a similar problem under XP and fixed adding a my.ini file (if not there) under c:\windows with the following settings:

[WinMySQLAdmin]
Server=C:/Program Files/MySQL/bin/mysqld-nt.exe

[mysqld]
basedir=C:/Program Files/MySQL
datadir=C:/Program Files/MySQL/data


(of course matching the correct paths).

I hope it helps!

Dave.
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Creating and Managing Databases with phpMyAdmin in cPanel.
This article shows the steps required to install WordPress on Azure. Web Apps, Mobile Apps, API Apps, or Functions, in Azure all these run in an App Service plan. WordPress is no exception and requires an App Service Plan and Database to install
This video Micro Tutorial shows how to password-protect PDF files with free software. Many software products can do this, such as Adobe Acrobat (but not Adobe Reader), Nuance PaperPort, and Nuance Power PDF, but they are not free products. This vide…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question