Getting internet shareing working with Mandrake and Win98

I have two computers conected by crossover ethernet cable.  My main computer has two network cards, one for cable modem, second for conection between computers.  When my master computer is running XP and my client is running 98 the network works fine, file shareing and internet shareing.

I just installed Mandrake Linux 9.2 on the master as a dual boot.  But am unable to configure it to alow for internet shareing nor file shareing.  The client cannot connect to any web site.  But the master (Mandrake Linux) can always access the internet.

I tryed to use DrakeConnect and DrakeGw to set things up.

eth0 is connected to the client and should be
eth1 is my internet conection (cable) using dhcp

They are both reported to be up and running in the DrakeConnect controll pannel.

In DrakeGw I chose to enable Internet shareing, but after enable, and next, the window closed and there were no other steps.

I can ping the client with 0% loss

Client can ping master and there is 0% loss, a nice conection.

winipcfg on the 98 machine gives satisfying results:

default gateway:

ipconfig on Mandrake (master) produces a command not found.

I viewed the services list and could not find any dns, but did find nfs, netfs and network are all running and start on boot.

My host file on Mandrake only contains localhost
Same with 98 machine.  Only localhost

I need help to get internet shareing and file shareing working in Mandrake linux so when I am in linux my mom can use her computer just about the same as she would when i am in xp.

Please help me configure it to work.
Who is Participating?
RFMullerConnect With a Mentor Commented:
In mandrake, do ifconfig not ipconfig

also, you probably need to enable ip forwarding:
echo 1 > /proc/sys/net/ipv4/ip_forward

and nat (Network Address Translation):
/sbin/iptables -t nat -A POSTROUTING -i eth0 -o eth1 -j MASQUERADE

and flesh out your firewall a little:
/sbin/iptables -P INPUT DROP
/sbin/iptables -P FORWARD DROP
/sbin/iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
/sbin/iptables -A INPUT -i eth0 -j ACCEPT
/sbin/iptables -A FORWARD -i eth0 -j ACCEPT
simly0101Author Commented:
I will add points as they come available, As i thought I had more to spend, and this is a chalengeing question

Sorry for being stingy.
simly0101Author Commented:
ok that worked and she can get the internet,  but my file shareing still isnt working, so I went looking and found this Samba tutorial,

Problem is that yes, i now have a samba under network neighbourhood in 98 machine BUT none of the folders work, and I made sure I created the folders as directed and gave them permission.  I get the error that //SAMBA/everyone is not accessable.

I went to Controll Center and samba mount points and tryed to mount //SAMBA//everyone to /mnt/everyone but it still fails on her end.

I will give you points but before I close the question and award points I still need help to this file share part of the question.

Sorry, but I don't know much about samba (I don't use it myself).
Are the permissions on /mnt/everyone set so that users on the Win98 machine can read/write?

simly0101Author Commented:
permisions are ok, well I think I solved most of my samba problems now, I can now access //SAMBA/everyone

Thanks so much for solveing my internet shareing, and here are your points.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.