Solved

Home Network - 3 comprs.; 2 visble and 1 semi-visble. XP Pro & W2k Pro.

Posted on 2004-03-26
15
1,052 Views
Last Modified: 2010-08-05
I'm not sure if this is a WinXP Pro problem with Win2k Pro, or the other way around. I’ve been working on this problem in my spare time for over a week, and I’ve tried my own solutions as well as several solutions that I’ve seen through searching the web. I just can’t figure it out.


CURRENT SETUP
===============
I have three computers connected within my home network environment. All computers have all current updates, drivers, and patches.

1.) Desktop001 is running Windows 2000 Pro. It's Ethernet wired directly to a wireless “G” Linksys router.
2.) Desktop002 is running Windows XP Pro. It's connected to the network by a PCI Wireless "G" Linksys card.
3.) Laptop002 is running Windows XP Pro. It's connected to the network by a PC Card Wireless "G" Linksys card.


PROBLEM
=========
Desktop001 can see, read, and access the contents of either Desktop002 and Laptop001 with no problems.
Desktop002 and Laptop001 can see, read, and access each others content with no problems.

However, my problem develops when Desktop002 and Laptop001 try to see and access Desktop001. Both can see Desktop001 on the network, but neither can see nor access any of Desktop001’s shared content.


MY TROUBLE SHOOTING, SO FAR…
===============================
1. I've turned off Windows XP firewall on Desktop002 and Laptop001.
2. I’ve turned off the firewall program (Zone Alarm Pro) on each of the three computers. No positive results. I’ve turned them back on.
3. I’ve un-installed, re-installed, and updated the drivers on all three computers related to the ethernet card or their wireless “G” transmitting devices.
4. On Desktop001, I went through and deleted all references to “Shared”  folders on it’s system, and then I re-enabled most of them for sharing again. This was on the outside chance that it would help.
5. On all three computers I feel that I have properly installed, checked, and re-checked  “Client for Microsoft Networks”, “File and Printer Sharing for Microsoft Networks”, “NetBEUI Protocol”, “ NWLink NetBIOS”, “NWLink IPX/SPX/NetBIOS Compatible Transport Protocol”, “Internet Protocol (TCP/IP)”
6. Under “NWLink IPX/SPX/NetBIOS Compatible Transport Protocol”, they all share the same “Internal Network Number”. I’ve re-checked this several times.
7. Under “Internet Protocol (TCP/IP)”
7a. Both IP and the DNS are selected for obtaining automatically.
7b. Under “Advance”>> “Properties”>>”Advance”>>”WINS”,  “Enable NetBIOS over  TCP/IP” is checked on all three computers.
7c. All other settings throughout each computer appear to match up with each other.
8. I’ve performed a “IPCONFIG –all” on all three computers. Desktop001 is 192.168.1.101, Desktop002 is 192.168.1.103, and Laptop001 is 192.168.1.102
8. All three computers appear to have no problems pinging each other. In other words, I have success getting each computer to “PING” the other two with no apparent problems. Desktop002 and Laptop001 can actually see Desktop001 through pinging.
9. I’ve reset the Linksys Router several times thinking that a setting in there could have be the problem. I’ve also upgraded the firmware. I’ve seen no positive results by doing this.
10. I replaced the Ethernet card in Desktop001 with a newer one, but I still had the same negative results.
11. Under “My Network Places” >> “Entire Network” >> “Microsoft Windows Network”, when Desktop001 is powered off, the other two computers no longer show it within the network. When Desktop001 is powered on, the other two computers will show it within the network.


QUESTIONS
===========
1. At this point, I can’t help but get the general feeling there could be a setting(s) within the Registry or even within the Administrative Tools that is preventing Desktop002 and Laptop001 from seeing Desktop001,  or it could even be something that Desktop001 has that is preventing the other two from accessing it..  
The possible setting could be on both Windows XP Pro computers; Desktop002 and Laptop001, or it could just be within the Windows 2000 Pro computer; Desktop001. Is there any setting(s) within those areas that I should/could check, correct, or alter?

2. There is one thing that I’ve notice different between all three computers, and it’s under “Internet Protocol (TCP/IP)” >> “Properties”>>”Advance”>>”Options”.  All three have “TCP/IP filtering”, but Desktop001 also has the feature called “IP security”. Is this a potential problem, or is it something to be concerned about?

3. Or, is there something else causing the two XP computers not be able to see and access the contents of the W2k computer?

Since Desktop001 can see Desktop002 and Laptop001 on the network and can access their shared file, and Desktop002 and Laptop001 can see and access each others content, my goal is to not only have Desktop002 and Laptop001 see Desktop001 on the network (as it already does now), but to see and access the shared content on it.

Thanks in advance.
0
Comment
Question by:jbarrington
  • 5
  • 4
  • 4
  • +2
15 Comments
 
LVL 30

Assisted Solution

by:Gareth Gudger
Gareth Gudger earned 150 total points
Comment Utility
1/. So what error message do you receive when you access the Windows 2000 box? Can you see the shares but get "Access Denied" or do you not even see the shares.


2/. No that is how it is. Those were the design differences between XP and 2000 and nothing to be concerned about.
0
 

Author Comment

by:jbarrington
Comment Utility
diggisaur,

I don't actually see a error message box when I click on Desktop001 from either of the other two computers while in the network area, but if I right click on it and select properties, I'll get an error message stating: "The server Desktop001 does not accept remote requests".

Within the network of the two XP boxes, I do not see any of the shared files that I know exist on the W2k computer. However, both XP boxes *do* show a USB hard drive under Desktop001 that is suppose to be connected to the W2k computer, but the only problem is I do not have that drive connected at all to the W2k computer.

I don't know why the drive still shows up when it doesn't exists. I'm sure the request may be made by someone to reconnect it to see if that 'll help my situation, but before I realized my current problem, I had to reformat the USB drive due to overheating problems and decided use it for something else.

I tried to see if I could somehow delete the reference from Desktop002 and Laptop001, but it doesn't seem to allow it to be removed.

I originally didn't feel it was a serious problem, and felt it would resolve itself whenever I could re-establish a connection to Desktop001. I suppose this could be related to my problem, but I can't remove the USB Drive reference from either Desktop002 or Laptop001.
0
 
LVL 30

Assisted Solution

by:Gareth Gudger
Gareth Gudger earned 150 total points
Comment Utility
Hmm.....no errors. That weird. Now you said the XP boxes had no firewalls. Was this the same for Desktop001 as well?

Also, check your group policy.....

Start ==> Run ==> gpedit.msc

Computer Config ==> Windows Settings ==> Security Settings ==> Local Policies ==> User Rights

Are you seeing your XP accounts listed under the "Access This Computer From the Network"?
Also "Deny access to this computer from the network" should be blank.

Although these usually generate an error if set wrong.

Do you see any errors in the Windows 2000 event logs that might indicate failure of any networking services? ie is the browser or server service stopped, etc.
0
 
LVL 11

Accepted Solution

by:
infotrader earned 350 total points
Comment Utility
Not that it matters, but first of all, unless you are running something that requires all that stuff, I suggest you remove all of those unneccesary protocols.. It'll only make things worse, not better.

The only things you need in the network properties box are:

Client for Microsoft Network
File and Printing Services for Microsoft Network
Internet Protocol TCP/IP

no IPX/SPX, Netbui, etc... it'll only slow you down.

Let me know the results after you remove them.

- Info
0
 
LVL 11

Assisted Solution

by:infotrader
infotrader earned 350 total points
Comment Utility
P.S.  All those protocols, I believe, do not comply with WirelessG standards... which might explain why you can't use your wireless card to access the 1st machine, depending on the network binding order.

- Info
0
 
LVL 41

Expert Comment

by:stevenlewis
Comment Utility
in addition to the good advice above, check the policies on the machines, specifically network access policies
Run local security policy editor from control panel admin tools and set the local policy, Network Access:
0
 

Author Comment

by:jbarrington
Comment Utility
Messages: To diggisaur, To infotrader, To stevenlewis

To digisaur:
=========
That's correct. No firewall on the W2k except for ZoneAlarm Pro. Earlier in my trouble shooting, I disabled it on all three units for a period of time to see if it was causing my problems (without the cable modem being on).

Also,

For Desktop001 (W2k Pro), the Security Settings >> Local policy >> User Rights >> "Access This Computer From the Network", only had listed:

Administrators
Backup Operators
Power Users
Users
Everyone

For the Desktop002 (WXP Pro) computer:

Administrators
ASPNET
Backup Operators
Power Users
Users
Everyone

"Deny access to this computer from the network" was blank.


To infotrader:
==========

I deleted everything you mentioned except for:

“Client for Microsoft Network”
“File and Printing Services for Microsoft Network”
“Internet Protocol TCP/IP”

I did the deletions on Desktop001 and Desktop002. I then rebooted both.

(Note: During these troubleshooting tests that are being recommended, I felt that it might be best to skip any changes to my laptop until the two desktop units are corrected. This way if two of them get messed up, I can still access the internet and relay the results here.)

After each machine booted back into Windows, everything seemed normal at first. I tried both machines on the internet, and both still worked. However, the big changes occurred when either machine tried to access the other. Everything seems to have now reversed roles.

Before I describe what happened, let me take a moment to name my Windows workgroup “Network001”.

When I used Desktop002  (WXP Pro) to click into Network001, so that I could see if Desktop001 (W2k Pro) was showing, I received a surprize... an error message.

<SOM>
“Network001 is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

The server is not configured for transactions.”
<EOM>

I not only could not access Desktop001, but it seemed that I could not participate within the workgroup Network001. It can see the workgroup name, but it just doesn't seem to be able to enter it. I check to see if the network name was the same as I originally listed it under that computer, and it seems to be correct.

When I used Desktop001 to try and access Desktop002, another surprize... it now appears to work great. It can see and access everything that is being shared on Desktop002.

I decided to try and boot up Laptop001 (WXP Pro) to see what it could or couldn’t access. It could see itself within Network001, but it could neither see Desktop001 nor Desktop002 within the network workgroup. This is what I mean that everything appears to have reversed roles.

I decided to do a quick recheck of Desktop001 and now it could see and access the shared files on Laptop001, too.

I rechecked Desktop002 and it still gives the same error message.

I’m not too worried about Laptop001 for the moment, because if I can now get Desktop002 to see and access Desktop001, then I can applied the same changes to the laptop.

Although I’m not out of the woods, this appears to be a positive step.


To stevenlewis:
============

I didn’t entirely understand your suggestion. It almost looks as if a portion of your message was cut off in mid-sentence.
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 

Author Comment

by:jbarrington
Comment Utility
P.S. To infotrader,

I forgot to mention that I also pinged Desktop001 from Desktop002, and I received no problems. I can also access the router (to make setting changes) from any of the three computers.
0
 
LVL 30

Assisted Solution

by:Gareth Gudger
Gareth Gudger earned 150 total points
Comment Utility
Can you leave the firewalls down for a good half an hour on all machines. I don't think it is your firewalls but I just want to be doubly certain and sometimes the machine might take a good 5 to 15 minutes to show each other and start granting access.

Also, this person experienced the same error and claimed it was due to a virus.....
http://www.annoyances.org/exec/forum/win2000/1038386353

Another person said the IPC$ was not being shared....
http://www.annoyances.org/exec/forum/win2000/1045635398

Which seems odd to be as a reboot should reshare that unless you have specifically blocked it or a firewall is blocking it.

Some said "net share ipc$" was a temp fix from a command line.

Upon searching more resources they all seemed to lead towards viral infection that had stopped the IPC$ from functioning. Namely the MSBLAST virus that prevented the RPC from operating.
0
 

Expert Comment

by:Poofinger
Comment Utility


have you tried logging on to the xp machines a s a administrator that is listed on the 2000 machine.  It looks like a problem with user rights on a 2000 server.  Being that only admins can access 2000 servers that are Domain controllers.
0
 
LVL 11

Assisted Solution

by:infotrader
infotrader earned 350 total points
Comment Utility
Ok...  back to basics again.  It does seem that your situation is better, and for sure, not as confusing as before :-P

1.  Turn off all firewall software to eliminate confusion.
2.  Make sure the "Computer Browser" services is turned on under the Adminstrative Tools --> Services .
3.  Under your TCP/IP properties of all the comptuer, make sure that you enabled "Netbios over TCP/IP" under the Advanced options.
4.  When all else fails, remove the computer(s) from the workgroup and add them back in.
5.  When everything is working, you may then fine-tune your firewall settings.

- Info
0
 

Author Comment

by:jbarrington
Comment Utility
SUCCESS!!

Sorry it took a little long to get back and update everyone. This is really the first time that I’ve had to get back to this site and provide feedback.

Everyone’s been really great with helping. While waiting for more clues to try out this weekend, I was still trying different things on my own to try and correct my situation.

I think that I may have finally corrected the problem, but I want to share it here, so that it may be of some possible benefit to someone else. It doesn’t look like it was a virus, a firewall, or a hardware problem. However, I’m still not exactly sure what it was except related to some level of misdirection or corruption.

In an early message, I made mention that a directory on an USB hard drive kept showing up when it no longer was it the system. This ghost directory ended up being a very important clue to me. I’ll talk more about this in just a moment.

A second clue was from “infotrader” when it was later mentioned that that I should delete some of the protocols. Doing this basically reversed my problem on my computers. To me, this indicated that it wasn’t necessarily a hardware or a firewall issue.

Now back to the matter of the USB drive. Most of the things that I kept trying didn’t help before I came here. I couldn’t help but feel that I had a tiny setting out of place, or it was something that I could correct, but I’d forgotten about. When I later deleted the extra protocols and the problem persisted, but switched within the computers, I was beginning to think that it might have to do with a certain program and/or the registry. Other than trying to develop a connection with all three computers, the only programs that were having problems were the Windows Synchronize program and the Windows Explorer.

The Windows Synchronize program on the two XP machines would tell me that it couldn’t make contact with the W2k machine. It was trying to contact the USB drive that no longer existed. I had tried several times to turn the synchronize feature off, but it seemed to be ignoring it for some reason, and would re-appear turned on after each reboot or logon. I semi-ignored it because I thought it was due to my problems connecting the two XP machines with the W2k machine. From what I was seeing, I felt that if I could get all three connected again the synchronize problem could perhaps resolve itself, so this didn’t seem as urgent at the time.

I felt the Windows Explorer program wasn’t really as much a problem, as it was an indicator of something wrong. It kept showing the USB drive’s ghost directory every time I went to look at the network computer’s directory.

I used Windows Explorer to search for the problem directory, and it would see it within  the network. Area. I would try to delete it, but it would always reappear after each boot.

I decided to use Regedit to see if the problem directory existed within there. I found references to it, and I took a chance and deleted it within the Registry. The ghost directory within Explorer kept coming back. Windows had to be storing this non-existent USB directory information someplace other than the registry or as a directory name. It had to be within a file, but I did a more through search and still couldn’t find it anywhere.

I thought about this for a little bit, and what I did next was a little drastic. Against my better judgment, I decided to gamble and try several things all at the same time. Luckily, it seems to have paid off this time. I hate doing multiple fixes all at once because it can be hard to tell what work, or what just made the computer worse.

1. I disconnected each computer from the network. (I disconnected the Cat5 cable from Desktop001, and I removed the wireless G devices from Desktop002 and Laptop001.)

2. I disabled every “Shared” folder or file on that computer.

3. Starting first with Desktop001 (W2k Pro), I renamed the computer and the network workgroup. Then I rebooted.

4. I went into the registry and deleted every old key reference to Desktop001 and to anything that displayed the ghost USB directory. Anything that referred to sharing was deleted on the spot. (If the computer key reference looked extremely, extremely important, I felt a little more comfortable just deleting the value within the key.) Then I disabled (unchecked everything) the Windows synchronize. I rebooted again.

5. I double checked the registry for any references to the old computer name, the old network workgroup name, and the ghost USB. Everything seemed clear and I exited Regedit.

6. I reconnected the Cat5 cable into computer and back onto the wireless router and the internet. Everything seemed okay, but I did have to go back into properties section of the LAN card and then exit out of it before it started the signal again. I didn’t make any changes within the properties.

7. I designated one folder as a “Shared” folder.

8. I repeat the same process on the next computer, and then reconnected it back into the network. It worked, and now both computers could see each other.

9. I rebooted both of these computers several times and made sure they could see each other before I attempted the third and final computer. Everything seemed fine each time.

10. I repeated the same process to the laptop, and then reconnected it into the network. It was now seeing and accessing everything on the other two computers, and the other two computers could see and access it, too.

11. I waited several reboots before I decided to look into the Windows Synchronize program, but when I did, the ghost USB folder wasn’t there anymore.

I’ve waited a little bit to make sure that I wasn’t being too premature in announcing my (knock-on-wood) success.

The *only* thing that I can now tell is different is when I have Windows Explorer up and within the network workgroup area. It use to be that whenever I would startup, shutdown, or add another shared folder Windows Explorer would automatically refresh on it’s own and show the change. Now I have to click a different directory and then click back into the network see the changes.

Before I try to figure out how to award the points fairly, let me take until Wednesday or Thursday to make sure I’m out of the woods.
0
 

Author Comment

by:jbarrington
Comment Utility
Although no one was able to correct the problem before I solved it myself, infotrader did provide a bit of information that actually helped me narrow in towards resolving my issue. diggisuar pointed out a few things about the aministrator tools that made me think it might be a registry problem. The last entry that infotrader placed into the column showed me that (he or she) was on the right track when I announced that I had solved my problem.

I didn't want to leave without distributing the points, but I felt that it would be unfair to give a single person *all* of the points, since no person provided the fix.

I felt that infotrader and diggisaur mentioned several key words or made statements that helped triggered the natural direction for me to go. They also helped me argue with myself whether something could or couldn't be the problem, and if it wasn't the problem, what could it be.

I could be wrong in the way that I handed out the points, but I split the points, with infotrader getting the 2/3's bulk.

The answer that I posted as accepted showed me that it wasn't a problem with a virus, a router, or a single computer.

I want to thank everyone who helped me with my problem.
0
 
LVL 30

Expert Comment

by:Gareth Gudger
Comment Utility
Oh glad to help.... :)
0
 
LVL 11

Expert Comment

by:infotrader
Comment Utility
me too... glad to help...  There usually aren't just a simple answer that would explain all of the problems with the same/similar symptums, that's why a group effort such as the one provided by this site is always a good idea.  Glad you resolve the problem.

- Info
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

Greetings, Experts! First let me state that this website is top notch. I thoroughly enjoy the community that is shared here; those seeking help and those willing to sacrifice their time to help. It is fantastic. I am writing this article at th…
This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

7 Experts available now in Live!

Get 1:1 Help Now