Solved

InfoMaker chops off Long Character fields

Posted on 2004-03-27
6
471 Views
Last Modified: 2012-08-13
We have an ASA 8.02 database hosted on WIn2K server.  The database is used by our ERP software.  The software vendor recently changed several note fields to "long VarChar".  With the ERP app, we can enter & retrieve lengthly notes in the new fields.

We use InfoMaker 8 to create custom reports.  The problem we're having is that when InfoMaker fetches the field, it seems to only get the first 100 or so bytes of text.   We use ODBC to connect to the database.  When I connect using the ERP app, or Excel, or WinSQL, or Crystal Reports (all through ODBC) the entire contents of the field are returned, so I'm lead to believe that the problem is with InfoMaker.

Can anyone shed some light on this?
0
Comment
Question by:BudDurland
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 15

Expert Comment

by:namasi_navaretnam
ID: 10697591
Within datawindow, you will need to increase that char limit of the corresponding fields. In addtion enable 'auto resize' property to true on the datawindow field itself and the detail band.

regards-
0
 
LVL 15

Expert Comment

by:namasi_navaretnam
ID: 10697598
Also if using stored procedure make sure TEXTSIZE OPTION is set to a higher value or zero as the default.

SET TEXTSIZE     Specifies the maximum size (in bytes) of text or image type data to be returned with a select statement. The @@textsize global variable stores the current setting. To reset to the default size (32K), which is also the maximum setting, use the command:

set textsize 0

I am assuming that data is retrieved but not displayed because char limit property has not been increased on datawindow field. But setting 'auto resize' property on band and field is also important.

regards-
0
 
LVL 17

Author Comment

by:BudDurland
ID: 10703623
This is not a PowerBuilder datawindow; it's an InfoMaker report.
0
Free Tool: Postgres Monitoring System

A PHP and Perl based system to collect and display usage statistics from PostgreSQL databases.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
LVL 15

Expert Comment

by:namasi_navaretnam
ID: 10704069
Yes. But the same idea applies.

Click on the report field. Select Edit tab from the Properties pane. You will see limit property. You can increase the Limit to match the table definition.

Regards-
0
 
LVL 17

Author Comment

by:BudDurland
ID: 10709956
I had tried seting all the character size limits I could find before askign the question, do no avail.

I did, however, find the answer.  Dropping the field from the report, and removing it from the SQL SELECT statement took care of the problem.  It didn't work on the first try though --  I had to remove the field, saved the report, restart Infomaker, then re-add the field
0
 
LVL 5

Accepted Solution

by:
Netminder earned 0 total points
ID: 10710660
User resolved; points (250) refunded and question closed.

Netminder
Site Admin
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Excel Code not seeing ODBC driver for Sybase 1 1,083
installing Sybase IQ express edition 15.4 16 901
Sybase 15.7 database backup 8 658
performance measure of  running SSIS package 4 227
Read  the original post  on Monitis Blog. Hi.  My name is Erik Dietrich, and this is the first time I’ve posted on the Monitis blog.  By way of introduction, I thought it would make sense to talk about my initial experience with Monitis.   Befo…
Building a cohesive image for your brand is vital to making an impression on consumers. When the economy is tough, brands do better than unbranded  products. This can have a huge impact on your long-term profits, as the economy goes up and down.

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question