We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

ERROR: The 'select into' database option is not enabled for database 'ipaddb'.

vpolonsk
vpolonsk asked
on
Medium Priority
15,641 Views
Last Modified: 2010-10-05
Hi,

I need to drop a column and im using this sql:

alter table Attachment drop attachmentType

i get this error message:

ERROR: The 'select into' database option is not enabled for database 'ipaddb'. ALTER TABLE with data copy cannot be done. Set the 'select into' database option and re-run.

seems clear, i set this option and everything should be ok, so i run this:

--------------
use master
go
sp_dboption ipaddb, 'select into', true
go
sp_helpdb ipaddb
go
--------------

and the options seems to be set since i receive this output:


name        db_size     owner       dbid        created     status
----------  ----------  ----------  ----------  ----------  ----------
ipaddb                   |      250.0 MB | ipad                     | 39         | Dec 01, 2003   | select into/bulkcopy/pllsort, trunc log on chkpt, abort tran on log full |

----

but, for some strange reason - it doesnt help, i get the same error as before:

ERROR: The 'select into' database option is not enabled for database 'ipaddb'. ALTER TABLE with data copy cannot be done. Set the 'select into' database option and re-run.


PLEASE HELP!!!!!
Comment
Watch Question

Author

Commented:
ok.. figured it out on my own:
needed to use checkpoint command, so this worked :
--------------
use master
go
sp_dboption ipaddb, 'select into', true
go
use ipaddb
go
checkpoint
go
sp_helpdb ipaddb
go
--------------

Commented:
You should always listen to your database :)
If you do a sp_dboption it returns that you must do a checkpoint before the change has effect....
Commented:
Unlock this solution with a free trial preview.
(No credit card required)
Get Preview
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a free trial preview!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.