We help IT Professionals succeed at work.

Network initial setup

Last Modified: 2013-11-29
OK - I set a new network for the first time. I am able to connect to the internet from my WIN98 Desktop & Laptop to my XP desktop DSL connection. I am trying to share files and printers but the XP machine does not know it is on a network, nor do the other machines. When I use the network wizard it says this computer is not connected to a network.

When i setup my router it set up its own Local Area connection pro /100ve. It did not use my original DSL connection PPPOE.

Now I have messed with the  proprties of the LAN connection and added Sevice Advertiseing & file & printer sharing & internet protocol. I don't know what I am doing so i am doing everything.
Watch Question

Need some more information

Need all the equipment (everything, computers, routers, dsl modem) you now have on your network, then we can go from there.

HI slicktoo,

lets start from basics.  Before we start to advise you, what system have you got now?  Does your ADSL router connect directly into a computer, or does it connect into a switch? How are your other computers connected? Can you post a few details of your router and/or adsl modem (eg d-Link xx123)

I'm guessing now re your setup - If you have a router AND an ADSL modem, then the router should be connected to a switch, not a computer.  

I'm happy to assist, but need a bit more clarifying info.




I have a DELL Desktop with a Ethernet network modem which I used to use to connect to the internet. I then bought a D-Link wireless router DI-514. I installed a wireless router on a DELL desktop WIN98 with Microsoft MN-510 wireless B adapter. I installed a d-link DWL-650 card on my DELL laptop WIN98.

I do get internet access on all machines but I don't have a network recognized by any machine.

On your desktop - this is the WinXP machine right?  from a command prompt, can you type ipconfig /all and paste the results - second thought, do that from all the computers - this will give us a complete picture of your network.

From the fact you have inernet access from all machines, it soulds like you've got almost everything right.  It may just be that you haven't shared a folder anywhere - don't be too concerned about "my network places" saying it can't find a network - If everyone can see the internet, you have one ;)  

Share a folder on a windows 98 computer, and try to map a drive to it from the windows XP computer, using the IP address (you will get that from apconfig /all) and the share name ie: from the run command type \\\sharedfiles see what you get.


If its a hassle getting the info from ipconfig on the win98 into this post you can also type winipcfg from the Run command and write down the info...  particularly IP address.

Good article eddkhamou.  


THANKX - I'll try tomorrow - gotta go now to enjoy Sat Nite!

Just a guess but I bet your protocols are off. On all machines make sure that the TCP/IP protocol is installed and enabled. Also install IPX/SPX NetBIOS compatible protocol on all machines. Make sure that all the machine names are unique. Use the same workgroup. Enable printer and file sharing on all machines (network SERVICE). And make sure that the Client for Microsoft networks is installed.

It is a common mishapp with XP. The best way to set up a small net work is to use TCP/IP and Netbuei but xp uses NetBIOS (IPX/SPX) so use TCP/IP and IPX. It's browser master issue. If you look in your error log for your XP system you should see this error.

Good luck

If I can be more of assistance I am here.


hi ...
first u clear me the senario....u have 2 internet connections one is laptop other is on desktop....all the systems r in lan....right..u want the communications between these system on internet or intranet ?......if u wan comunication localy through lan...u ping all the system on the local network..is it pinging with each other.check it first..tell me the correct scenario.

manoj vahinipati


I will try to answer all your suggestions.

A fact first:

I get an error message when I boot the XP machine stating “there is a duplicate name on the network” I close that window and the computer completes the boot.

On the WIN98 Desktop I get a similat message


I run ipconfig/all in dos but do not know how to copy/paste in a dos screen.

How do I share a folder and map a drive to it? I afraid you will have to spell that procedure out for me.

I went to the website you suggested but got lost pretty quick. I did add file & print sharing to all machines. & changed the workgroup computer name and description.


The laptop WIN98 computer reads:

D-Link air DWL
Adapter address: 00-0d-88-52-12-do
IP address:
Subnet mask:255-.255.0
Default gateway

The Desktop with WIN98:

3com 3c90x etherent
Adapter address: 00-50-da-67-35-91
IP autoconfig address:
Subnet mask:255-.255.0
Default gateway – blank


How do I enable file & printer sharing?

I changed all to a unique name – I no longer get the error messages at the top.

Now where do I find the other computers on the network on XP & WIN98? In my computer?

Thank you all for your efforts

Doing well...

Lets work with your 98 laptop for a second.  To set up file and printer sharing, go to netowork properties (from contol panel or right click network nieghbourhood) There is a button called "File and Printer Sharing" Click on that and select the checkboxes you want.  Say OK, and OK again, windows will prompt for a reboot.

When windows restarts you can then start sharing whatever files or directories you want.  For example, if you want to share the C Drive, you would open explorer, right click on the c: drive icon, select "Sharing"

A Window comes up, with radio buttons for "Not Shared" and "Shared As:"  Select shared as, then give a name - (Use a simple one) such as "Files" (No quotes).  You can also change what rights people connecting to the share will  have - read-only or Full control.  In this example, set it to Full, and click ok.

You have now created what is known as a Share.

Lets try to connect to that share.
On the Windows XP machine,  open explorer, from the tools menu select Map Network Drive.  Select a drive letter (any will do)  The type in the name of the share, this is in the following format:
\\<name of the computer you are connecting to>\<Share name> or, so if your win98 laptop were called Harry then it would be \\Harry\Files

Sharing on Windows XP:
Create a folder you wish to share, or use an existing one.  File sharing is already enabled, so the process is simpler.  Right click on the folder or drive, then select sharing sharing and security.  You will be presented with a window with two sections:

Local Sharing and Security, and Network Sharing and Security.  Depending on what you have already tried, the lower section may have a line along the lines of "Enable sharing ...." or it may have a check box saying "Share this folder on the network"

If this check box does not exist:  Click on the words, It will prompt you asking approximately "Do you understand the risks of sharing files on your computer?" answer yes, it will then as you whether you want to run the wizard, or enable simple file sharing, select Just enable sharing.

Click the Check box "Share this folder on the Network" and give a name - again, something simple, like XPFiles or whatever.

The checkbox below is like the option in windows 98, for read only or full access.  The default is read only.

When you click ok you're done.

You can connect to this share from the laptop in the same way as described above.

Almost there....

The desktop 98 workstation seems to have a Network card installed; does it also have a Wireless card?
You can see what is cards are being used by typing "winipcfg" from the run command.  A window titled "IP Configuration" will come up There wil be a drop down list, there should be an item with 3com 3c90x ethernet, and hoepfully also with something more like D-Link air DWL; if there is, select it and check the IP address line.  If it reads 192.168.0.xxx you are working, you just have to go through the steps listed above to enable file sharing etc.

Printers are pretty much the same principle...

I've got to go to work :( Its 7:15 in the morning here) Let me know how you get on.


When I get to the point of mapping the connection - I get an error message  -- cannot find network path. When I browse it only finds my XP machine not either of the WIN98 computers

Follow these steps on the XP machine.

Enable NetBios over TCP/IP in WIndows XP

Step 1: Turn On NetBIOS over TCP/IP

1.  Click Start, click Control Panel, and then click Network and Internet Connections.
2.  Click Network Connections.
3.  Right-click Local Area Connection, and then click Properties.
4.  Click Internet Protocol (TCP/IP), and then click Properties.
5.  Click the General tab, and then click Advanced.
6.  Click the WINS tab.
7.  Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.
8.  Click Close to close the Local Area Connection Properties dialog box.
9.  Close the Network Connections window.

Step 2: Start the Computer Browser Service

1.  Click Start, right-click My Computer, and then click Manage.
2.  In the console tree, expand Services and Applications.
3.  Click Services.
4.  In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.
5.  Close the Computer Management window.

Disable the Authentication for the Wired card.

1.  Click on the Wireless Connection Icon in the bottom left corner of the computer screen
2.  Click on Properties when the Card Status Dialog box opens
3.  Click on Advanced
4.  Under Internet Connection Firewall make sure the box is UN-checked
5.  Next, click on Authentication
6.  Uncheck the 'Enable IEEE 802.1x authentication for this network'
7.  Click OK


I was not able to Disable the Authentication for the Wired card since there is no Wireless Connection Icon in the bottom left corner of the desktop.

Using all the suggestions above - I currently have been able to print from the WIN98 Laptop to the XP computer.

Day 3 - Moving right along!
Sorry Slick replace wireless with wired in the above post.


1.  Click on Start>Settings>Network Connection.  Then right click on the Connection you are using.
2.  Click on Properties when the Card Status Dialog box opens
3.  Click on Advanced
4.  Under Internet Connection Firewall make sure the box is UN-checked
5.  Next, click on Authentication
6.  Uncheck the 'Enable IEEE 802.1x authentication for this network'
7.  Click OK



An update: When I open My Computer on the XP machine and clicking on My Network places the other 2 computers shared files & folders are visible with a generic appearing icon  and in the computer column is is written 'unknown'.

Clicking on these icons does nothing.

did you put your username and password as users on the 98 machines, if not you need to.


Don't know. How do i check & how to I do that.

Open network properties on the windows 98 computer.  Just above the file and printer sharing button, there is a Primary Network Logon drop down list - select "Client for Microsoft Networks"  When you reboot the computer will ask for a username and password.  Use a name and password that is on the XP machine.  The default user on a standard XP build is Owner, with a blank password.



MBR1971 & eddkhamou

Thanks for your help thus far. You have corrected most of my problems. But on both the WIN98 laptop & WIN98 desktop I have installed my hp photosmart 7960 printer 4 times. It refuses to show up in START-SETTINGS – PRINTER list. Also on the WIN98 desktop only the local laser printer shows even though I was able to install the XP desktop laser printer on the laptop and it works. When I install the XP laser it also refuses to show as an option to print to.

I am able to share files on all the networked computers. I just can’t print to the 7960 from either. When I go to Network Neighborhood the hp 7960 & XP laserjet show as being shared but I don’t know how to print to either without them showing in FILE PRINT printers.


Another point - on my XP computer when I try to share the phosmart printer & click on additional drivers - WIN98 - the computer freezes  up when I insert the WIN98 disk when asked for it. Of course the laser  printer does not have additional drivers installed and the laptop can access it. So....?

Install the printer one one of the computers and share it.

From the other computers do not use the add printer wizard

Click on my network places on the XP machine
Double click on the Windows 98 machine
Double click on the Printer Icon

This will install the printer on the XP machine, it may ask for the drivers disk.

I don't remember if you can do the same thing with 98 but try it anyway.


If the printer shows up in the browse list , you should be able to right click on it and then click on install.  

Don't try to install additional drivers on XP, this often gives problems (as you have discovered).  When you connect to the XP Laser on the 98 machine it will prompt you for drivers.  (What sort of Laser is it?)  Don't go through any installation wizards ect that are on the CD when you are just installing the drivers, there should be a directory somewhere which just contains the INF and DLL files... they usually call the directory Drivers, and put it under something like \EN\WIN9x\Drivers  

If it is a "Windows Printing System" like some Canon and Minolta printers, you may not be able to share it without a lot of mucking around...



Again THANKS - I'm away till Thursday, late, and will concentrate on your answers then.

I am dealing with a HP 1200 LaserJet and a HP Photosmart 7960 printers. They do show in the Network Neighborhood but no where else. I have installed them many times but no luck on showing up in the printer area or in file - print - select printer.


I tried again but aIl get is a message -  this printer is already installed on this computer -  just connect the printer and it will work. When I try to print from any program the printer does not show in the list of printers to select. It does show in Network Neighborhood.
Unlock this solution and get a sample of our free trial.
(No credit card required)
Unlock this solution and get a sample of our free trial.
(No credit card required)


Ed, I did change the name to 8 letters - it was 9. When i try to install the printer  i still receive an error message it is already installed even though it does not show up in the printer list anywhere.

On the XP machine in additional drivers when I check WIN98 i get a message - Cannot create a file when the file already exists.


In 'my' morning 12-15 hours from now I will try your suggestion. "Where in the World are you" anyway.

hey slicktoo....

so u r trying many time doing the same...
when u r installing the printer in XP mac...as administrator...
try this...u r installing HP 1200 laserjet right ?
u can install it in the TCP port...u have the IP of the printer ...

PIng  the printers iP 1 st...if pinging
add printer n select local printer in the drop down list of port select tcp port and configure it with printer iP say ...

try this fast it will work.

accept the answer
i forgot 2 tell one step XP prompts to give access to other user in this computer u say yes..

and share the printer if u want to make prints through this mac...i f not

do the same cofiguration all the clients



I am sorry manojvahinipati - I do not understand your instructions - that is why I did not answer your first comment. I do not know how to ping the printers.

I am trying to have my WIN98 machines, desktop & laptop recognize a HP Photosmart 7960. The drivers are installed on both machines several times but do not show up in the list of printers anywhere.

I even downloaded new drivers from HP specifically for WIN98.


THANK YOU mbr1971 and ED. You two are terrific and stuck with me long enough so WE finally solved the problem. Your patients is cetainly appreciated. I split the points btween you two but could only accept one answer. Doesn't seem fair since all your answers eventually helped.

Finally Iwas able to install the photosmart by finding the inf file in a subfolder's subfolder hidden away.

Thanks again - all is well in my world again. Now how do I make this network secure? Oh well thats for another day.

Hey Slicktoo

Glad you're working :)  Thanks for splitting the points.  I live in Australia, which is around 14 Hours ahead of the US (I'm guessing that's where you are)  Makes it pretty hard to follow some of these threads ;)

Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.


Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.