We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

Avi in Director MX

Medium Priority
3,105 Views
Last Modified: 2013-12-24
Hi, i'm using director mx and i recently consturcted a movie player for my web site which would play avi's. The problem is, when i upload the swf file to the ftp along with the movies, it keeps telling me it cant find them. Can someone help me remedy this problem as i have been trying for a while and have had no luck. Thanks in advance.
Comment
Watch Question

First, SWF is Flash, not Director.  As to the paths, make sure the same relative location is preserved and that the pathname is hte same (case sensitive for some servers.)  You may have better luck with something streaming as well like QT or Flash video.

Author

Commented:
Is there anyway (for free) that i can convert my video to quick time? And what is flash video?

Commented:
If you have Adobie Premier, you can export it as quicktime.

I use sorenson squeeze --> www.sorenson.com -> for mpeg 4/quicktime..... also quicktime pro ->http://www.apple.com/quicktime/download/ --->  but niether are free.

Here are some free solutions that might work ->
http://www.divx-digest.com/software/smartvid.html
http://www.downrecs.com/software.html

                                     <-Also you could look into ->
                        www.microsoft.com/windows/windowsmedia
                                             www.divx.com

*Newer versions of macromedia flash have support for video streaming. Moe people probably have the latest flash plug-in, than thos with QT or divX. Issuses to conssider are the normal bandwidth of your target audiance.

Author

Commented:
Ok, I stupidly forgot to install quick time after i reformatted recently which explained why i couldnt import my avi files in as quick time. Now i have changed everything to have quick time functionality. but now when i upload it, it tells me:

"This application an Xtra (quicktime) that does not exist or failed to initialize properly. Please make sure the appropriate Xtras are in the Xtras Folder(s)"

When i go to the xtras drop down menu in director its very confusing so could you pleae tell me what i have to do for this? Is it as simple as just exporting all files to a folder and then uploading it to my ftp?
Modify>Movie>Xtras.  Select the QT Asset Xtra and click download if needed, then republish.

Author

Commented:
ok, i did that, but when i load it up it still doesnt load the video, although it doesnt give the previous error. Do i just upload my videos in a folder called xtras?
The videos need to be in the same folder as the movie and ideally set to stream or preload in the Xtra properties.  Make sure to always retain the same relative paths as you authored in.

Author

Commented:
Gahh!!! when you say the xtra properties, what do you mean because when i go to the xtras drop down menu it doesnt give me any options to do what you say.
Sorry, in the cast member itself.   Sorry for the confusion.  Click on the cast member and check the options in the property inspector.

Author

Commented:
ok, i've done that, but still it doesnt show up when i load it. I set the file path for the file in my ftp and uploaded the video but still nothing. Surely there must be someway of exporting the .swf file with the avi included all together?
You keep mentioning swf, do you mean DCR?  just making sure as Flash and Director are very different animals. :)

Does the video load if you let it sit there a while?  Does it work locally?  (remember that locally everything must be in a folder named dswmedia to allow local acces of files.)  

Do you get a red X or just nothing?  Try including the playbar as well to see if its just starting paused, etc.

Author

Commented:
ok, heres exactly what i'm doing:

I'm using director to build sectoins for my website. I then publish each section as .swf along with the reletive .htm file. When I preview in the broswer everything is fine. But not when i upload to my ftp.

The reason i dont use DCR files is because they are too large and not everyone can view them unlike swf.

Does this give you a better understanding of what i may need to do? I have uploaded the videos to my ftp and tried setting the path in the movie properties to the location in the ftp but that didnt work either. I'm a bit stumped :/
Ok, but if you are making SWF files then it is not in Director, its in FLash, right?  If you jsut change the filename then its still a DCR, just with a swf extension.  Just trying to determine what program you are using here.

Author

Commented:
lol, I assure you i am using director MX. And yes, you know when you go to the publish settings, its default is in dcr format, but i change this to swf for the simple reason its recognised by more users and is smaller in size.
But Director does not publish SWF. :)  What you are doing is making a DCR file and naming it swf.  Flash still can not play it, only Shockwave.

Aside from that have you tried the control bar idea?  Also you might (jsut to test) want to use something like this on the video sprite...

on beginSprite me
  alert(sprite(me.spriteNum).member.filename)
end

This will tell you where its trying to look for the video.

Author

Commented:
Hmm, thats weird about the swf. It does come up as a flash file when i publish it and is considerably smaller in size than the dcr. I have put a control bar on for a change from the buttons i made to control the movie but no change.

The script you have there, can you give me an example of how i should type it? Ythe cast member i am trying to get to play is called 'phto003.avi' and its on channel number 7.
Just make this a behavior and drop it on the quicktime sprite...

on beginSprite me
  alert(sprite(me.spriteNum).member.filename)
end

But check the code in the HTML.  I bet it is still showing hte plugin space as Shockwave.  Director can not publish to Flash.

Author

Commented:
I put the code you said onto the sprite and it told me where it was but how does this help me?
Is the path correct?  Thats the first check.  Make sure the file location matched the server file location.  Also, did you try the tool bar?  THis will let you see if its loading.  Sometimes it will stay paused if it can't load fast enough.  If this is the case I can help with code there too.

Author

Commented:
ok, when i uploaded it did show the path name of the video in my ftp. Still it wouldnt play. When i check my connection to see how much information i'm recieving its nothing, only the bog standard traffic from msn messenger etc. I get the tool bar to come up and thats it, no loading and no frame where the video would be. Hope you can help. Cheers
Can you show me the URL where this is posted to test?  Can you access the QT directly via the browsser?  Did you upload both in binary mode instead of ASCII?

Author

Commented:
uhh, i dont know about binary and ascii modes, but heres the url:

www.invisibledanger.com/beetle.htm

If you cant access through that, go to www.invisibledanger.com and go to visual>launch video player>then select beetle from the drop down menu to the left.
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
:S oh my god, i dunno what going on!!!

Author

Commented:
Right, i think i got it now, you know you set the path for the video, instead of putting ftp://invisibledanger etc... i put in just www.invisibledanger.com/phto003.avi?

Author

Commented:
or phto0003 rather

Author

Commented:
Got it sorted, Thanks a lot for all your help mediamacros :D
Glad you got it.  :)  Sometimes these can be difficult to debug because its a blind guess.  Use things like alerts, etc to help you narrow problems.  Let me know if you need anything else.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.