Want to network 3 W2K and 2 XP machines...?

I'm running 3 Windows 2000 Pro and 2 Windows XP machines in a small office.  They all have online access through a cable router.  I want to be able to use file/print sharing and need a few pointers.

I know I need to:
1)  Assign unique computer names under the same workgroup but one W2K machine will not allow me to name the workgroup despite full administrator access....?  I read something about "installing networking"....?  So far the following are installed:
Client for Microsoft Networking (isn't this the networking I need?)
QoS Packet Scheduler
File and Print sharing for Microsoft Networks
NWLink netbios
NWLink IPX/SPX/netbios compatible transport protocol
TCP/IP
Seems like those should more than accomplish what I need.
2)  Despite the fact that they are somewhat networked already, do I still need to assign unique IPs (192.168.0.*)?
3)  If so, do I need to create a new/seperate network connection to accomplish this since they now obtain IPs automatically?

Those are the basic points I'm stuck on.  If I missed anything else please advise.  Thanks to all.
LVL 1
wec012299Asked:
Who is Participating?
 
Fatal_ExceptionSystems EngineerCommented:
Ok...

1)  Yes, you need to have all your systems in the same workgroup, with unique names so Netbios can 'discover' them..  I am not sure why you cannot change that workgroup over..  Something else is going on with this system.

Note, if you are not running Novell, you do not need the IPX or NWlink configured..  This will cause undue overhead on your systems..  All you need to do is enable Netbios over TCP/IP and you will be fine..  Additionally, if you are using static IP's, you can edit your host files and enter the path (192.168.1.x    computername)..   but the most important thing is that you ck the box in your TCP/IP properties to allow for Netbios..  this should resolve the computernames for you..

2)  Since you will be using Netbios over TCP/IP, you can use DHCP to issue IP addresses for your network..  But if you want to use the host file, you will need static IP addressing..  DHCP (from your router) will give all your systems unique IP addresses for you..

3)  No, your present config should work just fine..  

Any questions, just ask..

FE
0
 
sirbountyCommented:
First of all - get rid of NWLink, unless you're connecting to a Novell network - these aren't needed.

As for TCP/IP - if you're getting a DHCP leased address(192.168.x.x) on all machines, that should be enough.

Need some more info on the w2k machine that won't allow you to change the name - what error are you getting?

The XP machines - are they Pro or Home edition?

Try these steps:

Disable all firewalls for testing.  This includes Zone Alarm, Norton Internet Security, etc.
   Including XP's ICF...
   From Control Panel, open Network Connections.
   Right-click Local Area Network from Control Panel's Network Connections and choose Properties
   Click the Advanced tab and deselect (remove the checkbox from) "Protect my computer..."
   Click OK and close out of Network Connections & Control Panel

Enable NetBIOS over TCP/IP:
   XP utilizes DNS for communication by default.  To enable the systems to communicate via NetBIOS,
   proceed as above to enter Network Connections.
   Right-click your Local Area Connection and click Properties
   Scroll down in "This connection uses the following items:" to find Internet Protocol (TCP/IP)
   Select it (highlight it) and click properties
   Click the Advanced button on the General tab.
   Click the WINS tab.
   Under NetBIOS setting heading
    Click Enable NetBIOS over TCP/IP
   Click OK, OK, OK and close out of Network Connections & Control Panel

Disable Simple File Sharing on the XP machines
    Right-click the Start button and click Explore
    Click Tools then Click Folder Options
    Click the View tab
    At the bottom of the Advanced Settings list, deselect (remove the checkbox from):
     "Use simple file sharing (Recommended)"
    Click OK

Let Everyone's permissions apply to anonymous users as well:
    Click Start
    Click Run
    In the Open box type SECPOL.MSC /S <ENTER>
    Navigate to Local Policies/Security Options.
    Double click "Network Access:Let Everyone permissions apply to anonymous users"
    Click Enabled and click OK


Some helpful links:
http://www.microsoft.com/windowsxp/home/using/howto/homenet/default.asp
http://www.practicallynetworked.com/sharing/troubleshoot/
http://www.homenethelp.com/web/howto/net.asp
0
 
Fatal_ExceptionSystems EngineerCommented:
Well, you beat me on that one SB...   :)
0
Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

 
sirbountyCommented:
Well, I got back in time to 'play' a little...:D
0
 
Fatal_ExceptionSystems EngineerCommented:
BTW:  nice instructions...  
0
 
sirbountyCommented:
Well thank you FE.  Some of course off the top of my head, others from the SBKB...
0
 
wec012299Author Commented:
When trying to run secpol.msc /s on one of the XP Home machines I get the following error:
"Windows cannot find 'SECPOL.MSC'.  Make sure you typed the name correctly, and then try again."  ....which I did several times.  It does work on the W2K machine whose workgroup I am unable to change.....go figure.

The workgroup issue does not give me an error, it's just that the "Network ID" button is dimmed out, not selectable, almost as if that feature had somehow been disabled.

BTW, both use XP Home.



0
 
sirbountyCommented:
XP Home?  Aw man - I thought this was going to be easy!  :)
XP Home isn't the edition for network - XP Professional is.
There are some ways to force it to work, but they are often quite cumbersome.

Let's start with the W2k machine...

Try this:  From network properties, remove ALL clients/protocols/services...
Now from device manager (start->Run->devmgmt.msc) - scroll down to network adapters and remove the NIC that's under there.
Reboot.  Windows should reinstall the NIC for you - go back into network properties - if it hasn't added a minimum of
Client for MS, File & Print, and TCP/IP, add them manually (Client/Service/Protocol in that order).

Now try changing the workgroup...
0
 
Fatal_ExceptionSystems EngineerCommented:
But..  XP Home will work just fine in a workgroup..  Pro is really for use in Domains, so this should not be an issue..  You will want to map the printers and whatever shares you want to access, at least this is the easy way to do this..

To map the shares, you will be using this command...  It can be placed in a batch file, and loaded on startup, or just placed on your desktop and executed as you will..

net use x: \\"computername"\"sharepoint" "password"  /user:"username"

Follow SB's advice on that W2K box though and get back to us after..

FE
0
 
wec012299Author Commented:
Also, firewalls are disabled.
0
 
wec012299Author Commented:
<At the bottom of the Advanced Settings list, deselect (remove the checkbox from):
     "Use simple file sharing (Recommended)">

FYI, I don't even have this option under advanced settings...
0
 
sirbountyCommented:
You won't in XP Home...
0
 
wec012299Author Commented:
Gotcha.  OK....I left my NIC and my TCP/IP alone and just uninstalled clients and services.  Rebooted, reinstalled clients and services....bingo!  Moving right along...

I'm a little unclear about the shares mapping.  I'm assuming this is what authorizes all machines to access, for example, the printer....creating a batch file and loading it on startup sounds like the way to go...only thing is I wouldn't know the first thing about it.

net use x: \\"computername"\"sharepoint" "password"  /user:"username"

computername - makes sense.
sharepoint - means nothing to me.
password/username - where does this come from and how/where is it defined?

Also, would this batch file (.bat?) run as a startup item on every machine?  



0
 
wec012299Author Commented:
The pain for you guys is almost over and this net-newbie will be on his merry way.  Thanks for your patience.
0
 
wec012299Author Commented:
Under "Computer Management" on the XP machine I went to "Shared Folders", selected "Shares" and received the following error:

The following error occurred while reading the list of shares for Windows clients:
error 2114.  The server service is not started.  

Which server is this referring to?  
0
 
Fatal_ExceptionSystems EngineerCommented:
Lets start with the last comment regarding the server service...  Start > Run > Services.msc (ok)..  This will open up your Services Window..  Look down the list until you find the Server Service..  Open it and make sure it is set to start automatically..  If it is not started, go ahead and manually start it..

Now...

sharepoint = the sharename that your created..  In other words, every folder that you share has a name, so that name goes in the net user line to identify what share you want to connect to when executed..

If you password protect your folders or use different usernames that are not defined as user profiles on the shared system, you must authenticate to the shares.. so you must place these credentials in the command..  This only makes it easier to connect..  Not a requirement though..  

Get your shares set up first and we can proceed with the next step after..

FE
0
 
sirbountyCommented:
If I might elaborate on those fine points sir...

Let's say computername= MyPC1
sharename is = MyImportantDocs
Username is =Fred
Paswword= behemoth

You're better off having the same account and password for every account in a workgroup network...so Fredd/behemoth is on all machines.

Now, you may can avoid the batch file if you run it the first time this way:

Start->Run->CMD <enter>

Net use \\MyPC1\MyImportantDocs /user:Fred behemoth /persistent:yes <enter>

Good luck, er net-newbie?  :D
0
 
wec012299Author Commented:
There is no server service on the XP machine, I did find it on the W2K.
0
 
Fatal_ExceptionSystems EngineerCommented:
See if you can create a share on your desktop..  Create a folder, then open up its properties..  Go to the Sharing tab and select to share the folder...  Perhaps the following will help you..

Description of File Sharing and Permissions in Windows XP

http://support.microsoft.com/default.aspx?scid=kb;en-us;304040#appliesto
0
 
wec012299Author Commented:
We're almost there folks!  Everything is working great, I can see each machine in "My Network Places".

Just one problem....when I try to access a shared folder from an XP machine on a W2K machine there's no problem.  Accessing the shared folder on the W2K from the XP is another story.  It's asking for username/password.  Now, from command line I did enter the "Net use" line as instructed.  However, I'm thinking my syntax may have been off.  I should probably be specific with my path....no?  Sirbounty's example from above:
Net use \\MyPC1\MyImportantDocs /user:Fred behemoth /persistent:yes <enter>
....This line assumes MyImportant Docs is where exactly?

Bottome line: I get a user/pswd dialog and my user/pswd does not work.  

I checked out the sharing/permissions article suggested by FE, but wasn't helpful in this regard.

Almost done....just get me over the hump.  Thanks.

0
 
wec012299Author Commented:
Never mind, I'm over the hump...mission accomplished.  Thanks all.  
0
 
sirbountyCommented:
Great!
Just to respond to your last question there though..

Let's say you've got a directory listing of

 C:\Data

You can actually share that out with any name...
From a command line type (you can of course do this through explorer - I'm just more of a command line person...)

 NET SHARE MyImportantDocs=C:\Data

Now, it's shared MyImportantDocs.
But you could have that same share on a folder contained here:

 D:\DavesStuff\2004\TaxData\FileCopes

A share can basically point anywhere on your system.
Printers work the same way for the most part...you can share them with any name.

By default, your system has each drive already shared as C$ or D$ or whatever drive letter (the $ indicates that it's a hidden share).
Hope that helps clear things up a bit.  Thanx.
0
 
Fatal_ExceptionSystems EngineerCommented:
Nice...  Glad to see we are wrapping this up...  

just to expand a little on shares..   If you go to Start > Run > and type in: \\computername  this will connect to your remote client and throw back all the shares on the system..  It does not matter where they are located in the directory structure..  And with a hidden share symbol, you can bring back the entire tree..  For example, \\computername\C$ will open the root drive of the system..   Not the most secure, but as long as permissions are set, you should be okay..

The $ can also be used to hide a share..  Say you want to share a folder, but want to keep it hidden from computer browsers..  Just append the sharename (data$)...  Although it is still a share, it is hidden from public view..

FE
0
 
sirbountyCommented:
...and to add to that insightful comment. :D (this is fun!)

You can simply type

 NET SHARE

from a command prompt to get a listing of ALL local shares and their relative path ( \\computername won't show you the hidden shares.
0
 
Fatal_ExceptionSystems EngineerCommented:
yea..  this is the way a thread should go, with the experts expanding on each others comments..   A good example of the proper way to progress to a solution..   :)
0
 
wec012299Author Commented:
You have both been great.  Thank you very much.  I agree with you FE, this was a text book illustration of how this site can best be utilized.  For several years now I've used experts-exchange and it's always been an excellent resource.  However, this was truly the most concise and worry-free experience.  Some "expert" responses I will take with a grain of salt.  You two not only made a great team, but the label expert is well deserved.  Now I'm just working on increasing points and splitting them evenly.  Thanks again.
0
 
Fatal_ExceptionSystems EngineerCommented:
Thank you wec..  Nice working with you and glad we could help..

FE
0
 
sirbountyCommented:
Haha - that's cause FE and I were seperated at birth...
I just don't understand why he won't give me his current address and his phone number says it's been changed to a non-published one...what's that about? :D
0
 
Fatal_ExceptionSystems EngineerCommented:
hahaha...  It really is non-published too..!!!
0
 
sirbountyCommented:
I know!  I can't find Fatal_Exception on anywho.com
I've written the site authors, but they insist they have explicit instructions from you to not share it out...
I'm crushed!  (:-{
0
 
Fatal_ExceptionSystems EngineerCommented:
But if you google for it, you can find me here..!!  
0
 
sirbountyCommented:
No kidding!
0
 
wec012299Author Commented:
Funny thing is, as it turned out one of the XPs was Pro...only one out of the bunch.  XP home and W2K machines recognize each other just fine.  I can see the XP Pro from other machines but cannot access shared folders.  Something about unable to access/permissions, etc.  I tried with simple sharing both enabled and disabled but no go.  Made sure they were all configured the same but I have a feeling I've missed something about the XP Pro.  Ironic considering the XP Pro is the one you want to network, and it's the only one giving me problems.  Luckily sharing for that machine is not essential.  
0
 
Fatal_ExceptionSystems EngineerCommented:
Open up the properties of one of its shared folders and access the Security Tab..  Make sure that the user you want to have access this folder has the proper permissions there...  (Read/Write/etc)
0
 
wec012299Author Commented:
I'll give that a try...thanks.
0
 
Fatal_ExceptionSystems EngineerCommented:
Thanks..  and good working with you and SB on this..

FE
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.