Solved

Squirrel Mail

Posted on 2004-03-28
2
1,041 Views
Last Modified: 2013-12-15
Hi,

    I have installed Squirrelmail 1.4.0 on Redhat Linux 8.0. It is running fine. But i am not able to attach file more than 100K. How can i increase this file size?

i have already changed, in /etc/php.ini, max upload file  size but still same prob.


Vasanth.
   
0
Comment
Question by:vasanth
2 Comments
 
LVL 2

Accepted Solution

by:
perldog earned 200 total points
ID: 10698260
There are three settings in the php.ini configuration file that may need to be changed.

The values you will need to increase are:

memory_limit
post_max_size
upload_max_filesize

The values can be set in bytes (1,048,576 per MB) or they can be set in MB by appending the value with an "M", ie. 8M.

To upload large files, this value must be larger than upload_max_filesize. If memory limit is enabled by configure script, memory_limit also affects file uploading. Generally speaking, memory_limit should be larger than post_max_size.

You should also take into account limits for your MTA software:
- Courier-MTA: showconfig or /etc/courier/sizelimit - default 10MBytes
- Qmail-MTA: a file in /var/qmail/control called databytes. The file contains one line that represents the max size of attachments in bytes.

And if you are using Apache as your HTTP server:

You can restrict maximum file size using [LimitRequestBody] directive

Now, an issue specific to Squirrelmail:

Squirrelmail tries to stop users from submiting attachments bigger than a certain size by using <input type="hidden" name="MAX_FILE_SIZE" value="1000"> html code. You may need to edit one or two php files (start with your_squirrelmail_directory/src/compose.php)

Here is an issue specific to Redhat 8.0 (and newer):   In RedHat 8.0 there is an additional PHP config file, /etc/httpd/conf.d/php.conf, and increasing the number on the line "LimitRequestBody 524288" should solve the issue.

Also, check the max execution time in PHP.INI. Very large attachments may take longer than the 30 seconds allowed. Symptoms may be found by looking at the httpd error log and seeing "httpd in free(): warning: recursive call" yet the httpd does not core fault and die altogether. For a 10 MB file attachment I set execution time to 180 seconds.

I know this is a complex answer but I hope it helps!
0
 

Author Comment

by:vasanth
ID: 10712068
Thank you..


I got it working.
0

Featured Post

Gigs: Get Your Project Delivered by an Expert

Select from freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Network Interface Card (NIC) bonding, also known as link aggregation, NIC teaming and trunking, is an important concept to understand and implement in any environment where high availability is of concern. Using this feature, a server administrator …
I am a long time windows user and for me it is normal to have spaces in directory and file names. Changing to Linux I found myself frustrated when I moved my windows data over to my new Linux computer. The problem occurs when at the command line.…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

808 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question