Solved

Want to remote login to my pc...how do I do it?

Posted on 2004-03-28
18
15,534 Views
Last Modified: 2013-11-21
I would like to use either XP Pro's remote desktop or realVNC to log onto my home computer at work.

I am behind a hardware firewall because I am running a home network. How do I make it so that I can connect to my PC from outside the house.

I know my IP address.
I have a Linksys: WRT54G, BEFSR81, BEFCMU10.

What do I do now? I assume I have to set my Linksys to do something...

Thanks,
Erik
0
Comment
Question by:tifosiv122
  • 6
  • 4
  • 3
  • +4
18 Comments
 
LVL 49

Assisted Solution

by:sunray_2003
sunray_2003 earned 50 total points
ID: 10701131
I would think this can help you

First give a static IP to your computer. Go to network connections, right click the connection you are using and give a  static IP address like 192.168.0.105 etc..

Now open the web management of the router and do port forwarding to that static IP address. May be you can look into your model to know how to do port forwarding.. So now when you use remote desktop from outside giving the IP address of your house assigned by the ISP , then it should connect to your PC.. Check this
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 10701135
Get your wan address here: http://www.whatismyip.com/

forward port 5900 (default for VNC) to your LAN IP (IPCONFIG from a command prompt will give you this)

>>>By default, a VNC server will listen for connections from a VNC viewer on TCP port "5900+N", where N is the "Display Number" (usually just zero). So a VNC server setup for Display-0 will listen on TCP-5900, Display-1 is TCP-5901, etc.

Additionally, the VNC server will listen for connections from a web-browser on TCP port "5800+N", where N is as above. If you point a web-browser to this port, the VNC server will automatically provide a Java VNC viewer that runs right in your web-browser. This Java Viewer will then exchange data with the VNC Server on the same ports a normal VNC Viewer would use: "5900+N". <<<ref:http://faq.gotomyvnc.com/fom-serve/cache/52.html

3389 for RDP...

From Linsys - forward that/those ports to your LAN IP (192.168.1.100)...
0
 
LVL 1

Author Comment

by:tifosiv122
ID: 10701187
When I set a static IP, 192.168.1.100 {the current IP} I could no longer connect to the internet, it timed out. I went to network connections, setup the IP through the TCP/IP. I did the IP, gateway, and subnet all the way it was currently. Any reason why I lost connection? When I went back to auto it worked fine. I guess this is the first step...i'm stuck.

Erik
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 10701204
You should get your IP lease from the router.
It 'should' be 192.168.1.100
You should be able to configure the router over http://192.168.1.1

Static may not have worked for a number of reasons...conflict, misconfigured...??  Leave it at dynamic though.

Did you get your Wan IP?
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 10701206
http://ipchicken.com can also give it to you...
0
 
LVL 1

Author Comment

by:tifosiv122
ID: 10701229
As I said in my original post, I know my IP already. I assume the first poster was correct, I need to assign a static IP...but I can't get that to work. I don't see a setting in my router, 192.168.1.1 to setup the static IP so I assume I need to set it up on the computer.

As for the port forwarding, do I try port 5900 to 192.168.1.1 or do I set it to 192.168.1.100 assuming I get my PC to go static?

Erik
0
 
LVL 49

Expert Comment

by:sunray_2003
ID: 10701258
You would see the setting in your PC to do that static IP.
open control panel
go to network connections
right-click the connection you are using say LAN or wireless
go to properties
click on tcp/ip
click on properties
enable "use the following ip address"

give the following


192.168.0.105 ( or anything ur router can assign)
subnet mask : 255.255.0.0
default gateway : 192.168.0.1

preferred DNS : 192.168.0.1
alternate : 4.2.2.2

Now your static IP is set for your pc. this wont work if your router cannot assign that number. check in the web management of your router.

0
 
LVL 2

Expert Comment

by:Jman8R
ID: 10702289
To get all of the settings that you need to set when statically assigning your IP, have it assigned dynamically and go to a dos/command prompt and enter the command "ipconfig /all". Please post the results here. However, from what you posted, it does not sound like you entered any DNS servers when you assigned the ip address statically - this would could major problems for you.

You will need to configure port forwarding in the WRT54G. I have one of these units at home and I could probably guide you through the process if you have any problems with setting up the router.

I would strongly advise using Windows XP remote controll over VNC. VNC is a great product since it is available on many OS's, but XP's built in remote control software is significantly faster when using Windows. It will, however, depend on the client that you will be using... Is it a situation where you have a laptop and will be travelling around with it wanting to dial into the internet and then control your home PC's, or are you wanting to use any available internet cafe, etc??

You will have to configure your WRT54G to forward traffic for TCP port 3389 to the computer that you want to control - hence, you will either need to assign the IP and other settings for the computer statically, or, set a 'reservation' for the ip/computer in the WRT54G's DHCP settings.

As said, I can help out with the router config if you are having trouble - but I will have to look at the web interface at home...


Hope that this makes sense!
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 10702858
You don't need a static IP address for the reason that your router will assign you one and that's that.
Basically, post the IPCONFIG as mentioned.  This will be your local LAN address.

To allow access to a dynamically asssigned WAN address (that your ISP provides you - which 'may' change from time to time), go here: http://www.dyndns.org/services/dyndns/ for a dynamic DNS solution...
0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 
LVL 1

Author Comment

by:tifosiv122
ID: 10703437
Windows IP Configuration

        Host Name . . . . . . . . . . . . : erik
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Unknown
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Intel(R) PRO/100 VE Network Connecti
on
        Physical Address. . . . . . . . . : 00-07-E9-B3-C9-79
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 192.168.1.100
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        IP Address. . . . . . . . . . . . : fe80::207:e9ff:feb3:c979%5
        Default Gateway . . . . . . . . . : 192.168.1.1
        DHCP Server . . . . . . . . . . . : 192.168.1.1
        DNS Servers . . . . . . . . . . . : 167.206.3.224
                                            167.206.3.223
                                            167.206.3.158
                                            fec0:0:0:ffff::1%1
                                            fec0:0:0:ffff::2%1
                                            fec0:0:0:ffff::3%1
        Lease Obtained. . . . . . . . . . : Sunday, March 28, 2004 11:01:43 PM
        Lease Expires . . . . . . . . . . : Monday, March 29, 2004 11:01:43 PM

Tunnel adapter Teredo Tunneling Pseudo-Interface:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
        Physical Address. . . . . . . . . : 00-00-EE-6B-BC-AE-C9-5E
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 3ffe:831f:4004:1956:0:ee6b:bcae:c95e

        IP Address. . . . . . . . . . . . : fe80::5445:5245:444f%4
        Default Gateway . . . . . . . . . : ::
        NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Automatic Tunneling Pseudo-Interface:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface

        Physical Address. . . . . . . . . : C0-A8-01-64
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : fe80::5efe:192.168.1.100%2
        Default Gateway . . . . . . . . . :
        DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                            fec0:0:0:ffff::2%1
                                            fec0:0:0:ffff::3%1
        NetBIOS over Tcpip. . . . . . . . : Disabled
******************************************************************
I have 9 PC's. If I don't assign a static IP, everytime I restart my PC it will take the next available IP...

Erik
0
 
LVL 27

Assisted Solution

by:pseudocyber
pseudocyber earned 100 total points
ID: 10703453
I think you might have had a problem with 192.168.1.100 because that's the first address in the default scope of the router.  If you're going to assign a static address, pick one outside the scope, like .50.

I don't think you need Dynamic DNS - you don't really care about DNS resolution like you would if you were hosting a website.  You just need the IP address.  Since you're using a router getting an IP address via DHCP, you should keep that address for a pretty long time - assuming your power doesn't go out or turn off the router.  With DHCP, you will get an address assigned to you for a period of time.  Halfway through the lease period, the DHCP client on your router on the WAN side will seek to renew the address to the server.  Assuming everything goes the way it's supposed to, it will renew the address for another lease period and make the same request half way through the lease period and so on.

If you want to use Dynamic DNS the WRV54G can support either http://www.dyndns.org or http://www.tzo.com.  Click on "Setup" and then DDNS.  This would allow you to give your router a name and then forget about being concerned about remembering the IP address or if the address changes - but it would be another small monthly fee.

I happen to have a WRV54G sitting in my test lab (my desk).  According to the router itself, you must disable DHCP on the client when you use port forwarding because the IP could change on your workstation - makes sense.

Click on the "Applications and Gaming" tab in the router and then click on UPnP Forwarding.  In the Application field, make something up like RC.  In the external port, enter the port you need - 3389 for Windows Remote Assistance, 5900 (or whatever you set it to) for Real VNC.  I would think you should use the same port internally, but you could play with that.  Enter the IP address of your statically assigned machine, and then enable it.  You should be good as far as port goes.

While you're in the router, go to "Setup" and at the top of the page it will tell you the IP address of the WAN port.  Or you can go to "Status" and then router and it will tell you the IP and the lease period.

See the articles below for how to set up Remote Assistance and Real VNC.

Ps.  You may have an issue at work where the outbound port is not open in your firewall - or you can get out, but the request can't come back in.  It depends on how tightly your work firewall is locked down - ours is pretty tight.

Overview of Remote Assistance in Windows XP
http://support.microsoft.com/default.aspx?scid=kb;EN-US;300546

HOW TO: Configure a Computer to Receive Remote Assistance Offers in Windows XP
http://support.microsoft.com/default.aspx?scid=kb;EN-US;301527

Description of the Remote Assistance Connection Process
http://support.microsoft.com/default.aspx?scid=kb;EN-US;300692

Real VNC FAQ
http://www.realvnc.com/faq.html#port

HTH
0
 
LVL 2

Assisted Solution

by:Jman8R
Jman8R earned 350 total points
ID: 10704937
As a start,

Please try the following settings,

Set your home PC to use a static IP: 192.168.1.50
Subnet mask: 255.255.255.0
Default gatewat: 192.168.1.1
Primary DNS server: 167.206.3.224
Secondary DNS server: 167.206.3.223


Can you now still access the internet?
0
 
LVL 1

Author Comment

by:tifosiv122
ID: 10705629
I'm at work now...i'll be home tonight and i'll try again, then post results.
Everyone convinced me to use XPs Remote over Real, so let's focus on that after I figure out this static issue.

Thanks,
Erik
0
 

Expert Comment

by:osbjmg
ID: 10707023
I agree, make sure your static IP is outside the range of DHCP addresses.  It is likely you were conflicting with the first leased address of 192.168.1.100.  

I use this same router with Windows XP Remote Desktop.  
I simply set my desktop ip address to 192.168.1.7 - subnet mask of 255.255.255.0 (depending on your setup, but this is default for the wrt54g)  My gateway is the address of the LAN interface on the router (defaults to 192.168.1.1) and you need to find out your DNS servers to use.  It seems you have found your DNS servers, so they are entered.
Now you forward the VNC port (TCP 5900) or Remote Desktop port (TCP 3389) to your desktop IP address.  You can get to port forwarding by logging into your router, and going to port forwarding or maybe it is called applications and gaming.  Have you found port forwarding?

 This router has a range feature in the configuration where you can forward a range like 2000-4000 to one computer, you just want to put the same port in the beginning and end box.

That is all, make sure remote desktop or vnc is running and you should be all set.  Do you know how to set up remote desktop with windows xp?  Or vnc?
0
 
LVL 1

Author Comment

by:tifosiv122
ID: 10707350
I setup remote desktop already, I use it to go between my 9 PCs, so I don't need another KVM.
I know how to get to port forwarding, i've just never used it before. Usually when I play games I would open my PC with DMZ and take it off when I'm finished, but this is a bit different.

I will try the settings above when I get home and post my results.

Erik
0
 
LVL 2

Accepted Solution

by:
Jman8R earned 350 total points
ID: 10710056
After this whole static issue is worked out, you should, as previously mentioned, set up the port forwarding.

You should use the WRT54G's web admin interface to do this.

 - Log into the web admin interface ( http://192.168.1.1 )
 - Go to the "Applications and Gaming" screen.
 - There should be a table that you can enter the appropriate information into. So, along the first available/blank row, enter the information.
 - In the "Application", enter "MS RDP" or something else that makes sense to yourself.
 - In the start port and end port boxes enter 3389.
 - Fill in the last octect of the IP address as the IP you are using on your PC ( 50 in the specs that I provided previously ).
 - For protocol, drop down the list and select "TCP".
 - Click on the "Enable" check box.
 - I am working off memory here, so I believe that is all the information to be entered. Click on the save settings button down the bottom of the screen.
 - Exit the Web admin of the WRT54G.

At this point, the networking side of the set up should be complete. However, you still need to enable a Remote Desktop connection through the "System Properties" in "Control Panel" and select which users are to have access. Also, there will have to be no user logged in on the PC for you to be able to connect successfully. I would suggest disabling automatic logon at startup if your home PC does this at the moment.

Also, keep in mind that although this should work from a normal internet connection, you may have difficulty connecting from your place of work as there may be firewalls in place or other configuration issues. If you have done all of this setup successfully and you can not connect from work, try a non-restricted internet access such as a dialup modem on a laptop of maybe a friends internet connection.

Hope that this helps!
0
 
LVL 1

Author Comment

by:tifosiv122
ID: 10723837
Thanks everyone, got it to work. I split the points for the answers that helped the most. I can now remote log-in.

Erik
0
 

Expert Comment

by:jojockey
ID: 10894633
FYI about Linksys DDNS 4/13/2004

FIX available for firmware for WRV54G. (version 2.25.2) This should fix the disable problem and functionality with PPPoE connections...

Firmware Version 2.25.2
- Added support to act as a Boingo Hot Spot AP
- Fixed issue with DDNS and PPPoE
- Fixed issue where DDNS status always shows Disabled
- Fixed issue with Domain Name Routing

http://www.linksys.com/download/firmware.asp?fwid=185
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Article by: IanTh
Hi Guys After a whole weekend getting wake on lan over the internet working, I thought I would share the experience. Your firewall has to have a port forward for port 9 udp to your local broadcast x.x.x.255 but if that doesnt work, do it to a …
Data center, now-a-days, is referred as the home of all the advanced technologies. In-fact, most of the businesses are now establishing their entire organizational structure around the IT capabilities.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now