VSS, Shadow Copy errors and problems

I am trying to create an ntbackup process for a small office server that I support remotely, but when it runs I get the following:

Event Type:      Error
Event Source:      VSS
Event Category:      None
Event ID:      5013
Date:            29/03/2004
Time:            11:16:13
User:            N/A
Computer:      HTSRV01
Description:
Volume Shadow Copy Service error: Shadow Copy writer ContentIndexingService called routine VsServiceChangeState which failed with status 0x8007041d (converted to 0x800423f4).

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 57 53 48 43 4f 4d 4e 43   WSHCOMNC
0008: 32 32 33 30 00 00 00 00   2230....
0010: 57 53 48 43 49 43 00 00   WSHCIC..
0018: 33 37 32 00 00 00 00 00   372.....

Needless to say when you go to microsoft it tells you that there is no reference to 5013. I have also had other VSS error msgs doing ntbackup, cannot create instance, etc.

I have searched the Net for answers, but all the questions/answers (of which there are too few) relate to SQL databases. I dont have one! I do have an Access database though.

I also cannot see a "Shadow Copy" on the eproperties page of the disc in question.

Can anyone steer me down the right path?

Many thanks I hope in advance!
OverTheHillTechieAsked:
Who is Participating?
 
bruintjeConnect With a Mentor Commented:
maybe the solution posted here will give you an idea, the error and eventid are mentioned

title: Virtual Shadow Copy service fatal errors
source: http://tinyurl.com/2l523
description:
-----------
It seems that when I was beta testing Office 11 (aka Office 2003), Visio installed a key in the Content Indexing Service creating a separate index catalog for Visio files. When I uninstalled Visio, that key didn't go away.
Because CISVC was disabled, it never made a difference to content indexing.
However, it certainly got on the wrong side of VSS.

deleted

hklm\SYSTEM\CurrentControlset\Control\ContentIndex\Catalogs\visio

and now VSS seems to run OK.
-----------
hope this helps a bit
0
 
sirbountyCommented:
Are you using NT Backup?
There is a setting when you create the backup job (you have to click Advanced if going through the wizard) to disable volume shadow copy.

Try checking this on a new job and determine if the error continues.  It may be that a file is in use that simply can't be locked down...
0
 
OverTheHillTechieAuthor Commented:
Yes, am using ntbackup on XP Pro (latest SP's)

This only occurs when the option to use shadow copy is selected... I need to do this as the backup is taken during working hours. Even if I select one file to backup (which is not in use) I get the error when using VSS.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.