• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1243
  • Last Modified:

2 * XP Home networking problem, computers cannot access each other

Hi,

Please bear in mind that i am a novice at this, so please go step by step 8-)



I recently bought an ethernet switch and I was wanting to connect my windows XP Home PC to my windows XP Home laptop.

I have finally got it so that the machines can see each other.

The problem is that I cannot access the other computer from both machines, I get the - You might not have permissions error when I try to access them through the workgroup view.

I can ping both computers from the other computer using the IP address but not the computer name.

The only thing I can think of is that:

When I run IPCONFIG /ALL on my laptop it says that NODE TYPE: PEER-TO-PEER
When I run IPCONFIG /ALL on my desktop it says that NODE TYPE: UNKOWN

Please help as this is driving me nuts!!!

Thanks,

Sparko



P.S.

 I have also heard some people say that you need to have the same accounts and passwords on both machines, and guest accounts enabled,

Does anyone know if there is any truth in this,


I cant figure out why everyone seems to have a Node type: HYBRID and mine is just unknown on my Desktop?

It is so frustrating sitting there, able to see both computers on my workgroup but I everytime I try to click on the other machine, I get that really annoying message about permissions etc.
0
sparkogeek
Asked:
sparkogeek
  • 5
  • 3
  • 2
1 Solution
 
sirbountyCommented:

Enable NetBIOS over TCP/IP:
   XP utilizes DNS for communication by default.  To enable the systems to communicate via NetBIOS,
   proceed as above to enter Network Connections.
   Right-click your Local Area Connection and click Properties
   Scroll down in "This connection uses the following items:" to find Internet Protocol (TCP/IP)
   Select it (highlight it) and click properties
   Click the Advanced button on the General tab.
   Click the WINS tab.
   Under NetBIOS setting heading
    Click Enable NetBIOS over TCP/IP
   Click OK, OK, OK and close out of Network Connections & Control Panel

Let Everyone's permissions apply to anonymous users as well:
    Click Start
    Click Run
    In the Open box type SECPOL.MSC /S <ENTER>
    Navigate to Local Policies/Security Options.
    Double click "Network Access:Let Everyone permissions apply to anonymous users"
    Click Enabled and click OK

0
 
sparkogeekAuthor Commented:
Hi, I have NetBIOS enabled on both my desktop and Laptop,

[Let Everyone's permissions apply to anonymous users as well:
    Click Start
    Click Run
    In the Open box type SECPOL.MSC /S <ENTER>]

I have tried the above, but when I press enter, nothing happens, is this only for XP-PRO?

[Navigate to Local Policies/Security Options.
    Double click "Network Access:Let Everyone permissions apply to anonymous users"
    Click Enabled and click OK]

If i get SECPOL.MSC /S to run, do I have to do this on both machines?
0
 
sparkogeekAuthor Commented:
Also,

Should my laptop's node type be set to PEER-TO-PEER
and should my Desktops node type be set to UNKNOWN

Thanks
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
Gareth GudgerCommented:
Yes do it on both machines. Typically you need the same user/pass on both machine or guests enabled.
0
 
sparkogeekAuthor Commented:
Hi diggisaur.

On the desktop I have 2 user accounts, on the laptop I have one user account, which is the same as the one on the desktop i.e.

DESKTOP
userA passwordA
userB passwordB

LAPTOP
userA passwordA

does this mean that I have to add "userB passwordB" onto the laptop?

I think that is what you meant by the above,

I have to say that the Microsoft documentation doesn't make this clear at all!!!
0
 
Gareth GudgerCommented:
No as long as you are using USerA PasswordA when trying to access the resoources then that part is good.
0
 
sparkogeekAuthor Commented:
Hi,

I was looking at trying to fix my NODETYPE problem,

what should I be trying to get each computers node type to be: broadcast or hybrid,

I think the reason I might be having the ping problem is that the IP address can be found but the computer name can't. The laptop's node type is Peer-to-Peer and this refers to a WINS server for the name (which I don't have) and my desktop shows mode type as unknown.

2 problems,

1) how do I get my laptop to get the correct node type (I cant find the NodeType or DHCTPNodeType registry value to do so)
2) how do I get my desktop to get the correct node type (I also cant find the NodeType or DHCTPNodeType registry value to do so)

2a) my MOBO is an Asus A7N8X deluxe rev2, it has 2 lan ports, is the node type unknown because the 2 ports should be bridged(or set to the same settings)??
0
 
Gareth GudgerCommented:
Renewing your IP address should use the current node type of your network. If no WINS server is specified it will/should resort to braodcast.

The only time I can see that this may not is if your IP info is DHCP but you IP advanced properties have a WINS server manually entered. So go into TCP/IP Advanced properties and see if you have any WINS servers specified on the WINS tab.
0
 
sparkogeekAuthor Commented:
Hi,

Sometimes I can release my ip address but I can't renew it?

seems like my computer is full of problems!!!
0
 
sirbountyCommented:
Reset TCP/IP:
 Start->Run->CMD <enter>
 at the prompt, type:

 netsh int ip reset c:\resetlog.txt <enter>

Winsockfix:
 Download and run the following:
 http://members.shaw.ca/techcd/VB_Projects/WinsockFix.zip
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 5
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now