Solved

User recieves "You do not have permission to change your password" when warned that password will expire in X days.

Posted on 2004-03-29
9
247 Views
Last Modified: 2010-04-13
When the user logs on they get a warning that their password will expire in X days, would you like to change it now.  When they try they get a "You do not have permission" error.  If they log in to the machine, they can change theor password through the old Ctrl-alt-del menu.

I have checked the domail controller policy and the allow access object has everyone and authenticated users.

Help!

0
Comment
Question by:scwerntz
9 Comments
 
LVL 44

Expert Comment

by:CrazyOne
ID: 10707086
http://www.mike-tech.com/article.php?gif=win2k&article=165

You Do Not Have Permission To Change Your Password (05-05-2002)
--------------------------------------------------------------------------------
If you use a password policy in your Windows 2000 domain, Active Directory users may receive "You do not have permission to change your password" when they attempt to change their password in response to a password change notification.

Chances are that the Everyone group has not been granted the right to Change Password on the User object.

1. In the Active Directory Users and Computers snap-in, right-click your domain.

2. On the View menu, select Advanced Features

3. Right-click the OU hosting the user object and press Properties

4. On the Security tab, if the Everyone group is not present in the Name box, Press "Advanced" and Add it

5. On the Advanced tab, select the Everyone group

6. Press View/Edit and select "User Objects" in the Apply onto box

7. In the Permissions list, check the Change Password permission "Allow" box

8. Press OK and/or Apply till you are finished
0
 
LVL 44

Expert Comment

by:CrazyOne
ID: 10707149
http://www.jsiinc.com/SUBO/tip7300/rh7344.htm

7344 » When a domain user attempts to change their password during logon, they receive 'You do not have permission to change your password'?

The subject behavior will occur if both the following are true:

- You enabled the User must change password at next logon option.

- The Everyone group and/or the Authenticated Users group does NOT have the Access this computer from the network rights on an authenticating domain controller.

To resolve this problem:

1. Open the Active Directory Users and Computers snap-in.

2. Right-click the Domain Controllers container and press Properties.

3. Select the Group Policy tab.

4. Select the Default Domain Controllers Policy and press the Edit button.

5. Navigate through Computer Configuration / Windows Settings / Security Settings / Local Policies / User Rights Assignment.

6. Double-click Access this computer from the network.

7. If either the Everyone or Authenticated Users group is missing, add them and press OK. 8. Close the Properties dialog and exit the snap-in.

9. On a domain controller, run SECEDIT /REFRESHPOLICY MACHINE_POLICY /ENFORCE.

NOTE: For Windows Server 2003, run gpudate /Target:Computer.
0
 
LVL 1

Author Comment

by:scwerntz
ID: 10707224
OK, both of these are configured correctly.  The permissions are there.
0
 
LVL 1

Author Comment

by:scwerntz
ID: 10707236
I checked all of these settings based on these and other articles I have found.  There has to be something else.
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 1

Expert Comment

by:justinm99
ID: 10707416
crazyone how do you get to questions so quickly? do you have something that notifies you if a new question has been asked or do you refresh the webpage like every 30 seconds?  :)
0
 
LVL 3

Expert Comment

by:fajar79
ID: 10709930
how about the length of password ? do you change the default setting? > 6 characters long, uppercase, lowercase, number, nonalphanumeric...
0
 
LVL 1

Author Comment

by:scwerntz
ID: 11326290
I had to open a ticket with Microsoft on this one.  We are running in mixed mode.  There was one registry key that was changed that had to be reset.  

PROBLEM
============

Users cannot change password until they log on to the system.


RESOLUTION
============

The issue is related to the registry key:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa\RestrictAnonymous

After changing its value from 2 to 0, the original issue is solved.
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 11518530
PAQed, with points refunded (250)

Computer101
E-E Admin
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
A Short Story about the Best File Recovery Software – Acronis True Image 2017
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now