Solved

Exchange Server 2003 and Full-Text Indexing

Posted on 2004-03-29
19
1,084 Views
Last Modified: 2007-12-19
OK, Exchange 2003 is up and running. Anytime i click on the Indexing tab in a property page i get the following error:
---------------------------
Exchange System Manager
---------------------------
You do not have sufficient permissions to administer Full-Text Indexing on this server.



Operation: Gathering Full-Text Indexing information.

ID no: c1034a95

Exchange System Manager

Microsoft has no KB other than one for Exchange 2000, which i tried and it made no difference. Any ideas?
0
Comment
Question by:maladyetz
  • 10
  • 9
19 Comments
 
LVL 24

Accepted Solution

by:
David Wilhoit earned 125 total points
Comment Utility
fairly explanatory, the account you're using doesn't have permissions, or you've put in a specific "deny" somewhere. What account are you using?

D
0
 

Author Comment

by:maladyetz
Comment Utility
The account is the main domain admin, it is in the Enterprise admin, exchange admin, exchange enterprise admin, domain admin, and local admin groups, plus almost evey other group as well. i've looked for a deny permission somewhere but have not found any, although i may just not have found the correct place to look yet either.
0
 
LVL 24

Expert Comment

by:David Wilhoit
Comment Utility
I'd like to be able to tell you where to start, but it's something of a hunt-and-peck situation. Check perms using ADSIedit, you'll get perms on every object instead of only the store object.

D
0
 

Author Comment

by:maladyetz
Comment Utility
OK, looked everywhere in Ad and in ESM, none of the properties seem to be incorrect, none of them seem to be directly related to MSSearch, but the ones that are are correct. i wne through all Exchange, Index, and Search AD objects and teh permissions are correct for all of them.

Any idea of where it should be, or if it could be something else and this is a bogus error message?
0
 
LVL 24

Expert Comment

by:David Wilhoit
Comment Utility
give me a corresponding event ID out of the applog, just recreate the pop-up error, and go check the log. Post the full error here, and remove any sensitive info...

D
0
 

Author Comment

by:maladyetz
Comment Utility
That is the odd thing, there is no eventlog entry that corresponds to the pop-up error:
"You do not have sufficient permissions to administer Full-Text Indexing on this server.
Operation: Gathering Full-Text Indexing information.
ID no: c1034a95
Exchange System Manager"

Nothing in the system, app, or security logs. i've enabled all the diagnostic logging i know to enable and still nothing.
0
 
LVL 24

Expert Comment

by:David Wilhoit
Comment Utility
http://support.microsoft.com/default.aspx?scid=kb;en-us;295921

I did manage to find this...was this server rebuilt at some point?>

d
0
 
LVL 24

Expert Comment

by:David Wilhoit
Comment Utility
oops, I bet this is the one you tried before, huh? Sorry.....

D
0
 
LVL 24

Expert Comment

by:David Wilhoit
Comment Utility
Did this ever work? Is this a clean install, or an upgrade? How long has it been like this?

D
0
Promote certifications in your email signature

Has your company recently won an award or achieved a certification? They'll no doubt want to show it off. Email signature images used to promote certifications & awards can instantly establish credibility with a recipient and provide you with numerous benefits.

 

Author Comment

by:maladyetz
Comment Utility
Yeah, tried both before, sorry.
0
 

Author Comment

by:maladyetz
Comment Utility
The server was built up from scratch, there were several issues because our old Exchange 5.5 org was named Webridge, Inc. which has two invalid characters. After much research and 90 minutes on hold with MS, they gave me a magic setup flag that got us past that. Now that the server is up and running, we get this error.

We also get an error from the public folder property pages that is not related to Full-Text Indexing.
0
 
LVL 24

Expert Comment

by:David Wilhoit
Comment Utility
That could be the IIS Exchange virtual directories, those have to be up and running clean for the ESM to be able to manage public folders. May be a totally separate issue.

Did you use Exmerge to move all your email or did you join this box to a 5.5 org? Sounds like you used the ADC...

D
0
 

Author Comment

by:maladyetz
Comment Utility
It was joined to the 5.5 org, so far one user has been moved over, for testing, no problems. This happened when we tried to test the full text indexing and replicate the public folders.

What can i check in the IIS stuff to validate it is good?
0
 
LVL 24

Expert Comment

by:David Wilhoit
Comment Utility
ok, cool. Did you create a PF connection agreement? Have you created the PF replicas since the problem has occurred? And is the User CA a 2 way agreement?

D
0
 

Author Comment

by:maladyetz
Comment Utility
Yes, yes, and yes. Ran PFMigrate.wsf to add the replication data to both servers, all 343 folders were done succesfully, all 4 system folders were done successfully.

Of course that is another odd issue. The replication ran through for all but 14 folders, ove rthe course of 48 hours. Now it is not staying in sync, although it says it is in sync, new items are not replicating, and the fodlers that never did replicate are empty on the new server. And right clicking a public folder and saying properties through a message about the mail property pages and replication being delayed.
0
 
LVL 24

Expert Comment

by:David Wilhoit
Comment Utility
Something broke in the AD, this is very odd behavior. Is the ADC service actually running now? If you turned up diagnostics logging on the ADC, and forced replication, you'd get a slew of messages, maybe that would point you in the right direction. I'd clear my applog first though, and save it off, because it will create a ton of messages.

D
0
 

Author Comment

by:maladyetz
Comment Utility
ADC is running. i'll try the event log thing and post any further info here.
0
 

Author Comment

by:maladyetz
Comment Utility
OK, got it to work, here's how:
Went to C:\Program Files\common files\system\MSSearch\bin\srcadmin.msc
Once in that console i was able to find properties on the public folders, and there was the promised land, a series of denies inherited from some upper level parent that it doesn't identify and you couldn't see. Unchecked the inherit permissions box, copied the permissions and then removed the Deny ones.

The Full-Test Indexes are now working. Thank you very much, you were right, it was just a matter of locating the permissions property page for the object.
0
 
LVL 24

Expert Comment

by:David Wilhoit
Comment Utility
nicely done!!!

David
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
Local Continuous Replication is a cost effective and quick way of backing up Exchange server data. The following article describes the steps required to configure Local Continuous Replication. Also, the article tells you how to restore from a backup…
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now