Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 419
  • Last Modified:

How to install SMC wireless card in Redhat linux 9.0 ?

Hi,
I  have downloaded the hostap driver as suggetsed in one of the posts here.
But i get the following messages when i try to make:
"[root@localhost hostap-driver-0.1.3]# make all
Makefile:20: /usr/src/redhat/.config: No such file or directory
Makefile:38: WARNING: No kernel PCMCIA support found and PCMCIA_PATH is not defined
Makefile:45: WARNING: Linux wireless extensions, CONFIG_NET_RADIO, not enabled in the kernel
make: *** No rule to make target `/usr/src/redhat/.config'.  Stop.
[root@localhost hostap-driver-0.1.3]# make install
Makefile:20: /usr/src/redhat/.config: No such file or directory
Makefile:38: WARNING: No kernel PCMCIA support found and PCMCIA_PATH is not defined
Makefile:45: WARNING: Linux wireless extensions, CONFIG_NET_RADIO, not enabled in the kernel
make: *** No rule to make target `/usr/src/redhat/.config'.  Stop.
[root@localhost hostap-driver-0.1.3]# make
Makefile:20: /usr/src/redhat/.config: No such file or directory
Makefile:38: WARNING: No kernel PCMCIA support found and PCMCIA_PATH is not defined
Makefile:45: WARNING: Linux wireless extensions, CONFIG_NET_RADIO, not enabled in the kernel
make: *** No rule to make target `/usr/src/redhat/.config'.  Stop.
[root@localhost hostap-driver-0.1.3]# make install
Makefile:20: /usr/src/redhat/.config: No such file or directory
Makefile:38: WARNING: No kernel PCMCIA support found and PCMCIA_PATH is not defined
Makefile:45: WARNING: Linux wireless extensions, CONFIG_NET_RADIO, not enabled in the kernel
make: *** No rule to make target `/usr/src/redhat/.config'.  Stop.
"
I am not sure what i should do. Any help is appreciated. I previously tried installing Symbol's Spectrum wireless card in vane.
Thanks!!
0
pvvijay
Asked:
pvvijay
2 Solutions
 
jlevieCommented:
I think the prime problem is found in the first error:

Makefile:20: /usr/src/redhat/.config: No such file or directory

which indicates that the Makefile is looking for the kernel sources in /usr/src/redhat. You'll have to have the kernel-source package installed for the kernel that you are running and it looks to me like you may need to edit the Makefile and set the kernel source directory to be /usr/src/linux-2.4.
0
 
CNCoolantCommented:
I've had simaller issues loading wireless drivers- tho I haven't tried hostap. For my SMC (pci) card, I found just using the available Orinoco  driver (modprobe orinoco_plx) got me up and running without building anything. You may have to tinker with a few config files to get it talking, tho.
Absolute Value Systems (www.linux-wlan.com? or something) has a lot of info.
Also, if you do have the source packages installed, you still may have to copy the correct .config file to /usr/src/redhat-- it should be found in /boot--- it would be named "config-2.x..x-x"  (the kernel version) and rename it to .config.
I'm using prism2_plx  on my desktop w/ an SMC (don't know the model) and prism2_cs on my laptop w/ a Microsoft 80211b pcmcia card. Works ok- but the pcmcia card can't be "hot-unplugged" without locking up the whole thing (fedora 1 on the lap, RH9 on the desk)
Hope that helps!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now