• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2138
  • Last Modified:

WebLogic 7.0 OutOfMemory problem

Hello,

I use weblogic 7.0 and I want to deploy my ECOM.ear. I got the error OutOfMemory when I want to deploy it in Jbuilder 9.0. Here is the startWebLogic.cmd

@rem Set JAVA_OPTIONS to the java flags you want to pass to the vm. i.e.:
@rem set JAVA_OPTIONS=-Dweblogic.attribute=value -Djava.attribute=value
set JAVA_OPTIONS=-Dweblogic.security.SSL.trustedCAKeyStore=D:\BEA\weblogic700\server\lib\cacerts

@rem Set JAVA_VM to the java virtual machine you want to run.  For instance:
@rem set JAVA_VM=-server
set JAVA_VM=

@rem Set MEM_ARGS to the memory args you want to pass to java.  For instance:
@rem set MEM_ARGS=-Xms32m -Xmx200m
set MEM_ARGS=

I think that change one of the option. Can you tell me which and how to change the option.

Thanks for your help
-FA

0
Farzad Akbarnejad
Asked:
Farzad Akbarnejad
1 Solution
 
objectsCommented:
to give it 512Mb use:

set MEM_ARGS=-Xms32m -Xmx512m
0
 
Farzad AkbarnejadAuthor Commented:
Thanks. But I got java.lang.OutOfMemoryError before. I think that I must set
-XX:MaxPermSize option for JVM but I don't knoe about its syntax.

-FA
0
 
objectsCommented:
-XX:MaxPermSize=<size>

eg. -XX:MaxPermSize=128m

Why do you think you need to set the permanent generation size?
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
Farzad AkbarnejadAuthor Commented:
I found it in google but I couldn't to solve my problem. :(
0
 
objectsCommented:
Did increasing the memory heap with -Xmx not help?
0
 
Farzad AkbarnejadAuthor Commented:
No. I test it at first. It didn't solve my problem.

-FA
0
 
Farzad AkbarnejadAuthor Commented:
Thanks objects. I succeeded to solve my problme by decreasing the lib-s that I loaded.

-FA
0
 
objectsCommented:
good to hear :)
0
 
Farzad AkbarnejadAuthor Commented:
objects,
Must I assign point to you or ask moderator to close the question? You spent time and I belive that I must assign point to you.

-FA
0
 
WebstormCommented:
Hi FarzadA,

as you solved the problem yourself (you also spend time i guess), the points must be given to you.
0
 
PashaModCommented:
Closed, 500 points refunded.
PashaMod
Community Support Moderator
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now