IIS 6.0: Images with no file extension

We have thousands of JPEG and GIF images that are displayed in internal web apps. Many of these image files, however, does not have a file extension. On Windows 2000 (IIS 5.0) this was no problem - the image file was sent to the browser and the browser recognized and displayed all images correctly.

But on IIS 6.0, I find that files without extension (no associated mime type) are not allowed, so I get 404 - Not found for all these images. If I add .jpg to the file name I can see the image, so it's not a matter of rights.

Does anyone know how to instruct IIS 6.0 to also allow files without extension?
LVL 3
jetaasenAsked:
Who is Participating?
 
Greg RowlandSoftware Designer, SysDBA, WebMaster OwnerCommented:
Interesting problem? I would never have believed it would work in the first place!

Searched Support.Microsoft.com product = IIS 6.0
Search string = allow files without extension

This article came up, currently unavailable?

      IIS 6.0 Does Not Serve Dynamic Content
       (555019) - When you request a dynamic content, from an IIS 6.0 Web server, and the services extension that is not being enabled on the Web server, you receive the following error message: HTTP Error 404 - File or directory not found.

0
 
jetaasenAuthor Commented:
Yes, as I said in my question - IIS 6.0 does not allow unknown mime types/file extensions. But you can add new and I have successfully loaded these images with custom extensions (like .xyz). But my question is: How do I allow files with no extension?
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
BAlexandrovCommented:
I have tried to register . extension for image/jpeg and also examined metabase (configuration settings) of IIS6 - nothing for turning off this behaviour. Probbaly it will be easyer to rename them - from command prompt: ren *. *.jpg

HTH
Bojidar Alexandrov
0
 
BAlexandrovCommented:
No this does not help! It is applicable only if you have extension to register.
0
 
tonyhall_mcseCommented:
This part didn't work?

-----------------------------------------------------
If you want to serve all files regardless of the file name extension (for example, if you cannot predict all files that will be served), follow these steps to add a wildcard character mapping:

(Note You should only add the wildcard mapping to the IIS MIME map as a temporary solution during troubleshooting. After you have determined that a missing MIME type is the cause of the issue, remove the wildcard mapping and add the specific mapping for the MIME type that you need to serve.)
Open the IIS Microsoft Management Console (MMC), right-click the local computer name, and then click Properties.
Click MIME Types.
Click New.
In the Extension box, type an asterisk (*).
In the MIME Type box, type application/octet-stream.
Apply the new settings. Note that you must restart the World Wide Web Publishing Service or wait for the worker process to recycle for the changes to take effect.
-----------------------------------------------------

Sorry ... sounded like it was feasible.

TTFN
Tony
0
 
BAlexandrovCommented:
Sorry, I did'nt read article till the end.

I have tried - this really works.
0
 
bakelsbvCommented:
That really helps, only you don't have to do this for the whole webserver, but you can also do this per website of virtual directory.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.