Avatar of YogiBear827
YogiBear827 asked on

Netwo

, I hope someone will be able to give me a pointer or two.

I have got a desktop machine running WinXP Home and a laptop running Win98. They are connected with a Belkin USB 802.11b Wi-Fi adaptor on the desktop and a Belkin 802.11b Wi-Fi PC Card in the laptop, running peer to peer. The internet connection is via a USB ADSL modem on the desktop machine.

Both machines are able to access the internet with no problems, however I can ping the internal network addresses and also internet addresses from the laptop, but with the desktop machine I can only ping 127.0.0.1, localhost, the network IP address of the desktop machine and the desktop machine by name and nothing else. I have already tried without the firewall loading on on either machine.

Both machines were given fresh installations of windows before I installed the Wi-Fi kit and once they were talking I patched them from Windows Update.

Thanks,
Richard
Windows Networking

Avatar of undefined
Last Comment
MaB

8/22/2022 - Mon
sirbounty

Enable NetBIOS over TCP/IP:
   XP utilizes DNS for communication by default.  To enable the systems to communicate via NetBIOS,
   proceed as above to enter Network Connections.
   Right-click your Local Area Connection and click Properties
   Scroll down in "This connection uses the following items:" to find Internet Protocol (TCP/IP)
   Select it (highlight it) and click properties
   Click the Advanced button on the General tab.
   Click the WINS tab.
   Under NetBIOS setting heading
    Click Enable NetBIOS over TCP/IP
   Click OK, OK, OK and close out of Network Connections & Control Panel

Are you trying to connect the two?
See here for ICS help:
 http://www.theeldergeek.com/icf_and_ics.htm
 http://www.geekgirls.com/windowsxp_home_network.htm

Let Everyone's permissions apply to anonymous users as well:
    Click Start
    Click Run
    In the Open box type SECPOL.MSC /S <ENTER>
    Navigate to Local Policies/Security Options.
    Double click "Network Access:Let Everyone permissions apply to anonymous users"
    Click Enabled and click OK
    http://support.microsoft.com/?kbid=318030
ASKER
YogiBear827

Sir Bounty,

I've enabled NetBIOS over TCP/IP and rebootedjust in case and it made no difference to the situation at all.

I'm posting all this from the laptop over the wireless network, so it must be almost there!

Thanks anyway
Richard
sirbounty

Richard - what are you trying to accomplish, exactly?

Connect the laptop to the desktop and vice versa?
Or simply get the desktop on the internet?

If the latter - can you do the following...

Start->Run->MSCONFIG <enter>

IPCONFIG /ALL > c:\ip.txt

and post ip.txt here...
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
Gareth Gudger

When you said you disabled the firewalls did you also disable the Internet Connection Firewall in XP. Its a built in firewall in XP.

Go to Network Connection and right click on your connection and choose properties. From here click Advanced and uncheck the Internet Connection Firewall.
ASKER
YogiBear827

I'm trying to get the machines to talk to each other so I can swap files etc. I want to end up with both machines able to see each other and access the internet. Both machines are currently able to access internet with no problems by using the wireless network and the ADSL on the desktop, so that obviously works, it'sjust that they can't see each other. The fact that the problem would appear to be on the desktop machine because it can 't ping anything other than itself would suggest that the problem would be there, but I can't see it. Probably because I've spent a couple of days at it and possibly can't see the wood for the trees!

Richard
ASKER
YogiBear827

Diggisaur,

That was my first thought! Sadly not right though, I like simple things!

Richard
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
sirbounty

I'd keep the ICF turned off for now...eliminates futile efforts.

Now, from both machines, type
IPCONFIG /ALL

It'd be great if you could post this here, but we can just presume some things here...

Let's say Desktop's IP is 192.168.1.100 and Laptop's is 192.168.1.101

The remaining items you want to be the same.  Both should have the same Subnet mask (255.255.255.0 for instance) and the same default gateway (192.168.1.1)

They should both be in the same workgroup as well and it helps to have the same user name and password on both machines.

Now try from the laptop...
Start->Run->CMD <enter>
 PING 192.168.1.100 <enter>
Post the results

From the desktop...
 PING 192.168.1.100 <enter>
 PING 192.168.1.101 <enter>
 PING 192.168.1.1 <enter>
Post the results

If that works then follow this route...initially from the laptop...
Click start->run->notepad %systemroot%\system32\drivers\etc\lmhosts.sam
You can copy and paste the line after run->

In the notepad window that opens,
192.168.1.100   desktop  #PRE

Click File/Save As and save it as (with quotes)
"LMHOSTS"

Now repeat on the desktop, but change the entry line to
192.168.1.101   laptop  #PRE
Click File/Save As and save it as (with quotes)
"LMHOSTS"

Next from both machines -
Start->Run->CMD
 NBTSTAT -R

Now you should be able to type
 PING LAPTOP
or
 PING DESKTOP
from both.

This should be the only line in LMHOSTS - all "#" (pound/number characters) are comment lines and are ignored...


If the above doesn't work or continues to fail responding to a ping, check your HOSTS file located in the same folder:
Click start->run->notepad %systemroot%\system32\drivers\etc\hosts

It might be there is a conflict there...
Good luck!
ASKER
YogiBear827

OK,

Ping from laptop:
ping 192.168.0.1

Pinging 192.168.0.1 with 32 bytes of data:

Reply from 192.168.0.1: bytes=32 time =11ms TTL=128
Reply from 192.168.0.1: bytes=32 time =5ms TTL=128
Reply from 192.168.0.1: bytes=32 time =5ms TTL=128
Reply from 192.168.0.1: bytes=32 time =4ms TTL=128

Ping statistics for 192.168.0.1:

ASKER
YogiBear827

Lets try not pressing the wrong button!

  Packets: Sent = 4, Received = 4, Lost = 0% loss),
Approximate round trip times in milli-seconds:
  Minimum  = 4ms, Maximum = 11ms, Average = 6ms

FROM DESKTOP

Ping 192.168.0.1

Pinging 192.168.0.1 with 32 bytes of data:

Reply from 192.168.0.1: bytes =32 time<1ms TTL=128
Reply from 192.168.0.1: bytes =32 time<1ms TTL=128
Reply from 192.168.0.1: bytes =32 time<1ms TTL=128
Reply from 192.168.0.1: bytes =32 time<1ms TTL=128

Ping statistics for 192.168.0.1:
  Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
  Minimum = 0ms, Maximum = 0ms, Average = 0ms

Ping 192.168.0.119

Pinging 192.168.0.119 with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 192.168.0.119

The desktop machine will however now resolve the name of the laptop to its IP address with the same result as above. At least that is one step forward!
Your help has saved me hundreds of hours of internet surfing.
fblack61
sirbounty

Okay - so what's 119?
ASKER
YogiBear827

The IP address that the laptop resolves to.
sirbounty

Okay wait...back up.
What is the laptop's IP address from IPCONFIG
and what is the desktop's?
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER
YogiBear827

The laptop's IP address: 192.168.0.119
and the desktop: 192.168.0.1

I've just tried running an FTP server on the desktop to see if I can access from the laptop and the laptop can download via the FTP server, haven't tried the other way round yet, but I suspect that it won't work because of the ping failure.

Richard
sirbounty

And you're sure ICF is turned off on the laptop?
If not - you can customize it to allow ICMP echo requests...
ASKER
YogiBear827

Certain, especially as the laptop is running Win98 and therefore hasn't got ICF! The tick box for ICF on the desktop machine is clear and when I am fiddling trying to make it work I disable the firewalls (Sygate) on both machines.
This is being written on the laptop which is connecting over the wireless, so it has got to be basically working.
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
MaB

Just a long shot and a question rather then a solution.

Could the problem be from using USB network adapters and not ethernet adapters?

BR MaB
ASKER
YogiBear827

MaB,

I tried connecting via an ethernet crossover cable once I first started to run into problems, just in case that would cure it.

Tried again just now after reading your suggestion and it is exactly the same as with the wireless connection, I can ping the desktop and the internet from the laptop, but only the local host from the desktop. I can connect the two by running a FTP server on the desktop and connect to that from the laptop, just not any other way!

Richard
ASKER CERTIFIED SOLUTION
Gareth Gudger

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
MaB

Good comment diggisaur. It rings a bell. Some previous network problem Q i followed was similar and got solved by running the winsock fix.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.