Solved

open *.JPEG with photo Editor and receive - No file format information can be found in the Registry

Posted on 2004-03-30
6
26,417 Views
Last Modified: 2011-08-18
this is my first post, so if I am missing info or this is posted incorrectly please let me know =)
Issue is on Windows 2k
I have a user attempting to open *.JPEG files and receives the following error-
No file format information can be found in the Registry
Followed by "Unknown file format"
When attempt to open with MS Paint -"Paint cannot read this file"
"This is not a valid bitmap file, or its format is not currently supported."
I have Followed and applied steps from - Microsoft Knowledge Base Article - 260151
http://support.microsoft.com/default.aspx?scid=http://support.microsoft.com:80/support/kb/articles/Q260/1/51.ASP&NoWebContent=1

But the same issue occurs.
I added user into power users groups and she was then able to access open jpeg files with MS Photo Editor without any problem.

Is there anything else that I could do in order for this user to have access to open jpeg files, with out being a member of the power users group??

0
Comment
Question by:netxit
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 44

Expert Comment

by:bruintje
ID: 10713834
so it looks like you still haven't the correct reg / permission entry under her normal user name / profile

if you chance the registry as described in the MS article under her power user login and retry as normal user does that help?
0
 
LVL 3

Expert Comment

by:AndrewGW
ID: 10714069
The most likely culprit is the files extension .JPEG   this is probably a file copied from the web and it was created on a mac and given a four letter extension (extensions don't mean anything in mac talk).  What you need to do is from Windows Explorer edit the file name(s) to remove the "E" from the extension to make it  filename.JPG
Then Windows programs will recognize the file name.
You may also have files that have no extension which are visible in Windows Explorer but not when you try to do a File-Open command.  Again, if you know the type of file, just add the proper extension .JPG  .TIF  .DOC  etc.
Hope this helps
Andrew
0
 

Author Comment

by:netxit
ID: 10738973


bruintje:
I have double-checked the registry permissions and I have added them correctly,
When user is a member of the power user group and she is able to open jpg files with no problems.  
She still has full control on the registry keys as specified in MS Kbase Article - 260151
The registry permissions stay the same if she is a power user or not.

Andrew:
I went to try your suggestion but it was already named with *.jpg,
My origial post was incorrect (sorry) the files are *.jpg files that I have this issue with.

Additional Steps I have tried:
I granted the user change right to WINNT directory, and the same issue occurs.

Something else I noticed is that according to the MS kbase Article the user needs to be granted full control over these registry keys (which she is) but I did notice that power user group only has READ access which is kind of odd considering that when added to power users group she is able to open these files. I "think" that there is a certain file or folder that she needs access to but what if that is the case.
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 33

Accepted Solution

by:
Jeroen Rosink earned 500 total points
ID: 10755648
Hello netxit,

perhaps this might help you:

http://oldlook.experts-exchange.com:8080/Applications/MS_Office/Q_20720587.html

regards,

Jeroen
0
 

Expert Comment

by:lowtech204
ID: 13040352

This problem is due to the fact that you do not have the necessary permissions the Graphics Filters registry key.

To resolve this issue, use the following, which will vary slightly based upon your operating system.

1. Log on with administrative privileges.

2. Start /Run / Regedt32 / OK.

3. Select the HKEY_LOCAL_MACHINE\Software\Microsoft\Shared Tools\Graphics Filters key.

4. Press Permissions on the Security menu.

5. In the Name list of the Registry Key Permissions dialog, select Users.

6. Check the Full Control permission under Allow and press OK, or press Advanced and apply these more restrictive settings
0
 

Expert Comment

by:spmc
ID: 13209352
Is it possible to apply theses setting through group policies using a 2003 server?
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will guide you to convert a grid from a picture into Excel format using Microsoft OneNote and no other 3rd party application.
This article descibes how to create a connection between Excel and SAP and how to move data from Excel to SAP or the other way around.
The viewer will learn how to make their project stand out over others by learning how to change colors and shapes, add spaces, change directions, and add bullets to their charts.
The viewer will learn how to use a discrete random variable to simulate the return on an investment over a period of years, create a Monte Carlo simulation using the discrete random variable, and create a graph to represent the possible returns over…

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question