• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1346
  • Last Modified:

Oracle Internet Directory troubleshooting

I have recently installed Oracle 9iAS, release 2 and am trying to configure Portal. I can't get past the Single Sign On.

When I try to login to Portal, I get this message on the Single Sign-On web page: Error: There is an error in the setup of the directory used for authentication. Please contact the administrator to make sure the directory is setup appropriately. (WWC-41655)

I don't know where to start to troubleshoot the OID for this. I went through Oracle's Note 206191.1 "Troubleshooting Oracle Portal 9.0.x" and got as far as step 3 (Single Sign On Server). Enterprise Manager says SSO is up, but I could not log in using User Name: orcladmin and its password.

I checked my dads.conf. Here's how it reads:  [The values in brackets aren't the real ones]

<Location /pls/orasso>

SetHandler pls_handler
Order deny,allow

Allow from all
AllowOverride None

PlsqlDatabaseUsername orasso

PlsqlDatabasePassword [encrypted password]

PlsqlDatabaseConnectString host:port:sid

PlsqlDefaultPage orasso.home

PlsqlDocumentTablename orasso.wwdoc_document

PlsqlDocumentPath docs

PlsqlDocumentProcedure orasso.wwdoc_process.process_download

PlsqlAuthenticationMode SingleSignOn

PlsqlPathAlias url

PlsqlPathAliasProcedure orasso.wwpth_api_alias.process_download

PlsqlSessionCookieName orasso

</Location>


<Location /pls/portal>

SetHandler pls_handler

Order allow,deny

Allow from All

AllowOverride None

PlsqlDatabaseUsername PORTAL

PlsqlDatabasePassword [encrypted password]

PlsqlDatabaseConnectString [myserver.stanford.edu]:1521:iasdb

PlsqlDefaultPage portal.home

PlsqlAuthenticationMode SingleSignOn

PlsqlSessionCookieName portal

PlsqlMaxRequestsPerSession 500

PlsqlDocumentTablename portal.wwdoc_document

PlsqlDocumentPath docs

PlsqlDocumentProcedure portal.wwdoc_process.process_download

PlsqlNLSLanguage AMERICAN_AMERICA.WE8MSWIN1252

PlsqlPathAlias url

PlsqlPathAliasProcedure portal.wwpth_api_alias.process_download

PlsqlFetchBufferSize 128

</Location>


0
solheimkj
Asked:
solheimkj
1 Solution
 
rogerperkinsCommented:
Be sure to include your domain name in the url when you go to the sso url, also include the hostname* in the bypass proxy list on your Internet Explorer Options.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now