Outlook Web Access is blocked by ISP

My ISP blocks incoming http port 80. I have a cable modem that gives a dynamic IP address to my Sonicwall firewall. I also have a few Wintel servers behind the firewall, one of which I would like to get Outlook Web Access to work on. I depend upon port redirection to get the different services to work. I would also like to advertise a web page, but I'll work on that problem after this one. I have an external DNS service that can do DNS port redirection. But I can't seem to get what I want to do to work on the server end. The firewall has redirected port 8080 to the correct server.
Now for the question. How do I get OWA to use a different port?  I woulld like to use port 8080 for the Outlook web access page.
Rob
LVL 1
fi8224Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

What90Commented:
Hi fi8224,

Open up ISM, find the (usually the default web site)OWA site, right click on properties and change port 80 to port 8080.

That's it.

0
fi8224Author Commented:
I've tried that. I would type in just the "remote.domainname.com" but it wasn't automatically filling http:// in the web browser. Duh... Still can't get the page to open up outside of the network though.
I must be have some kind of firewall issue because while I can resolve the web page for exchange internally and externally, I can only open the page internally. Externally it times out. When I say resolves, I can see the web page trying to go to the correct ip address and port number. The page just sort of gives up trying to open.
Any ideas on how to check if its a firewall issue or not.? Because I'm using a cable modem with a dynamic ip address, its not feasable to try the connection with out the firewall.
0
What90Commented:
So you were trying (on a web browser) http:// remote.domainname.com/exchange:8080 ?

What version of exchange are you running and what could you get the default web site to appear from external sources?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

shailendra_patankarCommented:
Hi..

First, check your firewall setting.. whether the port 8080 is blocked or use by someother application..

SEcondc, Check the Dns entires and IIS setting for the default web setting...

Third, Check at the ISP whether that have blocked the port.

Forth, You can Use any Sniper package to track the port connection..

talk to the ISP guys and stick to basic... talk to Microsoft whether You can change the default port for OWA
0
fi8224Author Commented:
I've noticed in other posts that people seem to have some confusion about DNS port redirection. Let me clear this up. It is possible to have a DNS provider, like www.easydns.com, to port direct a dns query. This helps for situations where the desired port is blocked for what ever reason. In my case port 80 is blocked and out of my control. So I have the DNS provider redirect my domain name to port 8080. When I ping remote.domainname.com, it wont resolve because its only going to port 8080. When I try to go to the web page from a workstation outside of my network, which I can do from a client's server using terminal services, I can see the browser resolve the name http://remote.rob-tec.com to 67.86.166.12:8080. That tells me that that part of the configuration is working correctly.
I can't however get the web page to open. So something else is the problem.
I can open the web page internal to my network when I type the http://internal ip address:8080 in my browser. That tells me that I have the "default web site" configured to use port 8080 correctly.
My only guess is that some how the firewall is screwing things up. Even though I'm clearly redirecting port 8080 for tcp,6, to the internal ip address of the server or that somehow I don't have the security settings on the website set correctly.
Does anyone know what the correct settings should be to allow proper access from the outside.
0
mikeleebrlaCommented:
you have some other issues going on,,,,

i just did an NSLOOKUP on remote.rob-tec.com and it resolved to 216.220.40.244 from web.fwd.easynds.com

but if i typed in http://remote.rob-tec.com/ in IE you can see that it is attempting to open 67.86.166.12:8080 just like you said,,, would seems like it would work,, but i still get a page cannot be displayed error......

even it i type in http://67.86.166.12:8080 directly,, i still get a page cannot be displayed error,,, which means you have at least 2 proplems,,,,

1. http://67.86.166.12:8080 isn't getting to your webserver like it should... my guess is your router isn't forwarding it correctly. what is probably happening is your router is set up to forward anything looking for http://67.86.166.12 to port 8080 , but the fact that port 8080 is already attached to the end is messing it up. what kind of router do you have?

2.  for whatever reason,,, and i dont know why,,, you are getting two different IPs when you try to resolve http://remote.rob-tec.com/... i am getting  http://67.86.166.12:8080 and 216.220.40.244  depending on which method i do the lookup.
0
fi8224Author Commented:
My dns service is easydns.com. They are a great service, easy to configure and make changes via the web. I use them for many clients. The 216.220.40.244 is one of their servers. I have email bagging set up. Irrespective of the dns info, if you enter the ip address:8080, should get to the web page. But you don't. It errors out. I have a feeling that the isp may be actually filtering out port 8080 as a proxy port. So I'm going to try changing the port to something different. I will advise what it is when I do.
PS: this is a great interface for tech support. I value each and every response.
Rob
0
fi8224Author Commented:
I found that my isp was also blocking port 8080. I changed the port thanks for your inputs.
0
What90Commented:
shailendra_patankar identifed the problem, and I answered the first question :-)

Split between the two of us?
0
fi8224Author Commented:
You guys were right. You definately had me on the right track. I ended up finding a port that wasn't blocked by the ISP and then doing dns port redirection with an online dns service. The one I used and use for a number of clients is www.dns.com. A great service for 20.00 a year.
0
fi8224Author Commented:
excuse the error, I meant to say www.easydns.com
0
What90Commented:
Ta for the update, who was the ISP out of curiosity?
0
fi8224Author Commented:
Cablevision
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.