Solved

w2k server + rh linux webserver dns problems

Posted on 2004-03-30
7
410 Views
Last Modified: 2013-12-06
I have one w2k server (pdc) and one Red Hat Linux Enterprise Linux 3.0 server. This w2k
(called hast2.hast.fi) server works as fileserver, people log on that and get their resourses from there.
The RH linux-server is new and it is supposed to become Intranet (web)server (Apache, PHP, mysql etc.).
I have Apache, PHP up and running and my problem is when I try contact this webserver(linux) named intra.hast.fi,  it takes a long time to before page opens. This must be somekind of DNS problem. I have added this intra.hast.fi (and its ip address) into w2k dns (hast.fi forward lookup zones). I have tried different options on network configuration and HTTP configuration (virtual host) on linux server, but the same problems occurs. I don´t have any dns services running in linux box.

Please let me know if You Experts have suggestions how to setup those servers to communicate with each other like they are supposed to !
0
Comment
Question by:jartsa
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 10

Expert Comment

by:anupnellip
ID: 10721984
does just giving the Ip address in the browser make the page open faster . If not then you should look at apache configuration !
0
 

Author Comment

by:jartsa
ID: 10722399
Sometimes when I open connection with domain name, page cannot be displayed occurs. Opening page with IP-address doesn´t make opening any faster ! In Apache I have configured following
servername: hast.intra.fi (do I need to use domain name here ?)
virtual hosts: defaults (I have tried IP-based virtual host intra.hast.fi > and its IP, but no difference)

What else need I configure there ?

 

0
 

Accepted Solution

by:
umair1 earned 125 total points
ID: 10724030
Remove all the DNS configuration.
Add the hostname IP combo to the hosts file on the client (eg winnt/system32/drivers/etc/hosts on nt/xp)
Ensure that the client is not using a proxy for local addresses (on IE under LAN Settings check "bypass proxy server for local addresses" ) if you are using a proxy server.

If you still have the speed problem then its an apache config problem. Otherwise its a network problem.
0
Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

 
LVL 2

Expert Comment

by:enkrypter
ID: 10727300
IT's definitely not a DNS issue.  If ti resolves at all the problem is not DNS.  Test this with a ping.

Ping  [your server DNS name] -l 4590 -t

This will send a 4k packet repeatedly.  Keep track of any loss or latency.  If the server pings consitently without loss, then you have an issue with apache.  If and when you do attempt to troubleshoot apache, I find it best to eliminate variables first by disabling PHP, mysql, SSL, and any other apache addon modules.  Test a stripped down version of apache then slowly add back services to locate the bottle neck.

PHP can do some nasty things, especialy if mysql is involved.  I am willing to bet that DNS is not even a factor, but either network overload or Apache.
0
 
LVL 10

Expert Comment

by:anupnellip
ID: 10730047
It could be the reverse host lookup on your apache server .  
In your Apache Server httpd.conf change
HostnameLookups  to off
 
0
 
LVL 10

Expert Comment

by:anupnellip
ID: 10730088
also give your server Ip in httpd.conf for

BindAddress
 
 
0
 

Author Comment

by:jartsa
ID: 10738405
Now I noticed another strange thing in opening connection to server. When I open connection after a while (like this morning), I can´t open connection with domain name, and when I open the connection with ip-address couple of times and after that works domain name also.
I have checked apache configuration and HostnameLookups are off , and I Binded server address also, but  opening connection I still slow.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Active Directory Disappeared 2 54
exchange, IIS, AUTODISCOVER, OWA 18 68
How do I enable VPN on server 2008 R2 19 63
bash: ./Facebooker.pl :Permission Denied 9 58
Resolve DNS query failed errors for Exchange
In this article, I am going to show you how to simulate a multi-site Lab environment on a single Hyper-V host. I use this method successfully in my own lab to simulate three fully routed global AD Sites on a Windows 10 Hyper-V host.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question