Solved

telnetd: could not grant slave pty

Posted on 2004-03-31
7
1,975 Views
Last Modified: 2013-12-27
Sir,
We have Sun Solaris (Sun OS 5.6) E450 Server. When the user count ( #who | wc -l ) reaches to 185 then it is not allowing any more new Login and it will show the message "telnetd: could not grant slave pty". But I noticed that some times it will allow upto 189 connections.

Can you please suggest what is the reason and how to rectify this.

Thank You


0
Comment
Question by:Pramodpp
7 Comments
 
LVL 18

Expert Comment

by:liddler
ID: 10724247
you can increase the number of ptys, by setting the pt_cnt value in /etc/system and rebooting
0
 
LVL 1

Expert Comment

by:mdhmi
ID: 10725607

There are two relevant variables in /etc/system.

System V:
set pt_cnt = <num>

BSD Style tty:
set npty = <num>

If you change npty in /etc/system you will also need to replace the default pstl line in /etc/iu.ap (the '47' entry).

Mark
0
 

Author Comment

by:Pramodpp
ID: 10732579
Thanks for your comments.
But in our system pt_cnt is already set to 250.
One thing I noticed is some times it is allowing up to 190 to 191 users and some times it will start giving this error message when the user count reach to 185.
Waiting for your expert comments.... Thank You
0
Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

 
LVL 1

Expert Comment

by:mdhmi
ID: 10734105

Please post the output of 'grep cnt /etc/system' in addition to the contents of your /etc/iu.ap file.  If you have changed any settings in /etc/system your box will need to be IPL'd.

Mark
0
 
LVL 18

Expert Comment

by:liddler
ID: 10736845
mdhmi - IPL'd ?? Don't bring that scary mainframe language here

 Pramodpp - it sounds like you are running out of some resource, maybe look at increasing the ulimit for root, as telnetd is run by root
0
 

Accepted Solution

by:
modulo earned 0 total points
ID: 11387580
PAQed - no points refunded (of 250)

modulo
Community Support Moderator
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In tuning file systems on the Solaris Operating System, changing some parameters of a file system usually destroys the data on it. For instance, changing the cache segment block size in the volume of a T3 requires that you delete the existing volu…
Using libpcap/Jpcap to capture and send packets on Solaris version (10/11) Library used: 1.      Libpcap (http://www.tcpdump.org) Version 1.2 2.      Jpcap(http://netresearch.ics.uci.edu/kfujii/Jpcap/doc/index.html) Version 0.6 Prerequisite: 1.      GCC …
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
In a previous video, we went over how to export a DynamoDB table into Amazon S3.  In this video, we show how to load the export from S3 into a DynamoDB table.

943 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now