We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

ifconfig output question

midguy
midguy asked
on
Medium Priority
11,456 Views
Last Modified: 2013-12-21
Hi All,

I installed solaris9 on sunfire v440 server. There are two emulex HBA cards installed. when I install driver abd reboot server I am getting ifconfig output like this. It is configuring interfaces for lpfc0 and lpfc1. I don't know from where it is plumbing interfaces. Any body have idea the problem.... thanks.

ce2: flags=1000863<UP,BROADCAST,NOTRAILERS,RUNNING,MULTICAST,IPv4> mtu 1500 index 4
        inet 172.16.31.204 netmask ffffff00 broadcast 172.16.31.255
        ether 0:3:ba:72:69:96
lpfc0: flags=1000862<BROADCAST,NOTRAILERS,RUNNING,MULTICAST,IPv4> mtu 65280 index 5
        inet 0.0.0.0 netmask 0 broadcast 255.255.255.255
        ether 0:0:c9:3b:8:7c
lpfc1: flags=1000862<BROADCAST,NOTRAILERS,RUNNING,MULTICAST,IPv4> mtu 65280 index 6
        inet 0.0.0.0 netmask 0 broadcast 255.255.255.255
        ether 0:0:c9:39:e8:63
Comment
Watch Question

Commented:

Make sure you don't have any *lpfc* hostname files in /etc.  Also recheck your /kernel/drv/lpfc.conf file.

Mark

Commented:
These interfaces come from /etc/hostname.lpfc0 and /etc/hostname.lpfc1 files.

u can also do
ifconfig lpfc0 unplumb
and these will be unplumbed.

Author

Commented:
there are no /etc/hostname.lpfc0 and lpfc1 files in /etc directory. I need to fix this without unplumbing interfaces.

Commented:
If you are using the HBA's just for SAN storage, then you must edit your /kernel/drv/lpfc.conf file and change the setting for "network-on=1;" to "network-on=0;"   When you installed the HBA, you were asked if you wanted to configure networking, which meant LAN networking, and this created the interfaces for you because you answered yes.

You have to unplumb the interfaces to get rid of them by doing:

ifconfig lpfc0 down unplumb
ifconfig lpfc1 down unplumb

Then, after you have edited the lpfc.conf file, you can run the following:

update_drv -f -n lpfc

and it will re-read the config file on the fly without the LAN networking portion of the lpfc kernel module loading.

Author

Commented:
this parameter already set to network-on=0; don't know from where it is configuring
You need to make sure that a entry in your /etc/hosts file exist that matches the names specified in /etc/hostname.lpfc0 and /etc/hostname.lpfc1.  This is how Solaris assigns IP addresses at boot time, matching /etc/hostname.net_device names to /etc/hosts entires.

Commented:
What is the output of:
ls -ld /etc/host*

and have you followed  durindil  {10746421} instructions above?

Commented:
When you were installing the driver, did it leave a log of some kind.  You may want to take alook exactly what files it wrote to.  Your answers may be there.  
Commented:
Unlock this solution with a free trial preview.
(No credit card required)
Get Preview
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a free trial preview!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.