Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 167
  • Last Modified:

imported HTML form has "dead" first text box

I created an HTML page with a survey to be emailed via our Lotus Notes platform.
All fields can accept user input Except the first text field (item 1.c ).(this is not occuring if sending via any other app, so its not the code)

Any issues I have missed? Is it my encoding? I tried unicode and got the same problem. 5 hours spent on this one field and I gave up.

The page I import can be seen at: http://150.108.13.114/6.html

Gratefull for any feedback.
0
expert_2b2004
Asked:
expert_2b2004
  • 3
  • 2
  • 2
1 Solution
 
HemanthaKumarCommented:
It is not clear of what is that you want ? should Email field not accept any inputs ?? why ?

~Hemanth
0
 
expert_2b2004Author Commented:
It should accept input but it refuses to be a live field although the last two are live from the start.
I have since fugured out that if I double click anywhere within the form first, it makes is editable(read, fillable).
Is there a way to specify that the email should be editabble from start.
Something like the javascript "onload=focus()" ?
0
 
HemanthaKumarCommented:
"Live Field" ?? What is that ?

You are talking about this on web or notes client ? SInce you said when you double click anywhere in the form it makes it editable .. so I believe it is in notes. If that is the case then you have to understand the document always opens in read mode and then you can enable it to edit. Or there is a form setting which will open it in edit mode by default , check the form prop for "Automatically enable edit mode" (2nd tab of the form properties)
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
expert_2b2004Author Commented:
yes, this is in Notes, I have composed a simple html form page and imported it.
For recipients to be able to answer the survey, they need to double click the email first( i set up a dummy link to double click)
The "Automatically enable edit mode" (2nd tab of the form properties) would be perfect but i do not seem to have access to this . I presume it would be under document properties-->fields-->form. This only shows me "data type" and "length"... but I cannot find a way to modify the properties.
Am i looking in the wrong area?

(Thank you for your patience)
0
 
HemanthaKumarCommented:
No, that is in the design of the form.. open the form in the designer and you should be able to see it..Also enable store form in document.. So that the form when sent to users via mail will contain whole form with the document or you can invoke that property programmatically too
0
 
qwaleteeCommented:
Urk.  Imported HTML will cause you problems in your survey.  You shoudl replace all the "fields" that are imported with Notes fields, because the importer does not actually import those dropdowns as fields.  Otherwuse, you will have a huge problem processing the return results.

To make the form "live," enable the property "Automatically enable edit mode," so the user does not have to double-click.  You can also use hide-when formulas to automatically hide fields 1b/1c if 1 is YES.

Fields 1c and 10 are duplicative.

For Notes mail users, you should not need to ask for e-Mail address at all, as you will know it automatically.

You can have your submit button delete the e-mail automatically after sending.
0
 
qwaleteeCommented:
FYI, my sister is in Fordham, though she's currently in the law school, not undergrad.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now