Solved

Problems installing EPSON RX500 on USB2.0

Posted on 2004-03-31
3
4,676 Views
Last Modified: 2007-12-19
I have an Epson RX500 printer that was successfully installed on my old USB hub which was vsn 1.1.  I decided to upgrade my USB adapter and hub to the hi-speed vsn 2.0 (USB 2.0). I removed my old PCI card and replaced it with the new PCI USB2.0 card (it has 2 ports) and successfully installed the vendor-supplied drivers for the adapter. I then connected a 4 port hub (also hi-speed USB2.0 from the same vendor, Adaptec; the adapter and the hub came as a kit). Tested it out by synching my Palm Pilot and downloading some pictures from my digital camera ... worked fine, so I have to believe that the installation of the new USB2.0 adapter and hub is ok.

I'm running Windows 2000 Professional with everything up-to-date.

Then I attempted to install my Epson RX500 printer (from scratch ... had removed it from the system before I installed my new hub). With Epson installation, you don't plug in the USB cable til the setup program tells you to.  Set-up program got to that point, and I plugged the printer's USB cable into one of the free ports on the hub. The screen immediatley went black and the system spontaenously rebooted ... and then, after the Windows 2000 splash screen, I got a blue screen with a bunch of stuff about a "stop error". I finally figured out that if I unplugged the cable from the hub I could get Windows 2000 to boot up successfully. I then uninstalled the Epson printer software/drivers and tried again and got the same problem (three times I tried!). (Also verified that the hub port worked ok w/ my digital camera.)

So then I decided to try installing the printer with the USB cable connected directly to one of the ports on the adapter card (because I've read some things about some devices not working right when connected thru a hub). So I removed all the Epson stuff ... uninstalled all software; deleted all registry keys; deleted all directories (in that order). Rebooted, then started the setup from scratch (from Epson-supplied CD). When I was prompted to plug the USB cable in, I plugged it in to the USB port on the adapter. Happily, no black screen and rebooting and stop errors this time! BUT ... what happens is the "Found new hardware" wizard comes up, and it's found "USB2.0 MFP(Hi-Speed)" and I follow all the recommended actions to search the Epson CD for the driver. But it can't find a driver for "USB2.0 MFP(Hi-Speed)".

So then I downloaded the "latest" printer driver from the Epson website (which I think is the same as the version on my CD) and tried installing that. Same exact problem. Setup is trying to install "USB2.0 MFP(Hi-Speed)" and can't find a suitable driver.

I've emailed Epson but so far all they say is uninstall/reinstall, which, of course, I've already done several times.

Any ideas? And why would I have the "black screen/reboot" problem when trying to go thru the hub? And why can't Epson's setup program find the correct driver?

I'm getting ready to put my v1.1 adapter and hub back in!
0
Comment
Question by:alicia1234
3 Comments
 

Author Comment

by:alicia1234
ID: 10737073
I solved this myself ... sort of ... and I'm documenting it here in case it helps anyone else...

Installation of USB 2.0 stuff …
1. What I did wrong was that I didn’t get the latest drivers from Adaptec (I had 2.1.3000.2000 and 3.1.0.4001 was required for “composite” device support and my Epson printer is a composite device.
2. I uninstalled or disabled what looked like “old” USB stuff from Device Manager and it turns out that this stuff was required to support 1.1 devices; I found on Adaptec site that there are certain “Windows drivers” required for USB2 Support in order to support the 1.1 devices.
When I removed everything from under USB in Device Manager and then started from scratch and used the downloaded latest drivers, the adapter and hub worked ok.

Installation of Epson …
1. Once I had the latest Adaptec drivers, I reinstalled the Epson RX500 from the Epson CD and according to instructions in the “Start Here” document.
2. I ran in to some difficulty when setup tried to install USB Printer Support and I selected the “recommended” driver which was in the “Win9x” directory on the CD (I have Win2000). The installation of “USB2.0 Printer Support” didn’t finish because something was missing from the inf file.
3. For everything after that ("disk drive" and "generic volume"), I selected the Microsoft driver instead of the Epson recommendation and the remaining stuff went ok.
4. When I rebooted, it found new hardware … USB Printer Support .. and this time I picked the Microsoft driver. Now had “USB Printer Support” in Device Manager.
5. BUT .. printer didn’t work. I uninstalled Epson Printer Software (that removed printer and composite support from Device Manager) and restarted, then installed just the drivers from the Epson CD. Noticed that files were being copied from WIN2K_XP dir on CD. Installation completed successfully but I was never asked to pick drivers.
6. Device manager now has Adaptec USB Composite Device Support, USB Mass Storage Device, and USB Printing Support.
7. Restarted. Printed from MS Word; got ink levels and it printed ok. But same delay before printing as what I had with old USB, so not sure what new USB got me.

Open Question:
Should I have “USB 2.0 Printer Support” instead of “USB Printing Support” and if so, how do I get it?
0
 
LVL 4

Accepted Solution

by:
Da-Bu earned 100 total points
ID: 10737169
There is no USB 2.0 Printer Support. It is automatic. If your printer support USB 2.0, EPSON RX500 supports it, and you have USB adapter which is also USB 2.0, then they comunicate at 2.0 usb standards..
There is other thing. Sometimes printers and scanners have usb 2.0 label, and they support usb 2.0. But that is all, they don't use 2.0 speeds. That is probably your case. Sorry :-)
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to solve seemingly unsolvable printer issues. Users sometimes run into printing issues where all the normal steps do not seem to work. Well the steps below can show users how to take one extra step beyond the normal steps needed to remove old…
Causes of paper jams:The following are the main causes of paper jams. Guides:If the guides for the paper are not set correctly they may cause the paper to enter at an angle. You should ensure that the guides are set correctly for the paper type a…
Migrating to Microsoft Office 365 is becoming increasingly popular for organizations both large and small. If you have made the leap to Microsoft’s cloud platform, you know that you will need to create a corporate email signature for your Office 365…
Edureka is one of the fastest growing and most effective online learning sites.  We are here to help you succeed.

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now