• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 190
  • Last Modified:

Problems turning off welcome page and getting html directory content recognized

On redhat linux enterprise version 3 / apache web server ...
I installed a file called "index.html" in /var/www/html.
I set up only one host / virtual host as a name-based host.
I edited the welcome.conf file to "comment out" all lines as instructed.
I restarted the apache server (service httpd restart)

I access the webpage with browser from other machine and same machine.
I see the Redhat default Welcome test page.

What do I do to get the Index.html to load in the browser when I put just "www.xxxxxxxx.com" (my webpage) in the URL?

Thx.    - Grant
0
grant-ellsworth
Asked:
grant-ellsworth
1 Solution
 
Alf666Commented:
Are you sure you named your index.html page "index.html" (low case), and not index.htm or Index.html ?

Then, check the access rights on this page :

chmod 644 index.html

You can also completely delete the welcome.conf file. It's of no use anymore.
0
 
grant-ellsworthAuthor Commented:
Hello.  I did verify the name.  
I already deleted the welcome.conf - the apache default welcome still displayed!!!   Why??
I'll double check the chmod setting.

Further clues?
0
 
tcmvCommented:
Check here for a similar question ....

http://www.experts-exchange.com/Security/Linux_Security/Q_20935931.html


Hope that helps,
-tcmv
www.mvix.net
0
Restore individual SQL databases with ease

Veeam Explorer for Microsoft SQL Server delivers an easy-to-use, wizard-driven interface for restoring your databases from a backup. No expert SQL background required. Web interface provides a complete view of all available SQL databases to simplify the recovery of lost database

 
grant-ellsworthAuthor Commented:
For TCMV ... Thanks for the link = interesting reading, but not related to my problem.   Looks like the Redhat configuration program guts the httpd.conf file - I need to hand edit???
0
 
owensleftfootCommented:
Make sure  DocumentRoot in httd.conf is set to /var/www/html
0
 
grant-ellsworthAuthor Commented:
solved problem - changesmade thru the GUI interface were not recorded correctly in the config file.  I edited the config file directly (httpd...) then the features worked.  Bug in Redhat LUnux ES

case closed.
0
 
grant-ellsworthAuthor Commented:
Please note that the person filing the problem resolved the issue.  There is no way to flag the problem filer's comments as the solution - yet the solution is germane to the problem.  if you want to take my last message and paste it into one of your own, I'll be glad to "accept" your answer.  You get the points, the forum gets a solution to a vexing problem.  And I have a place to come back and search after I've forgotten how I solved the problem.
0
 
grant-ellsworthAuthor Commented:
My concern is that normal cleanup would lead to deletion of the problem and resolution.  If the problem and resolution will emain in the database for future users, then I have no problems.
0
 
DarthModCommented:
PAQed with points (350) refunded

DarthMod
Community Support Moderator
0

Featured Post

Free recovery tool for Microsoft Active Directory

Veeam Explorer for Microsoft Active Directory provides fast and reliable object-level recovery for Active Directory from a single-pass, agentless backup or storage snapshot — without the need to restore an entire virtual machine or use third-party tools.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now