Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 671
  • Last Modified:

Open Mail Relay

I have been trawling through all the past entries on this topic to no avail, basically I am running a single Exchange 2000 server SP2 which has it's SMTP virtual server to only allow relaying to the "list below" in the list I only have the three subnets that this server serves. I have been through the IIS settings on this server to ensure that this is the case for all entries in there also. I also have a server sitting in front of the exchange server scanning SMTP running Network Associates Webshield, this also has it's "Anti spam Relay" configured to only traffic from the three subnets, it also has IIS and SMTP disabled. However despite all this we are an open mail relay, I have even just stopped the virtual server and tried the external Relay tester again and it still came back as an open relay which tends to make me think that Exchange is configured correctly and this is something else. Does anybody have any ideas? I am getting desperate.
Cheers
0
mayiain
Asked:
mayiain
  • 4
  • 2
1 Solution
 
hcoltrainCommented:
Mayiain,

 What relay tester are you using? And what test are you failing?


 Harris C
0
 
mayiainAuthor Commented:
http://members.iinet.net.au/~remmie/relay/
http://www.mob.net/~ted/tools/relaytester.php3

These are the two I have been using today but I generally get the same response wherever I test it from.eg

Connecting to xxx.xxx.xxx.xxx ...
<<< 220 xxxxxxx.xxxxxxx WebShield SMTP V4.5 MR1a Network Associates, Inc. Ready at Thu Apr 01 14:54:16 2004
>>> HELO godfather.mob.net
<<< 250 xxxxxx.xxxxxxxx Welcome godfather.mob.net
>>> MAIL FROM:
<<< 250  ... OK
>>> RCPT TO:
<<< 554 SPAM-Relay detected
0
 
hcoltrainCommented:
Mayian,

 I beleive by default, that Exchange accepts mail from <> -null sender, as to be RFC complaint.  However, since spammers can use this against you a relay test will consider servers that allow this, as Open Relays. Looks like the test gets to sending mail off your server, where the <MAIL FROM:>field is blank and labels it as an open relay.

 In any case, you can solve this by having your users use SMTP Authentication. Try turning it on, and then running the tests and see what you receive. I am not sure, how to disable this in Exchange, but I am sure it can be done.

 Harris C
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
mayiainAuthor Commented:
Does anybody else no how to disable this in exchange?
0
 
mayiainAuthor Commented:
I have not abondoned it but as there have been no further suggestions offered or clarifications given there is not much I can do....
0
 
What90Commented:
Hi mayiain,

Is this what you wanted?

http://www.msexchange.org/tutorials/MF005.html
0
 
mayiainAuthor Commented:
Certainly is, many thanks
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now