[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 742
  • Last Modified:

Help! I can't delete SPAM mail from the Exchange 2003 queue!!

Help! I have a severe SPAM problems that have clogged up my queue.  I have followed all of MS' advice on creating new smtp connector to move everything to one queue and got rid of most of the spam.  But now I have 6000 messages that are stuck and won't 'delete w/ no NDR'.  The Exchange System Manager just hangs when I try.  Yes, I have run a full virus scan just to be sure.  It looks like the messages are all NDR's that are clogging up my queue.  Does anyone know another way to delete messages from the queue????  If I start the services again....it starts replicating like mad.  I have checked to make sure that there is no relaying and logged to check for authenticated user relays as well.  PLEASE HELP!!!
THANKS!!
0
kteal
Asked:
kteal
  • 4
  • 4
1 Solution
 
kristinawCommented:
Have you tried going directly into the mailroot folder on the box and deleting them there? Browse to (whatever drive letter you have Exchange installed on) D:\program files\Exchsrvr\Mailroot\vsi 1\ and then you will see all the folders. Check your queue folder. If this is where the messages are located, you can stop the Exchange services and manually delete the items. Be careful not to delete any valid messages!

hth,
Kris.
0
 
ktealAuthor Commented:
I've deleted everything in all 3 folders w/in the vsi 1 folder....however, i stil have 600 emails in the queue and as soon as i turn on smtp....they replicate like mad.
0
 
ktealAuthor Commented:
actually i believe it is all ndr mail generated bythe postmaster@mydomail.com account. Is there any way to disable this account?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
kristinawCommented:
Well, you can. Have you considered disabling NDR's temporarily until all this virus activity subsides?
0
 
kristinawCommented:
have you checked to make sure you're not an open relay?
0
 
ktealAuthor Commented:
i have disabled the ndr's in the global settings and also made sure (via telnet) that i;m not an open relay.
0
 
ktealAuthor Commented:
it is all incoming mail at this point....i have listed the spammer's ip addresses in the global settings to deny connection to my smtp...however, i am still receiving email from those domains.  I also made sure that I activated the filters in the advanced properties of the smtp settings....How are these emails still getting in??
0
 
kristinawCommented:
Have you considered added some spam filtering software to your setup? Its the only truly effective way to stop this kind of thing.
0
 
obeshawdCommented:
The problem is that you are getting spam as soon as you deleted it because you have an open relay.  Lock your relay down, delete the messages(bad ones) in the queue, and order is restored.
0

Featured Post

Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now