Solved

Cisco 515e with DMZ

Posted on 2004-04-01
8
480 Views
Last Modified: 2008-02-26
I have an installed and mostly functioning 515e, however I've been unable to configure the DMZ to allow access to the webserver that resides there.  The following functions do work; inside access out, dmz access out, inside to dmz.  I configured the router using a combination of the PDM interface and the command-line.  I'm enclosing my complete configuration, with the exception of my public IP addresses.

Thanks, Phil Howard



cisco1# write terminal
Building configuration...
: Saved
:
PIX Version 6.3(1)
interface ethernet0 auto
interface ethernet1 auto
interface ethernet2 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 dmz security50
enable password MB43qyYOeHIF8Tgs encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname cisco1
domain-name mydomain.com
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names
name 192.168.10.0 offsite
object-group service web tcp
  port-object eq www
  port-object eq https
access-list inside_outbound_nat0_acl permit ip interface inside 192.168.1.48 255.255.255.240
access-list inside_outbound_nat0_acl permit ip any 192.168.1.48 255.255.255.240
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 offsite 255.255.255.0
access-list outside_cryptomap_dyn_20 permit ip any 192.168.1.48 255.255.255.240
access-list remote_splitTunnelAcl permit ip 192.168.1.0 255.255.255.0 any
access-list outside_cryptomap_20 permit ip 192.168.1.0 255.255.255.0 offsite 255.255.255.0
access-list outside_access_in permit ip any host x.x.x.35
access-list outside_access_in permit tcp any host x.x.x.35
pager lines 24
mtu outside 1500
mtu inside 1500
mtu dmz 1500
ip address outside x.x.x.34 255.255.255.248
ip address inside 192.168.1.2 255.255.255.0
ip address dmz 192.168.9.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpn 192.168.1.50-192.168.1.60
pdm location 192.168.1.5 255.255.255.255 inside
pdm location 192.168.1.48 255.255.255.240 outside
pdm location 192.168.1.40 255.255.255.255 inside
pdm location offsite 255.255.255.0 outside
pdm location 192.168.9.10 255.255.255.255 dmz
pdm location 192.168.9.0 255.255.255.0 inside
pdm location x.x.x.35 255.255.255.255 outside
pdm history enable
arp timeout 14400
global (outside) 10 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 10 0.0.0.0 0.0.0.0 0 0
static (dmz,outside) x.x.x.35 192.168.9.10 netmask 255.255.255.255 0 0
static (inside,dmz) 192.168.1.0 192.168.1.0 netmask 255.255.255.0 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.x.33 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server RADIUS (inside) host 192.168.1.40 QTr3cm# timeout 5
aaa-server LOCAL protocol local
aaa authentication enable console LOCAL
aaa authentication ssh console RADIUS
aaa authorization command LOCAL
http server enable
http 192.168.1.5 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-l2tp
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer y.y.y.170
crypto map outside_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client configuration address initiate
crypto map outside_map client authentication RADIUS
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address y.y.y.170 netmask 255.255.255.255 no-xauth no-config-mode
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup remote address-pool vpn
vpngroup remote dns-server 192.168.1.40
vpngroup remote split-tunnel remote_splitTunnelAcl
vpngroup remote idle-time 1800
vpngroup remote password ********
telnet timeout 5
ssh 192.168.1.5 255.255.255.255 inside
ssh timeout 20
console timeout 0
vpdn username phoward password *********
vpdn enable outside
username user password yXUkmsszAtJ5Hw.g encrypted privilege 15
privilege show level 0 command version
privilege show level 0 command curpriv
privilege show level 3 command pdm
privilege show level 3 command blocks
privilege show level 3 command ssh
privilege configure level 3 command who
privilege show level 3 command isakmp
privilege show level 3 command ipsec
privilege show level 3 command vpdn
privilege show level 3 command local-host
privilege show level 3 command interface
privilege show level 3 command ip
privilege configure level 3 command ping
privilege show level 3 command uauth
privilege configure level 5 mode enable command configure
privilege show level 5 command running-config
privilege show level 5 command privilege
privilege show level 5 command clock
privilege show level 5 command ntp
privilege show level 5 mode configure command logging
privilege show level 5 command fragment
terminal width 80
Cryptochecksum:5245ffcd61265301cbfe0f52ca9f0d13
: end
[OK]
cisco1#
0
Comment
Question by:redav72
  • 5
  • 3
8 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 10734355
Can you post result of "show access-list" and see any (hits) on these two acl lines:
>access-list outside_access_in permit ip any host x.x.x.35
>access-list outside_access_in permit tcp any host x.x.x.35

What is the default gateway of the host 192.168.9.10 ? Can you post result of "C:\route print"

0
 

Author Comment

by:redav72
ID: 10734844
Thanks for the quick reply.

cisco1# show access-list
access-list cached ACL log flows: total 0, denied 0 (deny-flow-max 1024)
            alert-interval 300
access-list inside_outbound_nat0_acl; 3 elements
access-list inside_outbound_nat0_acl line 1 permit ip interface inside 192.168.1.48 255.255.255.240 (hitcnt=0)
access-list inside_outbound_nat0_acl line 2 permit ip any 192.168.1.48 255.255.255.240 (hitcnt=0)
access-list inside_outbound_nat0_acl line 3 permit ip 192.168.1.0 255.255.255.0 offsite 255.255.255.0 (hitcnt=2205444)
access-list outside_cryptomap_dyn_20; 1 elements
access-list outside_cryptomap_dyn_20 line 1 permit ip any 192.168.1.48 255.255.255.240 (hitcnt=0)
access-list remote_splitTunnelAcl; 1 elements
access-list remote_splitTunnelAcl line 1 permit ip 192.168.1.0 255.255.255.0 any (hitcnt=0)
access-list outside_cryptomap_20; 1 elements
access-list outside_cryptomap_20 line 1 permit ip 192.168.1.0 255.255.255.0 offsite 255.255.255.0 (hitcnt=3767)
access-list outside_access_in; 2 elements
access-list outside_access_in line 1 permit ip any host 65.212.4.35 (hitcnt=1062)
access-list outside_access_in line 2 permit tcp any host 65.212.4.35 (hitcnt=0)
cisco1#

And the route table for the server.

C:\Documents and Settings\Administrator.ECM-SVR-DEV01>route print

IPv4 Route Table
===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x10003 ...00 50 04 63 18 48 ...... 3Com EtherLink XL 10/100 PCI TX NIC (3C905B-
TX)
===========================================================================
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0      192.168.9.1     192.168.9.10     20
        127.0.0.0        255.0.0.0        127.0.0.1        127.0.0.1      1
      192.168.9.0    255.255.255.0     192.168.9.10     192.168.9.10     20
     192.168.9.10  255.255.255.255        127.0.0.1        127.0.0.1     20
    192.168.9.255  255.255.255.255     192.168.9.10     192.168.9.10     20
        224.0.0.0        240.0.0.0     192.168.9.10     192.168.9.10     20
  255.255.255.255  255.255.255.255     192.168.9.10     192.168.9.10      1
Default Gateway:       192.168.9.1
===========================================================================
Persistent Routes:
  None
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 10735634
Let's check off all requirements...

Packets are obviously being allowed in to the public IP...
>access-list outside_access_in line 1 permit ip any host 65.212.4.35 (hitcnt=1062)

- Check

Public IP has static xlate to private IP...
>static (dmz,outside) 65.212.4.35 192.168.9.10 netmask 255.255.255.255 0 0
                                 ^^^^^^
- Check

Private IP host has correct gateway:
>PIX:
>ip address dmz 192.168.9.1 255.255.255.0

>Network Destination        Netmask          Gateway       Interface  Metric
                         0.0.0.0          0.0.0.0      192.168.9.1     192.168.9.10     20
                                                                        ^^^^
- Check

Pix has appropriate default gateway out:
>route outside 0.0.0.0 0.0.0.0 x.x.x.33 1

- Check

There are no other access-lists applied to the DMZ interface.
- Check

What service are you trying to use on the inside host? Is that service running?
Can you ping 65.212.4.35 ?
It appears that everything is working OK.

Does this look right?

HTTP/1.1 200 OK
Content-Length: 13
Content-Type: text/html
Content-Location: http://65.212.4.35/default.html
Last-Modified: Tue, 30 Mar 2004 21:12:50 GMT
Accept-Ranges: bytes
ETag: "d0eb24c29b16c41:73f"
Server: Microsoft-IIS/6.0
X-Powered-By: ASP.NET
Date: Thu, 01 Apr 2004 20:41:05 GMT
Connection: close

hello world

Are you trying to get to that web server's public IP from inside the network?



0
 
LVL 79

Expert Comment

by:lrmoore
ID: 10735653
Highly suggest you lock down the access-list:

From this:
access-list outside_access_in permit ip any host x.x.x.35
access-list outside_access_in permit tcp any host x.x.x.35

To this:
access-list outside_access_in permit tcp any host x.x.x.35 eq 80


0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:redav72
ID: 10735752
doh, so its been working all along.  I tried it from an outside host and was able to access it fine, I'll follow your advise and lock down the access list.  Can I specify both 80 and 443 on the same line?  How can I enable access to the outside IP from the inside.

Thanks, Phil Howard
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 140 total points
ID: 10736304

access-list outside_access_in permit tcp any host x.x.x.35 eq 80
access-list outside_access_in permit tcp any host x.x.x.35 eq 443

Can't do it on the same line unless you create a protocol group, then assign access to the group. Two lines is easier...

In order to access the public ip from inside, you'll need to use the alias command, and "sysopt noproxyarp inside"

alias  (dmz) 192.168.9.10 65.x.x.35 netmask 255.255.255.255
sysopt noproxyarp inside
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 10736313
>alias  (dmz)

I think that should be
alias  (inside)
0
 

Author Comment

by:redav72
ID: 10736365
Thanks, that worked, I really appreciate the help

Phil Howard
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

This article is a guide to configure bridging on Cisco Routers.  This is something I never knew was possible until after making a few phone calls to Cisco.  Using bridging saved our company money by not requiring us to purchase a new switch.  Bridgi…
Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now