DHCP Stopped Working

Here's what happened.  I was connected to my home router, working just fine.  I decided to work in another room, and unplugged my laptop from the router to work.  Later, when I went back and connected to the router, I had no connection.  I rebooted several times, and still no connection.  I tried ipconfig /release and then /renew, and the renew wouldn't work.  Other computers connected can still access the internet and the router.  I also tried swaping to a known good network cable from another PC and still had no connection.  I let the laptop sit for a while (about an hour or so), came back, and the connection was up on my laptop.

Now, in the office, I can't aquire an ip through DHCP.  If I manually enter an IP address and network settings, it works just fine.  DHCP seems to be the only thing not working, but unfortunately, I have to use DHCP in the office.  All other users in the office are working just fine for network.

Any ideas?
LVL 3
jjmartinAsked:
Who is Participating?
 
sirbountyConnect With a Mentor Commented:
Try
Start->Run->CMD <enter>
 netsh int ip reset c:\ipreset.txt <enter>
 exit <enter>

http://help.stargate.net/broadband/netsh.shtml

Netsh: http://www.microsoft.com/technet/columns/cableguy/cg1101.asp

and/or to repair Windows Sockets...
Download and run this item:
 http://www.itc.virginia.edu/desktop/central/display/details.php3?installerID=127&nav=title
0
 
jjmartinAuthor Commented:
I forgot to add, this is winxp pro.
0
 
jjmartinAuthor Commented:
I've tried the netsh command with no luck.  I'll have to work on getting the fix program copied to the laptop.
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
sirbountyCommented:
no luck - it didn't work, or it errored?
0
 
jjmartinAuthor Commented:
The netsh command ran with no errors.  The log looks like it fixed some registry errors, but DHCP still isn't working.

I ran the winsock fix program too.  It ran fine... but DHCP still doesn't work.
0
 
sirbountyCommented:
With it set as DHCP - try releasing and then rebooting.
It should renew when it comes back up.

Your MAC address hasn't been blacklisted, has it? :D
0
 
jhenchCommented:
You need to disable IP autoconfiguration. Windows uses 169.254.x.x addresses when you are not connected to a network. Sometimes this can cause issues with dhcp. In the past i have had this problem. To resolve it, i added a registry entry as follows:

open regedit and browse to

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces

in this directory, you will see all the interfaces. select the one that has the ip addresses configured in it. You will need to add a new Dword value:

IPAutoconfiguration (set the value to 0)

reboot and try to obtain an ip address from your dhcp server.
0
 
jjmartinAuthor Commented:
No blacklist.  This is happening on my home router too.

I tried the registry setting, and I can see where it's no longer defaulting to the 169 address, but still no luck aquiring an ip address.
0
 
SunBowCommented:
Try a different port? Try adding a new network connection on PC?
Can you try a hard reboot?
0
 
sirbountyCommented:
If you've tried other ports, cables, etc. - I think you're limited to removing all your network components (protocols, services, adapter).

From your LAN properties - remove MS Client, File and Print service and TCP/IP.
Now click start->run->devmgmt.msc
Find your network adapter and uninstall it

Reboot.

XP should reinstall it.
Now go back to LAN properties and add Client for MS, F&P & Tcp/ip...
0
 
marco_peereboomCommented:
WinXP...

Firewall enabled? Disable it.
QoS status (disable it for test)
Check all other services / protocols running and evaluate whether you need them or not.
0
 
jjmartinAuthor Commented:
I've tried different cables and ports.
xp wonth allow you to uninstall tcp/ip, but I've reset it several times with the netsh command.
Reinstaling the adapter did nothing.

No firewall is running.

On my home network, most of the tme it is finding the router now, but I can't get out to the internet.  It detects the connection, and attempts to download a page, but nothing loads.  When I ping the router, about 1/3 of the packets get lost.

I'm beginning to think the nic card is hosed, which unfortunately, since this is a laptop is integrated into the mb.
0
 
sirbountyCommented:
>> When I ping the router, about 1/3 of the packets get lost.<<
Then I'd be inclined to agree - NIC is bad (or headed that way)...
0
 
marco_peereboomCommented:
And just removing the NIC out of the Device Manager.
If there are more networking components, remove them as well.
That might also be the reason that you couldn't remove TCP/IP, since it's in somehow in use.

You might want to upgrade the BIOS.
Check known issues for the NIC.

If you have a 3COM NIC, make sure the NIC is auto-config in DOS mode.
If your NIC has Boot-PROM, disable it for test in DOS mode.
Do this via the 3c90xcfg util.

But it is sounding a bit like a hardware problem.
0
 
jjmartinAuthor Commented:
A new pcmcia nic card is working just fine.  The integrated card seems to be toast.
0
 
marco_peereboomCommented:
Maybe some NIC diag can tell you if anything is wrong.
0
 
jjmartinAuthor Commented:
diagnostics software for the network card checks everything out OK, but with TCP/IP functioning normaly on a new card, I still am inclined to think this one is bad.
0
 
marco_peereboomCommented:
Hm, you might want to check HalfDuplex speeds on the faulty NIC and see what happens.
I've seen a case like this before, where FD was not functioning.

If this is the case, then I guess it would be the NIC itself.

You might want to check the manufacturer for ideas.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.