Solved

Sending Emails Using Mail Server Which is on a private ip address

Posted on 2004-04-01
4
358 Views
Last Modified: 2010-04-11
I have a network that is using private ip addresses. Network is connected to  CISCO PIX 501 firewall and then to CISCO 2620 router. NAT is configured on firewall. In my internal network i configured a mail server ( MS Exchange 2000). This mail server is on private ip address.I just wanted to "SEND MAILS"  not recieve emails .Throught this server. Is some special configuration needed on Router or Pix firewall to do this..Can any expert help me how can i do this.
0
Comment
Question by:ahmed1234
4 Comments
 
LVL 11

Expert Comment

by:infotrader
ID: 10735320
You'll need to allow port 25 to be opened on the PIX to your workstation.  Alternatively, a better way to do it would be to assign a NAT from a public to private on your LAN private IP address on PIX, and then make sure port 25 is open.
0
 
LVL 11

Accepted Solution

by:
PennGwyn earned 50 total points
ID: 10735506
Assuming the server is on the same private range as your clients, all you need to do is make sure that the PIX allows the server to open outbound connections on port 25 (SMTP).  Since the default config of the PIX is to allow all internals to open outbound to any port, you'd only need to do anything if you have a non-default PIX configuration for outbound traffic.  (For instance, in most cases it's reasonable to allow ONLY the mail server to send SMTP.)

0
 

Expert Comment

by:anujdhingra
ID: 10735542
Ahmed

I have the same network scenerio with Cisco 2620 and PIX 501. What I have done is that I am NATing the Private IP address of mail server at the Firewall to a Public/Static IP address. Then I am having my ISP maintain the DNS record for my mail server. Also I got the MX-Record changed for mail from the company that hosts the domain name.

Now on Firewall, open SMTP and POP3 port. If you want to allow access from outside without the VPN connection, open port for internet access, you can change that port in Exchange server settings. I have set that up as 8080 and that works fine for me.

Thanks
Anuj
0
 
LVL 6

Expert Comment

by:Pascal666
ID: 10739073
Exchange has problems with mailguard.  Enter the command "no fixup protocol smtp 25" on your pix to disable it.

The default behavior for the PIX is to allow all outbound traffic so as long as you have not added any access-lists blocking outbound traffic you should be fine.

-Pascal
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
jump server vs push server 6 98
SCCM And Branchcache Server 1 35
NSD FAIL 2 25
Connecting LAN to a new leased line 2 26
Some time ago I was asked to set up a web portal PC to put at our entrance. When customers arrive, they could see a webpage 'promoting' our company. So I tried to set up a windows 7 PC as a kiosk PC.......... I will spare you all the annoyances I…
Even if you have implemented a Mobile Device Management solution company wide, it is a good idea to make sure you are taking into account all of the major risks to your electronic protected health information (ePHI).
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now