Can no longer play AVI files.

Win 98 SE
Windows Media Player(WMP)
Viplay 2.09

All **WERE*** working fine...
Not sure why, or what caused it, but I now can't play AVI video files, on either WMP or Viplay.

The error is as if I don't have codecs installed.

Tried re-installing using IV5Setup.exe  to no avail...
Tried Divx again to no avail
Only seems to be AVI vids, other formats run fine.
Nothing I seem to do makes any difference.
Any ideas how I rectify this?
Who is Participating?
shamstarConnect With a Mentor Commented:
I wanted to stay away from manually modifying the win.ini and related system files, this is firstly what goes in there is pretty much dependent on the files/drivers you have installed in your PC, so basically its very difficult for me to tell you.  The other, stronger reason was because incorrectly modifying these files could easily leave the OS unbootable!  So its a good idea to stay away from that unless you can afford teh downtime and have made full backups etc.

let me know how you get on with the WMP updates, also - have you given any though to installing Win98 again on top of the current installation (not a full reinstall yet) ?
DaveEEAuthor Commented:
I just ran apples QuickTime Player, which immediately asked for the codec, installed it and played the file perfectly!

WMP and Viplay still won't play them!

Humm... if you're on a Windows system then have you tried using the system restore function to restore to a date before you had this problem?
Never miss a deadline with

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

Oppps... ignore that, you dont have system restore with Win98.
Go into Control Panels, and open the Sounds and Multimedia control panel.  Click on the Devices tab.  You should now be able to see a list of all the codes installed on your computer (should be under Video Compression Codecs).  Verify that the required ones are showing up on there.  If they arer already there, then try removing them first, frestarting, and then reinstalling again.
DaveEEAuthor Commented:
I was sure you had the answer shamstar!
But alas no!
The codecs were there as expected in the list of Video Compression Codecs.
The "Indeo ® video R3.2 by Intel" version was duplicated.
I removed ALL the Indeo codecs
Ran Iv5setup.exe again
Checked it had installed the Indeo codecs
Still the same! No go...

Then I found "indeo ® software" in 'add and remove programs' so I removed that and then repeated the above....
Still the same! No go...

Now I'm wondering if I'm even on the right track?

Amongst various others, there are a load of Sunplus AVI codecs too...

Sunplus 32-bit AVI compression driver [SP53]
Sunplus 32-bit AVI compression driver [SP54]
Sunplus 32-bit AVI compression driver [SP55]
Sunplus 32-bit AVI compression driver [SP56]
Sunplus 32-bit AVI compression driver [SP57]
Sunplus 32-bit AVI compression driver [SP58]
Sunplus 32-bit AVI compression driver [SP59]

Could it be these or something to do with them that's causing the problem?
I don't think it is, because if I look at the video properties in QuickTime I can see one of the ones that won't play is "Indeo ® video 5.1" Which is one of the codecs installed by Iv5setup.exe

However, when I look at an other AVI files (again with quicktime) I can see all sorts of different AVI formats, all of which work in quicktime, and NONE in WMP or viplay.

I'm now playing with 'file type' settings as I'm wondering if that has something to do with it?

Do you get any errors in any of the players, can you tell me what those errors are?  In specific I'd like to work with the Windows Media Player since its something I already have so makes it easier to help with.  Have you tried downloading any updates for the player?

Also, can you think of anything that you've changed since between the time when thigns were working fine and when you started having these problems?  Things to think about would be updating the OS, changing your video card drivers, other hardware or software changes.

Also, in WMP, does the file simply not load, or does it play with just sound but no video?

You can download new/old versions of WMP + codecs from this MS page:

Let me know your comments on the above first before you try whats below.

As a last option, you could try reinstalling Win98 ontop of the current installation, this can help to fix some system related problems which might be preventing playback.  Installing ontop of the current installation will keep all your programs+documents so you might want to try it first before doing a complete reinstall (if that becomes necessary).
Should just mention, that if you go to the link page above, then you should also try downloading and installing the appropriate version of Windows Media Encoder.  To see those download, choose "Windows Media Encoder" from the "Select Downloads" drop down box.
DaveEEAuthor Commented:
OK, firstly to answer some questions B4 I do anything else.
Apart from QuickTime player, ANY other 'PC' (rather than apple) video playing program will NOT play AVI files. They all phrase the error differently, but it ammounts to the same thing. "No codec for AVI"
The specific error message from WMP is: "Windows Media Player cannot play the file. The file is either corrupt or the Player does not support the format you are trying to play."

I know the file is fine, because QuickTIme (once it had downloaded & installed it's OWN copy of Indeo ® video 5.1, runs it perfectly.

WMP does nothing with the file apart from show the above error message.

Viplay, attempting to play the same file says: "The file format is invalid, unsupported, or you don't have all the necessary filters"

Like I say it isn't only 'Indeo' codecs, the overriding thing seems to be if it's any type of AVI then I can't play it. I can happily play MPG and other video types, but NOT AVI files. The all generate the same error.

If you click on "More information" in WMP it tells me the error is:
"0xC00D1199: Cannot play the file
Windows Media Player cannot play the file. You may encounter this error message for one of the following reasons:

The file type is not supported by the Player. The following table lists the file types supported by the Player. If the file type you are trying to play is included in this table, then the file may have been encoded by using a codec that is not supported by Windows Media Player. If this is the case, Windows Media Player cannot play the file.
The file type is supported by the Player, but the file was compressed by using a codec that is not supported by the Player.
The file type is supported, but you are trying to play it in a way that is not supported by the Player. For example, you may have attempted to drag a DVD file with a .vob extension from a DVD to the Windows Media Player icon. Or you may have attempted to open a .vob file by clicking Open on the File menu.
You are trying to play one part of a multipart file. Use a newsreader or other program to combine the files, and then try again.
The following table lists the file types (formats) supported by Windows Media Player."

Again I know the file is OK as QuickTime plays it and all my other AVI's which I used to be able to play with WMP.

There has been quite a long gap between me playing AVI's, and during that gap I've probably done all sorts of updating and upgrading. There's no way I could trace back to where the problem started.

What about all the 'VIDC' entries under 'drivers32' in the win.ini?
How crucial are they, as I don't know if all that are supposed to be there are there?

In the mean time I'll try the WMP update you mention shamstar

DaveEEAuthor Commented:
OK, Problem solved...
I decided to try a different tack, namely approaching the Viplay people and telling them I can't play AVI's.

They told me to remove a filter in the viplay filters directory called
and to re-register quartz.dll
regsvr32.exe c:\windows\system\quartz.dll

After doing this, all players (Including WMP) now play AVI's again!

I'll award points to you though shamstar as a thank you for your time and effort.

DaveEEAuthor Commented:
Unfortunately EE forces me to accept an answer even though the true answer wasn't provided here...

But thanks again shamstar.

No problem, and thanks for the points, atleast you're able to watch movies in the player of your choice again!
Install K-lite - is a time proved Media player and CodecsPack

*** advertising removed by Netminder, Site Admin ***
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.