Solved

Unable to obtain an internet connection in Mandrake Linux 10.0,

Posted on 2004-04-01
30
1,658 Views
Last Modified: 2013-12-06
I just installed Mandrake 10.0 and am trying to get it connected to the internet.  I am a total Linux Noob!  I have had some help with someone who knows linux well but we're unable to find a solution.  I have a Linksys LNE100TX 5.1 NIC and a Linksys BEFSX41 Firewall router.  I have COX cable and am setup for DHCP in Windows.  I opened a terminal and typed "su", put in my root password, then put in "/etc/init.d/network restart"  These are the results:

Shutting down loopback interface:       OK
Setting network parameters:              OK
Bringing up loopback interface:           OK
Bringing up interface eth0:                 FAILED

I was also told to type "/sbin/ifconfig" in the terminal and get the following on the second line:

inet addr: 127.0.0.1  Mask 255.0.0.0

I was told to try a different NIC, so i shutdown, took out the Linksys NIC, when into the BIOS and enabled my onboard realtek NIC.  Same problem.  I tried connecting it without the router, same problem.  Any Ideas?  Remember your talking to a Windows Geek...Linux Noob, please keep that in mind!

Thanks!
0
Comment
Question by:unassassinable
  • 10
  • 9
  • 5
  • +3
30 Comments
 
LVL 9

Expert Comment

by:majorwoo
ID: 10737554
under windows your DHCP works and you get online right?

When setting up your linux, did you select dhcp for the network?

You should be able to setup your eth0 (to use DHCP) from Mandrake Control Center -> Network & Internet -> DrakConnect
Configure the local area network (eth0) to use DHCP.

The other option is your network card was not recognized/no drivers, what does typing dmesg in a shell say about your network  card?
0
 
LVL 9

Expert Comment

by:majorwoo
ID: 10737557
0
 
LVL 9

Author Comment

by:unassassinable
ID: 10738088
under windows your DHCP works and you get online right? - Yes

When setting up your linux, did you select dhcp for the network? - In KDE i goto System > Configuration > Configure your computer > put in my root password > Network and Internet > Setup new conection...I put a bullet it Cable Connection, put a bullet in eth0: ADMtek|ADM983 linksys Etherfast 10/100 (my linksys card), put a bullet in Automatic IP (DHCP), leave check marks in 1) Assign host name from DHCP Adress 2) Network Hotplugging 3) Start on Boot.  In the "DHCP Host Name" COX cable told me that I should put 172.19.73.34, the next screen in the Host name field I put my Router IP address (192.168.1.1), I have no idea what a zeroconf Host name is so I just put "rich" (please tell me thats my only problem!!), then put a bullet in Start connection on boot, and then restarted the network.  Then it sais "congragulations, blah blah blah...  Nothing.


The other option is your network card was not recognized/no drivers, what does typing dmesg in a shell say about your network  card? It displays about 200 lines of stuff i dont understand. I look down about 3/4'ths the way and found a line that looks like:

eth0: ADMtek comet rev 17 at 0xd000, 00:0c41:2:37:5e, IRQ 19

Thats all i could find.
0
 
LVL 8

Expert Comment

by:da99rmd
ID: 10739090
>eth0: ADMtek comet rev 17 at 0xd000, 00:0c41:2:37:5e, IRQ 19
then is have been found, check in the file /etc/modules and check the alias for your eth0:
alias eth0 eepro100
this says like this for me:
and then do a "lsmod" and se if you find your module name for me it the eepro100.
For me the line looks like this:
eepro100               17664   1

If its there then you have the driver for the NIC.

Try to start the NIC, with out the dhcp stuff to se that it works:
ifconfig eth0 192.168.0.1 netmask 255.255.255.0 up
and then try doing a ping:
ping 192.168.0.1 if that works you are safe.

check to se if you have the program "dump" ?
if so use the command
pump -i eth0 -h hostname

/Rob
0
 
LVL 9

Expert Comment

by:majorwoo
ID: 10741452
if you have a router (linksys, dlink, or otherwise home version) you should just set everythign to DHCP and specify nothing.  (forget what COX todl you).  Your rotuer will do all that for you and giv you the settings you need via DHCP.
0
 
LVL 9

Author Comment

by:unassassinable
ID: 10746594
Rob:

I looked in the file /etc/modules and this is exactly as i see it:

#/etc/modules: kernal modules to load at boot time.
#
#This file should contain the names of kernal modules that are
#to be loaded at boot time one per line.  Comments begine with
#a '#' and everthing on the line after them are ignored.

scsi_host adaptor

It's funny though, I do not have any scsi devises.  

I tried typing in 'lsmod' in a terminal but got 'comand not found'.  Where do I do lsmod?  Remember im totaly linux retarded.

I also tried earlier without DHCP with no success.  I do not have dump, I did a search for packages that can be installed and found a 'tcpdump'?  I installed it but do not know where it installed to.  Any other ideas?
0
 
LVL 8

Expert Comment

by:da99rmd
ID: 10755382
ksmod is a program for listing loaded modules and you will need a loaded module for you internet card.

then you probobly dont have the right module or no module installed, then you have to check what NIC you have and go to the NIC homepage and se if they have any drivers for your NIC. Or what module to use for that nic if it is ne2000 complaiant Then check back to gicve the info and i will help you install de module.

/Rob
0
 
LVL 20

Expert Comment

by:Gns
ID: 10760350
Erhm, since this is Mandrake 10, probably with a nice 2.6.3 kernel... You shouldn't look at /etc/modules.conf (which is for the 2.4 kernel (or earlier:-)... You should look at /etc/modprobe.conf instead... I'm guessing, but I think your card has a tulip chip...
If you have the linksys firewall thing between you and the cable modem, then you're really on a LAN where the FW thing actually provide the DHCP... Rerun drakconnect  and try set it as a LAN/DHCP instead...
Could also be a missnegotiation between the card and the fw thing... Do you have any LEDs indicating link speed/duplex on both of them?

-- Glenn
0
 
LVL 9

Author Comment

by:unassassinable
ID: 10762760
****Rob****:

i went to the linux network support page at linksys (http://www.linksys.com/support/support.asp?spid=25#nmodules) and there are 2 links about half way down that page.  One is for downloading the latest tulip.c driver, i click on it and get a page full of code but dont know what to do with it. (ftp://ftp.scyld.com/pub/network/tulip.c)


****Glenn****:

I looked in /etc/modprobe.conf and this is what i see:

alias eth0 tulip
alias sound-slot-0 snd-cmipci
install scsi_hostadapter /sbin/modprobe imm; /sbin/modprobe ppa; /bin/true
install snd-cmipci /sbin/modprobe --first-time --ignore-install snd-cmipci && {
/sbin/modprobe snd-pcm-oss; /bin/true; }
insttall usb-interface /sbin/modprobe usb-uhci; sbin/modprobe ehci-hcd; /bin/true
remove snd-cmipci { /sbin/modprobe -r snd-pcm-oss; } sbin/modprobe -r --first-time
--ignore-remove snd-cmipci

I tried setting it to LAN/DHCP, still no connection.  

The LED's on both NIC and router/FW are all blinking as they should be
0
 
LVL 8

Expert Comment

by:da99rmd
ID: 10763708
Then you are safe when you have the line
alias eth0 tulip
try this one
ifconfig eth0 192.168.0.1 netmask 255.255.255.0
then make a ifconfig to se that the inteface is up then try doing a
ping 192.168.0.1
and se if it works.

/Rob
0
 
LVL 20

Expert Comment

by:Gns
ID: 10763750
Eh, "blinking as they should be" indicates traffic monitoring... I was more interrested in if they indicated speed/duplex, so that you could make sure that theres no strangeness between them on account of that.

As suspected, your card is a tulip, and you already have a driver set up to load when you bring up your interface.
Hm. Could you perhaps quote some lines from your dmesg output from the line about the eth0/tulip and ... oh perhaps 10/20 lines on from that (or EOF, whichever is first:-)? Just to make sure this isn't reporting some error.

Could you quote the files /etc/sysconfig/network and /etc/sysconfig/network-scripts/ifcfg-eth0 here? The tools mostly just set these up, and since they're plain text ... we might as well look at/change them directly;-).

On a side note: You wondered about scsi_hostadapter? Well, since you can attach "storage type devices" to most any bus nowadays, linux mostly "insert a scsi emulation layer" between them and the "storage type device consumers"... Pretty much like any OS does (even windoze NT and upwards:-). So here is a construct to try load this type of thing... For example ppa is parallell port etc.

-- Glenn
0
 
LVL 9

Author Comment

by:unassassinable
ID: 10795736
***Rob***

Sorry, doesnt work either.

***Glen***

I dont have any light labeled speed or duplex on the NIC, Router, or Modem.  

/etc/sysconfig/network displays the following:
HOSTNAME = 192.168.0.1


On a side note, I have increased the points by 240 (its all I have left!)
0
 
LVL 9

Author Comment

by:unassassinable
ID: 10795762
sorry, accedently hit submit before finneshing the last note...

HOSTNAME = 192.168.0.1
NETWORKING  = YES
GATWAY = 68.106.0.1

/etc/sysconfig/network-scripts/ifconfig-eth0 displays:

DEVICE=eth0
BOOTPROTO=dhcp
NETMASK=255.255.255.0
NETWORK=68.106.1.0
BROADCAST=68.106.1.255
ONBOOT=yes
MII_NOT_SUPPORTED=no
DHCP_HOSTNAME=192.168.0.1
NEEDHOSTNAME=yes

I FTP'd 3 images of dmesg to my website.  you can see them here.  I tryed to make them as clear as possible in photoshop.

www.artistic-nature.com/~ihatekansas/1.gif
www.artistic-nature.com/~ihatekansas/2.gif
www.artistic-nature.com/~ihatekansas/3.gif
0
 
LVL 9

Author Comment

by:unassassinable
ID: 10797513
Just going back to the original post...Doesnt the "inet addr: 127.0.0.1  Mask 255.0.0.0" in ifconfig and "Bringing up interface eth0:               FAILED"  mean there is something wrong with the NIC or the Computer reading the NIC?
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 20

Expert Comment

by:Gns
ID: 10801560
127.0.0.1 is the address for the lo (loopback "dummy") interface. Has nothing to do with eth0.
And don't fiddle with it... You need the loopback;-).

Your config files for eth0 looks a trifle strange though, so I'll do some tests and get back to you with something hopefully a bit more sane... As it is, I'd suspect that you're supposed to have the "address name" identify it to the DHCP server in some mysterious way... One usually handle this type of thing (if one actually needs something like this) via MACs, but that would perhaps be even more stupid... Oh well.
I'll get back to you.

-- Glenn
0
 
LVL 20

Expert Comment

by:Gns
ID: 10812203
Ok, you should be able to remove the NETMASK, NETWORK and BROADCAST lines from the ifcfg-eth0 file... And possibly the CDHCP_HOSTNAME and NEEDHOSTNAME too... And you strictly don''t need the GATEWAY entry in the network file either (if the DHCP clinet does what it should:-). Still a bit strange to have a dotted quad for hostname. I can well imagine a lot of situations where that'd lead to gross problems ... Provided it "survives" the DHCP negotiations. You can well try to set it to something else (mycomp.wherever.nu:-) and try bringing the interface up...
Try first with
ifup eth0
*before* editing the files, then try it again (you'll need do an "ifdown eth0" if it actually succeeds in bringing the interface up... Check state with "ifconfig eth0") after making the changes (.. and ... interfoliate... as needed:-).

Looking at your pics there, nothing seems strange with the NIC detection/module loading... Which puts us back to this either being a missdetect of speed/duplex (or other "wire-related" cause) or a missconfig. The above should give some answers to the last, and perhaps some indications of the first.

-- Glenn
0
 
LVL 9

Author Comment

by:unassassinable
ID: 10837130
***Glenn***

I just want to make sure Im doing the right thing that you suggested be fore I try anything.  You suggest I open the /etc/sysconfig/network-scripts/ifcfg-eth0 (i open it in konquerer) and remove the NETMASK, NETWORK, BROADCAST, CDHCP_HOSTNAME, AND NEEDHOSTNAME lines (the whole lines or just the stuff after the = sign?)

As for the dotted quad for the hostname, when i setup a new connection, in the screen that asks for a host name it sais i can use the address for the gateway (router).  Well, in Wondows 2000 the address to access my router is 192.168.1.1, I had 192.168.0.1 in there as I was trying what Rob suggested earlier.

I am unsure what you are saying about the "try first with ifup eth0 *before* editing the files, then try it again (you'll need do an "ifdown eth0" if it actually succeeds in bringing the interface up... Check state with "ifconfig eth0") after making the changes (.. and ... interfoliate... as needed:-)."   Could you please explain this process?  

Were gettin closer to this!  dont back out on me now!!  :)

BTW...added 30 points to the question...now at 415 points

Rich Out......
0
 
LVL 8

Expert Comment

by:da99rmd
ID: 10840068
Just write the following in the console before editing the files
ifup eth0
if this works you can check the state of the interface with  
ifconfig eth0

if the interface got no ip then do a
ifdown eth0
and then edit the files and do
ifup eth0
if this works you can check the state of the interface with  
ifconfig eth0

/Rob
0
 
LVL 20

Expert Comment

by:Gns
ID: 10840179
> I just want to make sure Im doing the right thing that you suggested be fore I try anything.  You suggest I open the /etc/sysconfig/network-scripts/ifcfg-eth0 (i open
> it in konquerer) and remove the NETMASK, NETWORK, BROADCAST, CDHCP_HOSTNAME, AND NEEDHOSTNAME lines (the whole lines or just the stuff after the =
> sign?)
Prudent. That is good:-).
Before editing, you can make a copy of the file, so if the edit goes ... badly... you can easily revert to a "known state":).
I presume you use the default action of konqueror-as-filemanager which will lead to some form of texteditor to be run on it (kwrite perhaps). This is very OK... After all, this is just a textfile;)... But you will need run as root to be able to actually edit the file, so perhaps we'll use a slightly different method... Look below.
I also see you meticulously copy my typos (CDHCP_HOSTNAME should be DHCP_HOSTNAME:-)... You needn't do that;-):-).
I realised almost as soon as I'd posted the above that it was a bit... obtuse:-\ ... I'll try be more, eh, decipherable:

Start a konsole or xterm, and in this become root by doing
su
<enter roots password>
Now as root start by checking the state of eth0 with
ifconfig eth0
This should give a few lines of information... State of the interface, MAC address etc and if it has been able to obtain an IP address this will shoe too. Here's an example:
# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:02:A5:17:F0:01
          inet addr:172.18.3.80  Bcast:172.18.255.255  Mask:255.255.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:23154435 errors:0 dropped:0 overruns:0 frame:192
          TX packets:1881126 errors:0 dropped:0 overruns:0 carrier:0
          collisions:181147 txqueuelen:100
          RX bytes:751286559 (716.4 Mb)  TX bytes:193315019 (184.3 Mb)
          Interrupt:20
You likely don't have the inet addr, nor the UP state. Now try the exact same command as is run during boot:
ifup eth0
this will likely fail, and this time you might actually see some "cause" indicated in the error messages (if we're lucky:-). If it doesn't work, you should now edit the file, so run
kwrite /etc/sysconfig/network-scripts/ifcfg-eth0&
which should bring up the GUI editor kwrite on it (the "&" will place it in the background so that you can continue to issue commands in the terminal).
Start by removing the "crud lines" that are meaningless in a DHCP config: NETMASK, NETWORK and BROADCAST
save the file and rerun "ifup eth0"... And difference? check with "ifconfig eth0"...
Now, The default gateway specified in /etc/sysconfig/network seems to be plain wrong too, and a sane DHCP setup _should_ set the default gateway, so you might want to edit that to read
GATEWAY=
instead... and try bring the interface up etc etc.
And also do try with a "non-IP" hostname ... That is just plain strange.

If you actually manage to bring the interface up, but still unable to communicate outside the box, then you need bring the interface down before editing any of the files ... and bringing the interface up again.

As said, lets try do this in "increments", so that you don't change to many variables in each edit/test iteration.
Clearer now?

-- Glenn
0
 
LVL 20

Expert Comment

by:Gns
ID: 10840209
... And (obviously:) neither Rob nor are even close to giving up yet... Hang in there Rich, we'll get there... eventually:-).

-- Glenn
0
 
LVL 9

Author Comment

by:unassassinable
ID: 10908415
Hey guys...been outa town now for a week.  

ok...I started by runing ifconfig eth0 in konsole and you were right, i didnt have an inet addr or the UP state.  It also did fail. this is what I got as far as an error:

detecting IP configuration for eth0...SIOCSIFFLAGS:function not implemented
SIOCSIFFLAGS: function not implemented
failed

I removed the crud lines from /etc/sysconfig/network-scripts/ifcfg-eth0& and now looks like:

HOSTNAME=mypc.myhome.myroom.com
NETWORKING=yes

I saved the file, reran ifup eth0, no difference.  

Added 45 points to the question.
Thanks again Rob and Glenn

Rich Out......
0
 
LVL 20

Expert Comment

by:Gns
ID: 10916431
Eh, hopefully that is how /etc/sysconfig/network looks;-).
/etc/sysconfig/network-scripts/ifcfg-eth0 might look something like
DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes
MII_NOT_SUPPORTED=no

... At least for starters:-).

-- Glenn
0
 
LVL 9

Author Comment

by:unassassinable
ID: 10953763
***Glenn***

.../ifcfg-eth0 looks like what you have with 3 additional lines:

IPADDR=68.106.1.21
DHCP_HOSTNAME=192.168.0.1
NEEDHOSTNAME=yes

-Rich Out......
0
 
LVL 20

Accepted Solution

by:
Gns earned 485 total points
ID: 10956808
Ok, then remove at least the two first of those.

-- Glenn
0
 
LVL 9

Author Comment

by:unassassinable
ID: 10982326
I removed the IPADDR and DHCP_HOSTNAME lines, anything else we can do?
0
 
LVL 8

Expert Comment

by:da99rmd
ID: 10984246
Have you done a restart of the network afterwards ?

IF none of this works you have to do as i do check out what ip some one else got and then just take a ip and insert it staticaly like this:
DEVICE=eth0
BOOTPROTO=static
IPADDR=(some ip that you usaly get with dhcp maybe try puting in an win comp and getting the ip worked for me)
BROADCAST=
NETMASK=255.255.255.0
ONBOOT=yes

It can be so that you had another compter here before and the switch/router or DHCP are chashing MAC adresses for some time, and that why it doesnt work to get a an ip.

/Rob
0
 
LVL 20

Assisted Solution

by:Gns
Gns earned 485 total points
ID: 10984516
Oh, this _can_ work... But be carefull... The "DHCP server" will not know that you've ... stolen ... the address and so might give it to some other equipment on the segment. So keeping an eye on NIC statistics is prudent in that case, or using arpwatch (or similar tool) to detect any duplicate addresses. You'll also need look at what a working dhcp client gets for GATEWAY (default route) and DNS servers.
Try skipping the NEEDHOSTNAME too, for the dhcp case.

Does cox have any info on how they percieve things on the net?

-- Glenn
0
 

Expert Comment

by:StikGawd
ID: 11062567
May work, May not... In some areas cox requires the -h... if this is the case, try running dhcpcd -h cx**** eth0.
Found with older cox modems it doesn't authenticate with the mac adress... maybe I'm way off base here but it worked
for me. :D
0
 
LVL 4

Expert Comment

by:ngopu
ID: 15680443
No comment has been added to this question in more than 21 days, so it is now classified as abandoned..
I will leave the following recommendation for this question in the Cleanup topic area:
Accept GNS's comment as answer

Any objections should be posted here in the next 4 days. After that time, the question will be closed.

Gopu N
EE Cleanup Volunteer
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Join & Write a Comment

In my business, I use the LTS (Long Term Support) versions of Linux. My workstations do real work, and so I rarely have the patience to deal with silly problems caused by an upgraded kernel that had experimental software on it to begin with from a r…
The purpose of this article is to fix the unknown display problem in Linux Mint operating system. After installing the OS if you see Display monitor is not recognized then we can install "MESA" utilities to fix this problem or we can install additio…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now