Solved

How do I REMOVE the IE restrictions put in place by IEAK

Posted on 2004-04-01
9
2,017 Views
Last Modified: 2013-12-28
We have a version of IE that is distributed to customer agents on their workstations. It includes many restrictions such as the inability to download files and the inability to quit (you have to use the Task Manager). I don't know much about IEAK but I know that's what was used. It was a long time ago.

I have inherited a Windows NT PDC on which some fool installed the restricted version of IE. I want to get rid of it but I don't know how. I tried to upgrade to IE 6 (from IE 5) but restrictions stayed in place.

I have looked everywhere for answers, asked the question on various forums, to no avail. How do I restore normal functionality? PLEASE don;t let this be another place where my question sits unanswered!

Thanks,

Mike
0
Comment
Question by:mikebernhardt
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 
LVL 5

Expert Comment

by:visioneer
ID: 10738253
All those changes will be in the registry in various places, depending on the changes made.  There's no one "undo" that I can point you to.  For each restriction, you'll have to find the corresponding registry key where that is set.

Most of them will probably be found in the branch HKLM\Software\Microsoft\Internet Explorer
0
 
LVL 28

Author Comment

by:mikebernhardt
ID: 10742592
Yesterday I went through an unaltered machine with Regedit and compared every key I could find in the HKLM\Software\Microsoft\Internet Explorer tree- and every other IE tree also. I found a few discrepancies, but altering them didn't alter the 3 remaining restrictions: I can't exit the application without using Task Manager; I can't use Windows Update; I can't download files. In all three cases I get an alert that I can't do it due to restrictions in place on the workstation. In the case of Windows Update, it complains after a certain point in the interaction, while it's trying to customize the patch list (it's badly out of date on the security patches).

I could easily have missed something in my search yesterday. If someone could tell me what specific keys cause these specific restrictions, and what to do with them, I will be in good shape.

If I just delete ALL IE keys and reinstall IE will that fix it or will I be committing suicide? Are we certain that these restrictions are even created by keys in the IE trees or do they reside elsewhere?
0
 
LVL 11

Expert Comment

by:nazirahmed
ID: 10743504
Hi Mikebernharbt...
i think if you use Policy Editor (PolEdit.exe) to opent the local registery it will be much easier for your find the settings and change them. go though the different options for Local Machine and Local user as well and see where you can make changes.
cheers
0
MS Dynamics Made Instantly Simpler

Make Your Microsoft Dynamics Investment Count  & Drastically Decrease Training Time by Providing Intuitive Step-By-Step WalkThru Tutorials.

 
LVL 28

Author Comment

by:mikebernhardt
ID: 10744643
Thanks. But nothing in the policy editor helped with this issue. I opened the registry and also the default user policy. The restrictions I've described are specific to IE, no other apps.

I can't get into IE's Tools/ Internet Options because the restriction won't let me. Maybe the file download and windows update restrictions are in there, but I can't get in to find out.
0
 
LVL 11

Expert Comment

by:nazirahmed
ID: 10745158
if you have the permissions, download IEAK and see if you can undo any settings
http://www.microsoft.com/windows/ieak/downloads/ieak6/ieak6sp1.asp
0
 
LVL 28

Author Comment

by:mikebernhardt
ID: 10745190
IEAK is installed. But I don't know how to use it to undo what's been done. The original build files are nowhere to be found.
0
 
LVL 11

Expert Comment

by:nazirahmed
ID: 10745208
ok search for *.ins files, if can find it then open the IEAK Profile manage and goto file open, it will open the profile, you can amend it then.
0
 
LVL 85

Accepted Solution

by:
oBdA earned 130 total points
ID: 10753170
The places to look for the current restrictions might be under HKCU and HKLM; look in Software\Policies\Microsoft\Internet Explorer and Software\Microsoft\Windows\CurrentVersion\Policies\Explorer.
To make that work using poledit, look for the following templates: axaa.adm, conf.adm, inetcorp.adm, inetres.adm, inetset.adm, oe.adm, sp1shell.adm, subs.adm, wmp.adm; they should be in %systemroot%\inf; if not, they might be in the IEAK installation folder under policies. Then start poledit, first go to Options--Policy Templates, add those files. Then choose "Open registry" from the menu and check for restrictions.
Note: Even if you reset the restrictions using regedit or poledit, they will still apply to new users. To get rid of them, you'll have to create a new installation with no restrictions using the IEAK and install it over the current one.
0
 
LVL 28

Author Comment

by:mikebernhardt
ID: 10768424
In the referenced registry locations, I just deleted the entire "Retrictions" folders. This enabled me to download files, quite normally, etc. oBdA is correct that logging in as a different user leaves me with all the same restrictions as before.

But now I can work with IEAK to create a new unrestricted version of Explorer that I can install on top of the old one, and use the existing IE in the meantime.
0

Featured Post

Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article shows how to use a free utility called 'Parkdale' to easily test the performance and benchmark any Hard Drive(s) installed in your computer. We also look at RAM Disks and their speed comparisons.
Compliance and data security require steps be taken to prevent unauthorized users from copying data.  Here's one method to prevent data theft via USB drives (and writable optical media).
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

628 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question