Solved

glib- configure error

Posted on 2004-04-01
5
397 Views
Last Modified: 2010-04-22
I have installed the  pkgconfig-0.14.0 & glib-2.2.1
& after that iam tryin to configure for the install of atk-1.2.0
                 ( Im using 'linux 2.4.7-10' which was shipped with  RH7.2 ---im using that old kernel coz i've written my total code in that & i have no time to port my LKM's to later versions.so plz dont ask me to change to the later kernels. )

but it gives me this error...

~~~~~~~~~~~~~~

Checking for GLIB - version >= 2.0.0...no
*** Could not run GLIB test program, but did not run. This usually means
*** that the run-time linker is not finding GLIB or finding the worng
*** version of GLIB. If it is not finding GLIB, you'll need to set your
*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
*** to the installed location. Also, make sure you have run ldconfig if that
*** is requited on your system
*** If you have an old version installed, it is best to remove it, although
*** you may also be able to get things to work by modifying LD_LIBRARY_PATH
configure:error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/.

...........

i tried to
$setenv LD_LIBRARY_PATH "/usr/local/"
but it says :
bash : setenv command not found.

i need to install pango & gtk+ after atk lib's... once this works for atk i guess it wud 4 all the other lib's given above. coz all of them give the same configuration error.

am not sure as to how to proceed & wat to do...
im in lot of hurry, plz help.

thx
suman.
0
Comment
Question by:suman18
5 Comments
 
LVL 8

Expert Comment

by:da99rmd
ID: 10739616
To set an env variable in bash use the command
export LD_LIBRARY_PATH=/usr/local
if its located there

/Rob
0
 
LVL 9

Accepted Solution

by:
Alf666 earned 50 total points
ID: 10743597
There's a big chance that you have not installed the glib-devel package.

It looks like your package's pre-install script is checking for glib's version. To do that, it needs glib-config, and this is usually in the devel package.
0
 
LVL 44

Expert Comment

by:Karl Heinz Kremer
ID: 10745349
Alf666 is very likely right. Also, be prepared for more of these errors once you've installed glib-devel. You are probably missing more of the devel packages. The good news is that you only have to go through this once, the next time all the packages will already be installed :-)
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Have you ever been frustrated by having to click seven times in order to retrieve a small bit of information from the web, always the same seven clicks, scrolling down and down until you reach your target? When you know the benefits of the command l…
The purpose of this article is to demonstrate how we can upgrade Python from version 2.7.6 to Python 2.7.10 on the Linux Mint operating system. I am using an Oracle Virtual Box where I have installed Linux Mint operating system version 17.2. Once yo…
Video by: Mark
This lesson goes over how to construct ordered and unordered lists and how to create hyperlinks.
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now