Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 305
  • Last Modified:

How to go external with my Apache Webserver ?

Hi,

I've made a Apache webserver at my workstation Mandrake 10...
Internal, everything works perfect...
But how can i go external, that you also can see my webpage...?
I've a Winxp selfmade Router...
How must i forward that IP of the router to my linux-workstation ?
Or port 80..?

My router has IP : (extern)80.34.12.123 & (intern)192.168.1.1
My linuxstation : (intern) 192.168.1.2
If I typ 192.168.1.2 at my router, it works perfectly. I see my webpage..
If I typ that external IP, it does nothing...

Sorry for my bad english but i hope you'll understand what my problem is.
0
koenvdl
Asked:
koenvdl
  • 2
2 Solutions
 
jar3817Commented:
on the router you need to forward port 80 (or whatever port your webserver is running on) to the ip of the linux machine 192.168.1.2.  I've never played with a windows xp nat machine so I'm not sure where exactly you do that, but I would guess probably in the Routing and Remote Access service configuration under Administrative tools (in the control panel).  You can probably right click on the NAT object and hit properties.  (Just a guess)

Hope this points you in a closer direction.
0
 
roeleboelCommented:
If you're using the 'internet connection sharing' on your xp-router, do this:
* go to the properties page of the network-card connected to the internet
* select the 'advanced' tab
* click on the 'settings' button
* if you want forwarding from port 80 external to port 80 internal, enable the 'web server' tickbox & fill in the ip address of your apache server
* if you want to customize your ports, add a new service & fill in the details required
(this is for windows xp pro, I don't know if this will also work on a home edition)

If you're not using the 'internet connection sharing', could you tell us what software you're using for routing?

Good luck!
0
 
koenvdlAuthor Commented:
I'm using the xp professional , but it isn't working...
I added that service, filled in my port 80, and my internal IP of my linuxstation.
reboot my system...,...

But when i'm typing in my external ip, he said DNSerror... Nothing found.
0
 
koenvdlAuthor Commented:
i've found it with an external program TCPTunnel...
It works fine now.
Thnkx
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now