• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 358
  • Last Modified:

Setting up instant messaging on Exchange 2000


I have Exchange 2000 set up on my PDC.  I installed instant messaging server on another domain controller but not the PDC.  I set up an instant messaging virtual server and set up a _rvp entry in DNS under my domains forward lookup zone.  

I followed the instructions on this page here:

http://support.microsoft.com/default.aspx?scid=kb;en-us;q266643

My problem is that when I configure msn messanger 5 to connect using my exchange account, I try to sign in and it says failed becasue the sign on name does not exist or password is incorect.  

Any ideas?
 
0
The_Master_Chief
Asked:
The_Master_Chief
  • 8
  • 8
  • 5
  • +1
1 Solution
 
Netman66Commented:
Hi The_Master_Chief,

Did you enable your account for IM in AD?  This is an Exchange tab entry on your account.

Regards,

Netman66, MCSE, MCT
Microsoft MVP Team
0
 
The_Master_ChiefAuthor Commented:
Yes.  I enabled 2 accounts for testing purposes.

0
 
The_Master_ChiefAuthor Commented:
Well I have read  a few articles on how to set it up but they all give examples and instructions on how to set it up on the machine that is running exchange 2000.  I installed it on another domain controller but not  the exchange server.  The server that I installed it on already had IIS installed and running.  

I have removed all of the instant messaging stuff and am going to start from scratch.

If you wannt to walk me through what I need to do to set it up this way that would be appreciated.
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
sunray_2003Commented:
Fatal_Exception,


Good evening to you too.

0
 
sunray_2003Commented:
OMG .. sorry guys wrong thread.. mouse is working crazy here
0
 
The_Master_ChiefAuthor Commented:
No problem...
0
 
Fatal_ExceptionCommented:
But you know I am watching..!!   :)
0
 
Netman66Commented:
<grin>

You two....make me laugh.

Well, to tell you the truth, I haven't done it myself.  We have it locked down at work so I haven't had the opportunity to spool it up.

I imagine it needs to run on the Exchange box itself to be able to properly hook into the services it needs - but, I could be wrong.

You know, once I thought I was wrong....but I was mistaken..... :o)
0
 
Fatal_ExceptionCommented:
Now you are making me laugh..  I too, do not allow IM on my network, and that is why I am really just watching to see what happens...  I did read the docs, and it does not look too hard to install..  guess I will just have to try it now..  hmmm
0
 
Netman66Commented:
Well, according to my Exchange Admin book, the IM client uses NTLM to authenticate so it cannot pass a proxy server.  What this tells me is that you need to provide an exclusion in IE for the IM server.

Now, for DNS you need:
1)  An (A) record for the IM server.
2)  Create a Host name of "im.domain.xxx" or an Alias.
3)  Add your _rvp resource record

Other than that, you need a home server and routing server (unless you are only using 1 server - then the home and routing server are one in the same).

By default IM uses Windows Integrated Authentication (WIA) and this will work fine if you do not need to cross a firewall.  If you do, you need to enable Digest Authentication.

Hope something here is of use to you.

0
 
Netman66Commented:
OK..to clarify # 2 above.

You need to create a Host or Alias record for the FQDN of "im.domain.whatever"

0
 
The_Master_ChiefAuthor Commented:
I am not using a proxy server but I am located in Las Vegas.   I am using a sonicwall firewall and I have a vpn to my office in NY.  Would I need to do something with the firewall?  It seems to me that when I try to sign in, it gets to the im server but can't authenticate.  I will try again tomorrow when I get into work.  I am just trying to set up instant messaging pretty much for fun.  For me and the other sys admins in NY.  
0
 
Fatal_ExceptionCommented:
Glad it is not mission critical...  :)

I may just play with it myself next week..  perhaps you can be the expert then and help me..  :)
0
 
Netman66Commented:
Ok, so you'll need to use Digest Authentication - search for that in the help files and make the necessary adjustments.

I would try to find some articles for you except I'm just about on the way out the door for a flight to Seattle.

Maybe FE can assist.

FE - his issue, the way I understand the Exchange book is that he'll need to get Digest Authetication working so it passes the firewall.  Perhaps you could check some sources for the correct method to enable it.  He should have a routing server (the one local to him in Vegas) and the home server in NY.  So the setup should be by the book for this scenario.  Maybe then he won't need Digest Auth since he will be routing off the local server.

I don't know what type of internet access I will have for the next week, but if I can, I will check in.

Good luck.

0
 
Fatal_ExceptionCommented:
Visiting Redmond, eh..??  

I will try to ck into it..  I am also leaving today, but just going to KY to ck out a job offer there..  Will try to ck back in to see how we are doing here though, as I can..  
0
 
The_Master_ChiefAuthor Commented:
Hey guys, I started from sctrach.  I set up a new web site, set up a new instant messaging virtual server, added the _rvp entry into DNS, and now it works.  I am able to log into messanger with my exchange account.  I didn't have to mess with the firewalls.

I don't know where the problem was, becasue it seemed as if I did exacty what I did before to set it up.  Anyways, to answer your question, the virtual messaging server does not have to be on the server running exchange 2000.  

I really don't know what I did wrong the first few times.  maybe I didn't alow enough time for everything to propegate before trying to log in.  I don't know.  But it is pretty straight forward and easy to set up.  Thanks for the info guys.
0
 
Fatal_ExceptionCommented:
Thanks for sharing the experience..   Am sure I will be reviewing this next week if I get a chance to install it in a test network..

Have a great weekend.

FE
0
 
The_Master_ChiefAuthor Commented:
I installed it on my network, but only enabled 3 people.  Myself and 2 other admins.  I know many businesses don't allow it, what are some of the security risks of running it?
0
 
Fatal_ExceptionCommented:
Basically it comes down to security..   IM opens ports that allow too many things into the system, and can become an admin nightmare if the users run amok with it...   Eats up bandwidth too...  but in your case, it should not be a problem..  If it is only being used by admins, they know what to do and what not to do..  :)
0
 
The_Master_ChiefAuthor Commented:
I was thinking of MAYBE giving access to  exchange messaging to the managers of my sites....maybe... but for now, just the admins.
0
 
Fatal_ExceptionCommented:
good idea to test it out first..  :)
0
 
Fatal_ExceptionCommented:
BTW:  I find that sometimes management is the scariest proposition when including users..  they think that they somehow know more than the rest of us who are paid to do know this stuff..  lol, eh..?
0
 
The_Master_ChiefAuthor Commented:
Isn't that the truth....silly managers :P
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

  • 8
  • 8
  • 5
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now