Solved

Can't open .smi files on Mac OS 8.5.1, don't seem to have Disk Copy installed.

Posted on 2004-04-02
21
3,671 Views
Last Modified: 2007-11-27
Can't open .smi files on Mac OS 8.5.1, don't seem to have Disk Copy installed.  Tried to download Disk Copy 6.3.3 from Apple but it is in .smi format, how do I insall Disk Copy without having Disk Copy installed already?
0
Comment
Question by:rogerperkins
  • 11
  • 10
21 Comments
 
LVL 30

Expert Comment

by:weed
ID: 10746619
.smi stands for Self Mounting Image. You shouldn't need Disk Copy to open it. My guess is that it's an incomplete or corrupt image and if the .smi downloaded form Apple doesn't self mount, you have something else wrong with your system.
0
 
LVL 2

Author Comment

by:rogerperkins
ID: 10746687
When I double click on the .smi file a message pops up saying cannot find the application that created .smi and then it gives me a list of programs to choose from to open the file with.  I have an imac.
0
 
LVL 30

Expert Comment

by:weed
ID: 10746691
Rebuild your desktop database by holding down command-option at startup until you see the Rebuild Desktop window.

.smi files are applications, they dont require another application to open them, so the error is...well...in error. A desktop database rebuild may clear it up.
0
ScreenConnect 6.0 Free Trial

Want empowering updates? You're in the right place! Discover new features in ScreenConnect 6.0, based on partner feedback, to keep you business operating smoothly and optimally (the way it should be). Explore all of the extras and enhancements for yourself!

 
LVL 2

Author Comment

by:rogerperkins
ID: 10748054
I hold down the button with a picture of an apple on it, and turn on the computer, I keep holding it down until it is all the way booted up but nothing happens.
0
 
LVL 30

Expert Comment

by:weed
ID: 10748076
command-option. Not one button, both keys. Gotta hold them both down.
0
 
LVL 2

Author Comment

by:rogerperkins
ID: 10748199
Okay, that brought up the rebuild thing, and I click Yes, but it didn't help.
0
 
LVL 30

Expert Comment

by:weed
ID: 10748236
And that applies to BOTH .smi images? Even the one from apple?
0
 
LVL 2

Author Comment

by:rogerperkins
ID: 10749593
Anything with an .smi extension it seems apple doesn't know what application to open it with, when I double click it.
0
 
LVL 30

Expert Comment

by:weed
ID: 10749902
Sounds like your machine needs some help. Maybe a run of Norton Disk Doctor or DiskWarrior.
0
 
LVL 2

Author Comment

by:rogerperkins
ID: 10750691
Oh, I forgot to mention that all the .smi files also have an associated .rsrc file with them.
0
 
LVL 30

Expert Comment

by:weed
ID: 10750695
Did you download these files to a PC then transfer them to a Mac?
0
 
LVL 2

Author Comment

by:rogerperkins
ID: 10750775
Yes, I downloaded them on a PC, uncompressed them with Stuffit, put them on a CD, and put them in the Mac
0
 
LVL 30

Accepted Solution

by:
weed earned 500 total points
ID: 10750820
Windows filesystems dont support resource forks. Resource forks are part of an application that contains vital data and is necessary for it to run. When you put a Mac app on PC, it gets rid of the resource fork because it doesnt know what to do with it. Suddenly your apps dont work anymore.

So, dont decompress the .smi images on a PC. Leave them compressed, and unstuff them on the Mac, then run the .smi.
0
 
LVL 2

Author Comment

by:rogerperkins
ID: 10750877
Okay, but it is funny because I can't install Stuffit703 on the Mac without OS 8.6 and I can't unstuff OS 8.6 without Stuffit703.
0
 
LVL 30

Expert Comment

by:weed
ID: 10750892
Then you need to go back to a version of stuffit expander that supports 8.5. We used stuffit back at 7.1 so there are versions that work on that machine. I dont remember which version of the OS started including Stuffit as part of the default install.
0
 
LVL 2

Author Comment

by:rogerperkins
ID: 10750899
I seem to have an older version of stuffit installed, but it won't open the archive, I will take another look.
0
 
LVL 2

Author Comment

by:rogerperkins
ID: 10753821
Okay, the stuffit I thought I had didn't run.  So I said forget and took the iMac into the living room and hooked it to the router, then download the update from mac.com directly to the iMac, when I did that I could run the file directly.  It's funny because I could install IE by downloading it to a CD from the PC and installing it on the Mac, but since I added more files to the CD on my PC I couldn't run any of them on the Mac  Now I'm having another problem, I moved the Mac back into the bedroom and now it won't even turn on, I think maybe a fuse blew, I checked the outlet.  I don't think it was because of the update.  Do you know where the fuse would be?
0
 
LVL 30

Expert Comment

by:weed
ID: 10753883
You could probably install IE because it was compressed in a way that didn't have a resource fork.
As for not turning on, check all the plugs, wall, and back of the machine. If you unplugged the machine while it was on you may have damaged something. May have damaged something in the moving process as well. The fuses are inside the power supply and would require a replacement power supply. That's something Apple would have to send you.
0
 
LVL 30

Expert Comment

by:weed
ID: 10759078
Reason for the B?
0
 
LVL 2

Author Comment

by:rogerperkins
ID: 10795673
I've tried to copy the compressed files to CD and extract them on the mac, but it doesn't recognize them either except for that one time when I loaded IE, so while your answer was very helpful, I'm still a little in the dark.  At any rate, it's a moot point now though unless I can get that thing to come back on.
0
 
LVL 2

Author Comment

by:rogerperkins
ID: 10798664
Good new the computer started working again, I just went over and pushed the button and it came on, maybe some capacitors discharged.
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Hi Folks, This article is intended to throw some light or basically give an idea towards taking the first step in the world of Systems Administration. This would in the real context of the word "Systems Administration" which would mean right from…
Are you looking to clear some space on your phone for the latest iOS 8 update? Did you switch to Spotify so you no longer need to keep music native on your phone? Run out of space for taking photos while in the middle of vacation? Sometimes the quic…
Users will learn how resize a batch of photos from a single command in Photoshop via Photoshop's Image Processor. Open up an Image you'd like to resize in Adobe Photoshop: Adjust the image size according to your preferences. Image > Adjustments > …
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

773 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question